Skocz do zawartości
fazi787

Prośba o sprawdzenie mojego schematu

Pomocna odpowiedź

Witam. Jestem w trakcie budowy robota linefollower. Na razie narysowałem schemat. Bardzo bym prosił o sprawdzenie czy nie ma tam żadnych błędów i czy wszystko jest ok.

Udostępnij ten post


Link to post
Share on other sites

Przy stabilizatorze nie masz +5V - elektrycznie nie jest połączony z resztą układu

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Myślę ,że nie ma sensu sprawdzać schematu pod kątem poprawności połączeń (wierzę że potrafisz je przerysować z not katalogowych). Jednak sam wygląd twojego schematu jest conajmniej nieestetyczny.

1. Poszczególne moduły są porozrzucane w chaotyczny sposób spróbuj je jakoś poukładać możesz je również otoczyć odrębnymi ramkami i opisać (to trochę strzelanie z armaty do muchy ale warto zadbać o czytelność)

2. Staraj się o ile to możliwe nie krzyżować połączeń robi się straszna plątaninina. A wierz mi że wodzenie palcem za synałem w celu zobaczenia jego połączeń jest rzeczą conajmniej irytującą.

3. Ostatnia rzecz urzywasz ATmegi 16 a niewykorzystujesz wielu z jej Pinów czy nie lepiej użyć mniejszego procesora lub też dołączyć większą ilość urządzeń ?

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Poprawiłem schemat. Mam nadzieję, że błędów już nie ma i, że jest bardziej czytelny.

Udostępnij ten post


Link to post
Share on other sites

dobrze jest tylko starał bym się żeby linie gnd były skierowane w dół

Udostępnij ten post


Link to post
Share on other sites

Dobra widzę że sobie dalej nie radzisz więc zdradzę ci sekret jeśli plączą ci się sygnały i robi ci się makaron (lewa storna procesora w twoim przypadku) kliknij na niego prawym przyciskiem myszy i wybierz opcje "Open symbol" otworzy ci się zakładka w której będziesz mógł poprzesuwać nóżki ATmegi sugeruje przesunięcie nóżek GND na dół symbolu a VCC/AVCC na góre pomiędzy ustaw VREF oraz XTAL1/2 to powinno pomóc pamiętaj jednak o dświeżeniu bibliotek przed ich ponwym użyciem !

Udostępnij ten post


Link to post
Share on other sites

Gdzieś uciekło GND przy programatorze.

Źle masz podłączony kwarc. Obie nóżki XTAL masz zwarte bezpośrednio do masy.

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Troszeczkę poprawiłem. Tolo dzięki za radę. AE teraz jest dobrze?

Udostępnij ten post


Link to post
Share on other sites

Wydaje się być ok, ale masz dużo wiszących nóżek, zajmij je czymś. ADC0 możesz wykorzystać do mierzenia stanu baterii (no chyba, że chcesz to zrobić na LM358), albo wykorzystać ten pin jako 8 czujnik. Dodałbym jakieś diody LED, więcej niż jeden switch, może jakiś buzzer itp.

Udostępnij ten post


Link to post
Share on other sites

no już jest trochę lepiej ale posiedź nad tym jeszcze trochę. Jako pomoc przysyłam obrazek mojego rozwiązania.

Zauważ że mój schemat zajmuje znacznie mniej miejsca oraz (jak mi się wydaje jest czytelniejszy)

Jeszcze sobie przypomniałem nie wiem gdzie chcesz kupić część ale spróbuj poszukać twz. Drabinek rezystorowych. Dlaczego ? Ponieważ bardzo upraszczają ścieżki i zmniejszają wymiary płytki.

Pzdr

Udostępnij ten post


Link to post
Share on other sites

Kwarc jest teraz ok 🙂

Udostępnij ten post


Link to post
Share on other sites

Witam ponownie. Nie chciałem zakładać nowego tematu a więc czy mógłby ktoś sprawdzić czy moja płytka pcb jest poprawna?

Udostępnij ten post


Link to post
Share on other sites

Małe czerwone kółka to miejsca gdzie prawdopodobnie wystąpią zwarcia po wytrawieniu.

Te dwa pod uC zwierają się nawet przelotkami...

Dużymi obszarami zaznaczyłem zawijasy które musisz poprawić - pamiętaj, że ścieżki powinny być jak najkrótsze!

Udostępnij ten post


Link to post
Share on other sites

Czy ty tego nie robiłeś automatem ?

Moje uwagi są następujące pomarańczowa obwódka: Naprawdę musisz ciągnąć te ścieżki przez całe PCB ? Przeciż ledy możesz podłączyć do którego kolwiek wolnego pinu

Żółta ścieżka : ten wygibas jest naprawdę potrzebny ? Po drugie musi być znacznie grubszy wogóle wszystkie ścieżki powinny być jak najgrubsze

Czerwona to samo

Nie wiem czy wiesz ale odrobina dobrej woli by wystarczyła aby zrobić tą płytkę bez żadnej zworki 😉

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...