Skocz do zawartości
Zaloguj się, aby obserwować  
Geezer

[Światłolub] L293D

Pomocna odpowiedź

Jak w temacie, czyli czy ten schemat jest prawidłowy i czy zdołam nim zaprogramować Attiny2313 bo głownie chodzi mi o naukę programowania.

Schemacik ma być zasilany baterią 9V (nie zaznaczone na schemacie). Oczywiście jest stabilizator który da napięcie 5V (jeśli wszystko dobrze zrobione)

Oto schemat:

Udostępnij ten post


Link to post
Share on other sites

To nie jest schemat, tylko projekt płytki.

Pokaż nam schemat to łatwiej będzie go ocenić.

Udostępnij ten post


Link to post
Share on other sites

Ten schemat nie jest prawidłowy bo to nie schemat 😋

Poza tym schematem nie da się zaprogramować procesora.

Jak rozumiem ma to być płytka do której się podłącza programator i programuje procesor.

Z układu ścieżek mogę stwierdzić jak narazie że po włączeniu spaliła by się dioda która jest przy złączu ISP oraz niezbyt dobre podłączenie resetu.

Ponadto nie rozumiem zastosowania C1, jak już to powinien to być ceramik 100n a nie elektrolit, ponadto nie rozumiem złącza "goldpin" oraz dołączonej do niego diody z dwoma (po co 2 ) rezystorami.

Poza tym jeśli robisz już złącza śrubowe przeznaczone na dołączanie czegoś do procesora to przydały by się także takie same wyjścia zasilania a chociażby masy.

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

A więc tak tu już jest schemat trochę różni się od projektu (sorki za wykonanie śpieszyłem się jak by co to jutro poprawie):

Nie mogłem znaleźć także tact switchy i umieściłem sam napis (i to z ortografem ale jutro poprawie)

na projekcie jest faktycznie kilka błędów (jestem początkujący). Goldpin miał mi służyć jako zapasowe zasilanie i dioda miała to sygnalizować (nie będę dokładniej tłumaczył bo to nie istotne dla mnie)

Diodę przy złączu ISP usunąłem (wiem że wystarczyło dać rezystor)

Jak powinno wyglądać połączenie reset skoro to nie jest zbyt dobre?

I rozumiem że jeśli reset będzie dobrze to już attiy2313 zaprogramuje?

Poza tym jeśli robisz już złącza śrubowe przeznaczone na dołączanie czegoś do procesora to przydały by się także takie same wyjścia zasilania a chociażby masy.

Rozumiem że chodzi o to iż np jak bym dawał diodę do ARK to drugi koniec muszę dać do GND. Masz racje i pomyśle nad tym już na końcu jak reszta będzie dobrze

Dzięki za pomoc

Udostępnij ten post


Link to post
Share on other sites

No od razu lepiej 😃 na takim schemacie można dużo łatwiej wychwycić błędy 😋

Jeśli chodzi o reset to zobacz jak to tu jest zrobione:

https://www.forbot.pl/forum/upload_img/obrazki/IMG_495b4fcbcb1f04451.jpg

Jest tam tylko mały błąd, w miejscu V--> Powinno być Reset czyli nóżka reset programatora, poza tym rezystor podciągający dał bym 10k.

Jeszcze taka uwaga co do diod to lepiej podłączać je do procesora jako aktywne stanem niskim, tzn. plus>rezystor<=>dioda>procek, gdyż porty procesora mogą bezpiecznie przyjąć więcej prądu niż wydać.

Jeszcze co do mojej wcześniejszej uwagi, przy nóżkach zasilania procesora warto umieścić jak najbliżej kondensator 100n ceramik.

Udostępnij ten post


Link to post
Share on other sites

Wprowadziłem poprawki i myślę że wszystko już powinno być ok

- Reset ze schematu który podałeś (10k OHM)

- diody odwróciłem (chyba o to chodziło prawda?)

- przy nóżkach uF ceramiki

- uwzględniłem także złącza śrubowe przeznaczone na masę.

Być może kiedyś będę pracował z kwarcem, więc dodałem miejsce na niego lecz na razie jest bez kwarcu. Nie zakłóci to pracy układu?

Jeśli potwierdzicie że wszystko jest dobrze to biorę się za projekt 🙂

Schemat:

Udostępnij ten post


Link to post
Share on other sites

Przy resecie brakuje ci węzła. Do tego wejście z wyjściem stabilizatora jest połączone.

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

🙄 eee no to poszalałeś tam miał być jeden kondenstator równolegle do zasilania a nie szeregowo z zasilaniem, przecież kondensator dla prądu stałego jest przewą więc to by nie miało w ogóle sensu.

Reszta wygląda oki (no poza tym co kolega wyżej napisał).

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

ok poprawiłem. Jeszcze tylko się upewnię. Ten węzeł to chodzi wam o połączenie ścieżek tą zieloną kropką? bo to właśnie uzupełniłem

I nic nie powiedzieliście o miejscu na kwarc więc domyślam się że nie będzie problemów

Dziękuje za pomoc i pozdrawiam 😉

Udostępnij ten post


Link to post
Share on other sites

Przy stabilizatorze też nie ma wezłów tam gdzie sa kondensatory i tam gdzie w stabilizatorze jest input i output jest linia ciagla chyba je podlaczyłeś co dana wyjściu 9v.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

Zaloguj się, aby obserwować  

×
×
  • Utwórz nowe...