Skocz do zawartości
Komentator

Kurs elektroniki - #7 - tranzystory w praktyce

Pomocna odpowiedź

@eriq9 coś tu jednak chyba pomieszałeś. Zerknij na grafikę podpisaną w kursie jako "Często używane klucze tranzystorowe NPN i PNP". Zobacz jak wygląda tam podłączenie - zwróć uwagę, gdzie w symbolu tranzystora jest emiter, a gdzie kolektor. Zobacz też jak podłączona jest dioda. U Ciebie jest trochę inaczej 😉

Udostępnij ten post


Link to post
Share on other sites

mam takie nurtujące mnie pytanie dlaczego dioda w ogóle świeci. Z jednej strony wpięta jest do + a z drugiej również mamy + z kolektora. Jedyne podłączenie do masy (-) widzę na emiterze. Chodzi mi o przykład "Test tranzystora NPN w praktyce". Moje rozumowanie jest oparte na płynącej wodzie (cieczy).

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

@2ara2a możesz wyobrazić to sobie jak zawór w pionie. Odkręcasz zawór to woda płynie.

14 godzin temu, 2ara2a napisał:

również mamy + z kolektora

Plus w tranzystorze to chyba nie najlepsze określenie. Częściej (tak jak w kursie) są zaznaczane strzałki informujące o potencjale względem emitera. W dalszej części kursu jest informacja o współczynniku betta, wzmocnieniu które wiąże prąd wpływający do bazy z prądem jaki może wpłynąć do kolektora.

Prąd ten przepływa przez diodę, złącze w tranzystorze i "wypływa" do masy.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Witam, 

Mam ciekawy problem, który polega na tym że jakkolwiek bym nie podłączał schematu z tranzystorem pnp to dioda nie świeci, można powiedzieć że cały układ nie działa ponieważ nie płynie żaden prąd, 

Warto dodać że układ montowałem na wiele różnych sposobów, zmieniałem tranzystory, diody, kable, rezystory, baterie, zmieniłem otwory na płytce stylowej i dalej dioda nie świeci (oczywiście wpięta jest poprawnie, ale dla pewności nawet sprawdzałem podpięcie jej na odwrót co jak łatwo się domyśleć nie dało efektu), prądów brak, napięcia na rezystorach i diodzie się nie odkładają, jedyne napięcia to między bazą a emiterem 8.95V i między kolektorem a emiterem 7,37V. 

Poniżej zdjęcia ukazujące mój problem IMG_20191125_013518.thumb.jpg.fbef43f248a0d473a70bbfe0ce182daa.jpgIMG_20191125_014611.thumb.jpg.e8464c6a77726d7a02cb671ff1b8c886.jpg

Dodam też że układ z tranzystorem typu npn działa co testowałem na kilka sposobów, poniżej przykład

IMG_20191125_014806.thumb.jpg.11021b3c9b6298ac0c8ba848a5fa39cf.jpg

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

@marekes97 witam na forum!

Fajnie że ambitnie podchodzisz do tematu, super!

Tranzystorów lepiej nie podłączać na wszelkie możliwe sposoby, bo można coś uszkodzić, a później na wszelkie inne sposoby nie będzie działać.

Możliwe, że problem polegał na pinoucie - choć jest on identyczny co w NPN to w tej konfiguracji musisz obrócić tranzystor tak ty emiter był przy +, jeżeli zmontujesz układ dokładnie jak na schemacie to będzie działać - przynajmniej jak to mawia informatyk "U mnie działa." 😄 

Na pierwszym podłączony do minusa - świeci, na drugim do plusa - nie świeci.

IMG_7053.thumb.jpg.d650275f1d05d414729d175fa4755313.jpgIMG_7054.thumb.jpg.9bd66f558eb07234c4fb06b1d3db1d82.jpg

 

Edytowano przez Gieneq
  • Lubię! 2

Udostępnij ten post


Link to post
Share on other sites

Dziękuję za szybką odpowiedź! 

Podłączyłem dokładnie tak jak Ty i mimo że wziąłem nowiutki tranzystor wcześniej nie używany (model też jak w kursie BC546) to dalej dioda (też nowa) nie świeci, co pokazuje na zdjęciu poniżej, no cóż może jakie zepsute tranzystory dostałem... Haha 

No cóż po dwóch dniach siedzenia nad tym problemem myślę że czas pójść dalej, wcześniej szło gładko bo po mam teoretyczne podstawy po elektronice, elektrotechnice i technice cyfrowej które miałem na 1 roku na studiach 😄

 

IMG_20191125_102844.jpg

Udostępnij ten post


Link to post
Share on other sites

Wiesz co jeszcze możesz sprawdzić czy kabelki stykają, weź multimetr w trybie pomiaru ciągłości i sprawdź czy sprawdź końce kabelków nawet wetkniętych w płytkę. Różnie bywa 🙂 

Udostępnij ten post


Link to post
Share on other sites

Problem rozwiązany !

Błędem okazało się to że do układu podpinałem tranzystor wykorzystany na pomiarach w kursie czyli BC546, w pracy domowej powinno być napisane żeby wziąć inny model (BC556), bo przed kursem myślałem że każdy tranzystor bipolarny jest albo npn albo pnp, a podczas kursu pomyślałem że ten jest jakiś uniwersalny, 

Teraz dla BC556 jak widać układ działa

bc556.thumb.jpg.aae870a8ea7e7557f374eb96eca67e9e.jpg

Pomiary wyglądają prawidłowo 😄 

Ib = 0,81 mA

Ic = 6,67 mA

Uce = 0,03 V

Ube = 0,73 V

Dla napięcia na baterii równo 9 V 

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

No tak, tranzystory NPN i PNP choć są podobne to mają inną budowę.

8 minut temu, marekes97 napisał:

pomyślałem że ten jest jakiś uniwersaln

Dobry pomysł, może kiedyś wymyślą - tranzystor uniwersalny 😅 Fajnie, że się wyjaśniło, powodzenia w dalszych eksperymentach.

PS. raczej możesz wyciągnąć rezystor przy diodzie i się nie spali (ja zapomniałem i działało), dlaczego, to zadanie dodatkowe. 😉 Ale w innych sytuacjach nie próbuj.

Udostępnij ten post


Link to post
Share on other sites

Dokładnie przestudiowałem treść lekcji o tranzystorach i interesuje mnie jedna kwestia. W jaki sposób obliczono, że do buzzera, który pobiera 50mA potrzebny jest rezystor 10k, a do odbiornika pobierającego 500mA należy zastosować rezystor 1k? Czy moje rozumowanie, że rezystor musi tak zmienić natężenie prądu na bazie, aby pozostał on na tyle duży, że po uwzględnieniu wzmocnienia na kolektorze pojawi się oczekiwana wartość. (50mA w przypadku buzzera i 500mA w przypadku innego przykładowego urządzenia)

Czy jeśli pomyślę o tym w taki sposób:

Arduino maksymalnie może zasilać natężeniem 20mA, napięcie w układzie to 5V to z prawa Ohma wychodzi, że najmniejszy możliwy rezystor bezpieczny dla Arduino to 250 omów.

To będzie to dobry tok rozumowania?

Czy dzięki temu tranzystor, który został omówiony w lekcji (zakładając, ze jego współczynnik β to uśrednione 300) wygeneruje na kolektorze maksymalnie 6A?  (20mA * 300 = 6000mA = 6A)

 

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Analizuję temat w głowie i mam jeszcze jedno pytanie.

Czy jeśli pin z Arduino podłączymy do bazy jako sterowanie (przez rezystor, tak jak pisaliśmy wcześniej) natomiast do emitera podłączymy zasilanie z zasilacza np. 12V (tranzystor PNP) to do obliczania wzmocnienia weźmiemy pod uwagę 4.3V z Arduino czy 12V z zasilacza? A może obie te wartości?

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...