Skocz do zawartości
Phil

Szumy na wyjściu cyfrowego sharpa 40cm

Pomocna odpowiedź

No więc sprawa wygląda tak: mam płytkę z 4 czujnikami sharp GP2Y0D340K, 3 z nich działają prawidłowo, jeden jak się okazuje ma pewien defekt. Niby działa jak powinien: gdy wykryje przeszkodę daje odpowiedni stan na wyjściu, ale gdy nic przed nim nie ma to ma tendencję do nagłych zmian stanów na wyjściu. Podłączony jest jak w nocie katalogowej. Wykluczyłem winę mikrokontrolera, którym odczytuję stan, podłączając czujnik do różnych nóżek. Dodałem dodatkowy kondensator 100nF na zasilaniu, bez efektów. Co może być przyczyną? Mam nadzieję, że nie jest to wrodzona wada... tych czujników już chyba nigdzie nie dostanę, a zawody się zbliżają wielkimi krokami 😐

Udostępnij ten post


Link to post
Share on other sites

Czy jest możliwe, by pola widzenia dwóch czujników zachodziły na siebie? W szczególności czy jakiś inny czujnik tego samego typu świeci swoją diodą IR w stożek widzenia tego felernego albo co gorsza prosto mu "w oczy"?

Udostępnij ten post


Link to post
Share on other sites

Czujnik jest ustawiony prostopadle do innych, nie ma możliwości, żeby tak świecił.

Udostępnij ten post


Link to post
Share on other sites

Uszkodzony rezystor 1Ω?

Zimne/niepewne lutowanie czujnika, rezystora, kondensatora?

Uszkodzona ścieżka? Sprawdź 5V wprost na nóżkach 1-4 czujnika. Sprawdź połączenie masy między nóżką 4 czujnika a masą procesora/zasilania.

Zobacz woltomierzem jak wygląda napięcie na wyjściu. Czy w stanie ustalonym jest prawie 5V a w stanie 100% detekcji przeszkody jest prawie 0V?

Czy te dziwne impulsy mają jakąś korelację z dotykaniem płytki, poruszaniem czujnikiem itp?

Udostępnij ten post


Link to post
Share on other sites

Rezystor sprawny, dla pewności wymieniłem, bez zmian. napięcie na nóżkach czujnika wynosi +/- 4.8V, chyba nie powinno robić problemu. Połączenia sprawdzone, są ok. W stanie detekcji na wyjściu jest blisko 0V, w stanie ustawionym ok. 4.8V. Napisałem program, który mi filtruje te impulsy, będę musiał to chyba jakoś przeżyć...

Udostępnij ten post


Link to post
Share on other sites

a masz po kondensatorze 47+uF na zasilaniu na każdy czujnik?

SHARP dosyć niefortunnie dodał ten zapis do noty, bo przy schemacie o nim nic nie ma, ale na 6 stronie jest o nim informacja. Bez niego różne rzeczy potrafią się dziać w układzie.

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Hudyvolt, nie miałem takiego, dodałem 3x22uF równolegle przy "wadliwym" czujniku i szumy pozostały, ale się znacznie zmniejszyła ich ilość i częstotliwość. Dodałem jeszcze jedną taką "baterię kondensatorów" przy sąsiadującym czujniku i zdaje się że zanikły totalnie. Dodam jeszcze przy dwóch pozostałych na wszelki wypadek.

Wnioski:

-dobre filtrowanie kluczem do sukcesu

-należy wczytywać się głębiej w notę katalogową

Dzięki wielkie Wam za pomoc i zainteresowanie się tematem 🙂

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...