Skocz do zawartości
Komentator

Kurs elektroniki II - #7 - scalony odbiornik podczerwieni

Pomocna odpowiedź

Nie masz podłączonego zasilania na odwrót? Lewa nóżka (na zdjęciu) to GND, a patrząc po sposobie podłączenia kondensatora elektrolitycznego masz tam + zasilania.

Udostępnij ten post


Link to post
Share on other sites

Lukaszm, Nie, jest tam minus zasilania a kondersator te jest dobrze podłączony.

Udostępnij ten post


Link to post
Share on other sites

Racja.

Jeżeli wszystkie połączenia i zasilanie są ok, a w pobliżu nie ma nadajnika odpowiedniego sygnału (może monitor zakłóca pracę układu?), to jedynym wyjaśnieniem pozostaje uszkodzenie układu.

Masz inny układ, żeby przetestować działanie?

Udostępnij ten post


Link to post
Share on other sites

Mam nadzieje że się nix nie zepsuło, co mogło by hszkodzić taki układ?

Mam nadzieje że ciś zakłucało, zapomniałem dodać że. Zasami świeci czasami nie ale sprawdze to jutro

Udostępnij ten post


Link to post
Share on other sites
Mam nadzieje że się nix nie zepsuło, co mogło by hszkodzić taki układ?

Najczęściej odwrotne podłączenie zasilania lub przekroczenie dopuszczalnego napięcia zasilania.

Udostępnij ten post


Link to post
Share on other sites

CyanFox, zacznijmy od tego czy masz odpowiedni odbiornik - korzystasz z naszych zestawów, czy sam kompletowałeś elementy? Pytam, ponieważ nie widzę, abyś miał zarejestrowany zestaw do tego kursu. Źle dobrany odbiornik to pierwszy możliwy powód Twojego problemu 🙂

Udostępnij ten post


Link to post
Share on other sites

Witam,

Mam następujący problem. Złożyłem układ według schematu, jednak odbiornik nie działa prawidłowo. Mianowicie dioda świeci przez cały czas. Gdzie może być błąd?

Udostępnij ten post


Link to post
Share on other sites

Platinu, witam na forum 🙂 Przyciąłem i zmniejszyłem trochę Twoje zdjęcia - teraz zamiast 9MB ważą 200kB. To tak tylko informacyjnie, na przyszłość warto zmniejszyć pliki przed wysłaniem.

Jeśli chodzi o Twój układ to mam wrażenie, że jednak podłączyłeś go źle. Zwróć uwagę na podłączenie odbiornika TSOP na naszych zdjęciach. Zawróć uwagę na opis odbiornika z kursu: "Patrząc od przodu, po lewej pierwsza jest masa, środkowa nóżka to dodatnie zasilanie, a skrajne prawe wyprowadzenie to wyjście naszego odbiornika". U Ciebie dioda podłączona jest do nóżki środkowej, a powinna być do skrajnej. Podłączyłeś układ zapewne tak jak jest to na schemacie (tam środkowa to wyjście). Pamiętaj jednak, że schemat to jedynie symboliczne przedstawienie całego obwodu. To jak dokładnie rozmieszczone są wyprowadzenia trzeba sprawdzić w nocie katalogowej, co było wspomniane w kursie:

Udostępnij ten post


Link to post
Share on other sites

@jas123 wydaje mi się, że jednak błąd polega na błędnym połączeniu układu. Zerknij na post wyżej - udzieliłem tam porady w identycznej sytuacji. Zwróć uwagę na opis wyprowadzeń TSOPa z noty katalogowej - tego trzeba się trzymać. Opis wyprowadzeń na schemacie ideowym nie ma tutaj znaczenia i nie można się nim sugerować (to tylko symbol).

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

@jas123 super, powodzenia w dalszych eksperymentach 😉 Trzeba zwracać uwagę na takie drobiazgi, bo często symbol na schemacie jest oderwany od rzeczywistości 😉

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Witam, początkowo miałem problem z układem złożonym według podanego schematu, dioda wcale nie reagowała na działanie pilota. Uznałem, że sprawdzę napięcie zasilania odbiornika i okazało się, że wynosi 5,7V. Na szczęście wyczytałem z noty, że maksymalne napięcie które nie powinno uszkodzić układu wynosi 6V i faktycznie układ jak się później okazało był sprawny. W celu obniżenia napięcia zastosowałem zamiast rezystora 100Ohm rezystor 1k i układ zaczął działać jak powinien (wtedy spadek napięcia na rezystorze wyniósł 0,3V i napięcie spadło do 5,45V), w czasie testów nie wiem z jakiego powodu, ale i ten układ potrafił nie działać, wtedy sprawdziłem z ciekawości rezystor 10k w tym miejscu i układ działał prawidłowo (napięcie na zasilaniu odbiornika wynosiło wtedy ok. 3V, więc mieściło się w przedziale). Co ciekawe kiedy sprawdziłem jeszcze raz rezystory 1k i 100Ohm układ w obu przypadkach działał prawidłowo (mimo napięcia zasilania odbiornika wynoszącego 5,7V przy rezysotorze 100Ohm). Spadek napięcia na diodzie prostowniczej wynosił u mnie 0,6V, napięcie z koszyka z bateriami 6,4V. Do tego zmierzyłem prąd jaki pobierał mój odbiornik i było to 0,33mA (w nocie typowa wartość to 35mA). Dodam, że jestem począkującym i piszę tu tylko o swoich doświadczeniach, które mam nadzieję, że mogą pomóc przy podobnych problemach. 

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Witam

Zmontowałem układ z odbiornikiem podczerwieni i przetestowałem sobie domowe piloty... przy okazji wyjaśnił mi się problem jednego z nich który wymagał bliskiej odległości od odbiornika. Okazuje się że faktycznie zamontowany w nim nadajnik IR ma bardzo niewielki kąt padania promieniowania podczerwonego a dodatkowo sam nadajnik jest małej mocy. Ciekawe ćwiczenie i można było sprawdzić jak rozchodzi się promieniowanie podczerwone w domowych warunkach i z różnych odległości (zjawiska takie jak odbicie, załamanie promieniowania, itd). Odkryłem jednak coś czego do końca nie rozumiem. Gdy miałem włączony układ i pracowałem na laptopie zauważyłem że gdy w pobliżu odbiornika znajdzie się myszka bezprzewodowa zaczyna świecić dioda. Wydawało mi się że komunikacja myszka optyczna - PC odbywa się po Bluetooth, jednak ewidentnie obserwuje odbieranie sygnału przez zmontowany odbiornik. Czy to jakieś zakłócenia? Dodam że najlepiej widać świecenie jak podniosę myszkę i podstawię część optyczną pod odbiornik. Machając palcem między nimi uaktywniam myszkę i wtedy układ coś odbiera.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Pamiętaj o tym, że o ile komunikacja myszki odbywa się po bt (czy nawet kablu), o tyle same przesunięcia myszki odczytywane są poprzez detekcję światła odbitego od stołu, przy czym moc diody oświetlającej w myszce jest stosunkowo duża. Światło odbija się od podłoża, gdzieś tam świeci na boki... a odbiornik po prostu wykrywa jakiś modulowany sygnał którego co prawda nie rozumie (bo żadnej informacji tam nie ma), ale daje znać że coś odbiera. Przy czym filtry podczerwieni w odbiorniku przepuszczają częściowo czerwone światło diody.

Proponuję jako ćwiczenie skonstruowanie nadajnika, i spróbowanie zastosowania w nim zamiast diody na podczerwień zwykłych diod led, a nawet czerwonej diody laserowej.

  • Lubię! 1
  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...