Skocz do zawartości
fazi787

TB6612FNG - spalony

Pomocna odpowiedź

Witam, mam problem z mostkiem TB6612FNG. Podaje schemat oraz płytkę:

Problem polega na tym, że wyjścia SILNIK 1A, 1B, 2A, 2B czyli te do silników są spięte z masą. Wszystko było w porządku, nie było żadnych spięć, robot jeździł aż nagle silniki przestały działać. Wtedy od razu sprawdziłem miernikiem i te wyjścia są wspólne z masą, mimo, że na płytce nie ma żadnych spięć. Wymieniłem mostek na nowy, znów wszystko było w porządku aż nagle stało się to samo. Wygląda na to, że mostek się spalił, tylko dlaczego tak nagle i dlaczego wszystko działało przez dobre kilka dni? Spotkał się kiedyś ktoś z czymś takim?

Udostępnij ten post


Link to post
Share on other sites

A jakie to silniki i czy masz tam gdzieś diody zabezpieczające przed prądem zwrotnym wyindukowanym w nich?

Udostępnij ten post


Link to post
Share on other sites

Silniki to pololu 30:1, nie nie mam diod zabezpieczających.

Udostępnij ten post


Link to post
Share on other sites

To nie musi być problem schematowo-sprzętowy, choć te cieniutkie ścieżynki idące naokoło całej płytki z których zasilany jest akurat największy pożeracz prądu są dość pocieszne. Pin VCC mostka nie ma żadnego blokowania pojemnością, bo mimo że na schemacie narysowałeś C12 tuż obok, to już na PCB wstawiłeś go gdzieś od czapy między cienką ścieżkę Vcc a jakąś masę, która z masą mostka ma niewiele wspólnego. Jeśli już wylewasz masy na obu stornach płytki, daj ze sto przelotek łączących obie powierzchnie w jak największej liczbie miejsc. Najlepiej narysuj sobie którędy masa C12 łączy się z masą mostka - sam widzisz... Równie dobrze tego 100nF może nie być w ogóle.

No ale chciałem o czymś innym. O życiu mostka decyduje też program. Jeżeli silniki są tylko trochę słabsze (dobrane np. na 50%) od możliwości drivera a sterujesz nimi w sposób "siłowy" zupełnie spokojnie możesz przekroczyć dopuszczalne parametry. Sprawdź w kodzie czy możliwe są sytuacje gdy jedziesz w jedną stronę a za chwilę dajesz w drugą bez chwili przerwy na stop. Wszelkie gwałtowne zmiany wysterowania PWM (już nie mówiąc o kierunku) generują w silnikach wielkie przepięcia. Jeżeli silnikami sterujesz głównie przez zmiany kierunku (linie SILNIK 1A itd.) bez żadnych łagodnych zmian PWM od max do zera i znowu do max w drugą stronę, mostek przeżywa tylko dzięki szczęściu.

Kolejna sprawa to napięcie. Im niższe, tym tranzystory mostka bardziej się grzeją. Nie widzę na schemacie żadnego układu pomiaru napięcia akumulatora. Czy jesteś pewien, że zawsze masz taki zapas, by szyna +5V miała zawsze właśnie tyle?

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

marek1707, dzięki za odpowiedź. Jeśli chodzi o kod to jestem spokojny, nie steruje silinkami nagle i gwałtownie. Co do schematu, owszem popelnilem wiele błędów, teraz nic na to nie poradze, jest nauczka na przyszłość. Bardzo dbam o pomiar akumulatora ale możliwe, że zdążyło mi się podpiac rozładowany. Teraz zauważyłem i dodam, że te wyjścia podpinane do silników to tylko albo aż trzy są spięte z masą, jeden jest w porządku. Taki mostek oczywiście już nie biedzie działał?

Udostępnij ten post


Link to post
Share on other sites

Oczywiście mierzysz bez silników i bez zasilania? No tak, mostek ze zwartym wyjściem do masy raczej działać dobrze nie będzie. Jeżeli jedno wyjście jest OK, to to jedno wyjście pewnie jeszcze działa, ale zostaje tylko sterowanie jednym silnikiem w jedną stronę (drugi koniec silnika do masy lub do plusa). Pozostałe wyjścia, żeby nie załączać ich górnych tranzystorów (bo wtedy masz zwarcie plusa z masą) trzeba wysterować na zero. Ale sumie to nie wiem czy jest co ratować. Skoro spaliły się aż trzy półmostki to nie wiadomo co zostało z tego czwartego.

Jakie tam masz silniki w robocie?

Udostępnij ten post


Link to post
Share on other sites

Oczywiście, mierze bez silników i bez zasilania, uzywam silników pololu. Czyli zostało tylko wymienić mostek na nowy?

Udostępnij ten post


Link to post
Share on other sites

Hm, jakby Ci to delikatnie powiedzieć żeby nie zmartwić, ale i nie skłamać... tak 🙁

Udostępnij ten post


Link to post
Share on other sites

Ok to w takim razie będę wymieniał na nowy. Mam nadzieję, że w przyszłości będę bardziej czujny przy projektowaniu układów no i, że ten mostek tak szybko juz sie nie spali.

Udostępnij ten post


Link to post
Share on other sites

Dobrze byłoby zwrócić uwagę na ten fragment. Nadzieja rzadko kiedy pomaga w takich przypadkach. OK, można liczyć, że to było jakieś przypadkowe zwarcie, kabelek plusowy albo silnikowy gdzieś się omsknął i tyle, ale jeśli możesz wykluczyć takie zdarzenie, to zabierz się do pomiarów. Wlutuj nowy mostek - bez tego się nie obejdzie, potem przyciągnij regulowany zasilacz i oscyloskop (bez tego także będzie ciężko) i pochyl się. Jeśli nie masz sondy prądowej to szeregowo z silnikami włącz mały rezystor (<1Ω) i w trybie różnicowym badaj prąd. Musisz wymęczyć układ tak, by wiedzieć kiedy zbliżasz się do granicy. Zmieniaj napięcie zasilania a program niech robi różne dziwne rzeczy z napędami. Zmierz przepięcia na wyjściach mostka, na zasilaniu itp w różnych stanach: startu, stałej jazdy, hamowania, zmiany kierunku itd. Sprawdzaj też (nawet palcem) temperaturę - gdy zaczyna parzyć to raczej niedobrze. W końcu wyjdzie. Jeśli coś siedzi w układzie lub programie, musisz to znaleźć albo nigdy nie będziesz już pewny działania tej konstrukcji.

Udostępnij ten post


Link to post
Share on other sites

marek1707, Dzięki, cały czas testuje według Twoich rad, zobaczymy co się okaże. W sobote są zawody więc będę musiał wziąć w nich udział na ,,ryzyku".

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...