Skocz do zawartości
Komentator

Kurs STM32 F4 - #10 - Obsługa SPI, wyświetlacz OLED

Pomocna odpowiedź

Cześć, w kursie przy sekcji o dołączaniu do biblioteki jest napisane:

Cytat

Zawartość inc przekopiujemy więc do folderu .../07_SPI_OLED/Inc, a zawartość src do folderu .../07_SPI_OLED/Src.

Problem w tym, że zaimportowany projekt nie zawiera tych folderów, są w folderach "wyżej". Nawet w zaprezentowanych sposobach dodawane są tylko dwa pliki (Fonts.c i SSD1331.c) do katalogu User

Z kolei w załączniku z paczką projektu już w folderach jest prawidłowo porozmieszczane.

Mógłby ktoś wyjaśnić dlaczego do Project Explorera są ładowane tylko podfoldery?

Udostępnij ten post


Link to post
Share on other sites

Możliwe, że to jakiś problem wynikający z aktualizacji środowiska. Jakiś czas temu była aktualizacja, która trochę namieszała. Możliwe, że projekty z poprzedniej wersji z jakiegoś powodu są importowane błędnie. Udało Ci się rozwiązać ten problem, czy nie możesz uruchomić przykładów?

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Witam,

Mam taki problem, że po wgraniu kilka razy programu z Państwa kursu na płytkę wyświetlacz przestał mi działać. Zero reakcji na wyświetlaczu. Ktoś kiedyś spotkał się z takim problemem?

Edytowano przez marville
Post widoczny jako ukryty, nie wiem dlaczego.

Udostępnij ten post


Link to post
Share on other sites

@marville witam na forum 🙂

Wgrywanie programu na płytkę nie powinno w żaden sposób wpłynąć na działanie wyświetlacza. Czy sprawdziłeś dla pewności wszystkie podłączenia, może przypadkiem coś przestało stykać. Nie przypominam sobie, aby ktokolwiek napotkał wcześniej na tego typu problem.

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

@Treker  Dzięki 🙂 Głupia sprawa ale miałeś rację. Dorwałem dzisiaj miernik i rzeczywiście było przerwanie na lini MOSI 😄

Dziękuję!

Udostępnij ten post


Link to post
Share on other sites

@marville super, powodzenia w dalszych eksperymentach 🙂

Udostępnij ten post


Link to post
Share on other sites

Witam,
pobrałem program jednak przy kompilacji wyskakują błędy, czy ktoś jest w stanie mi powiedzieć w czym tkwi problem?

Bez tytułu.png

Udostępnij ten post


Link to post
Share on other sites

@mikowal91 witam na forum 🙂 Czy poprzednie przykłady z kursu kompilowały się u Ciebie bez żadnych problemów?

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij, aby zacząć pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...