Skocz do zawartości
motorider

Dioda pulsuje po podłączeniu zasilacza

Pomocna odpowiedź

Dioda świeci prawidłowo tylko gdy Arduino podłączone jest do USB, gdy odłączę USB i podepnę zasilacz 12V 2.1A dioda zaczyna migać/pulsować. W czym może tkwić problem?

Schemat połączenia

Arduino_01_01-300x239.png

void setup() {
 pinMode(8, OUTPUT);
 digitalWrite(8, HIGH);
}

void loop() {
}

Udostępnij ten post


Link to post
Share on other sites

Zasilacz podłączyłeś do Vin, nie do 5V przypadkiem?

Udostępnij ten post


Link to post
Share on other sites

Zasilacz podpiąłem wtykiem DC 5,5 / 2,1 mm bezpośrednio do gniazda płytki Arduino. To tak nie działa?

Udostępnij ten post


Link to post
Share on other sites

Dziwne, dioda pulsuje bo prawdopodobnie procesor się resetuje a taki efekt dostaniesz gdy jest problem z poziomem zasilania na linii 5V. Masz kilka możliwości i w wielu jest coś nie tak z zasilaczem:

- Zasilacz jest inny niż uważasz, że jest (np. 3.3V/10A lub 12V/0.1A),
- Zasilacz jest uszkodzony i ma dużo mniejszą wydajność prądową lub daje jakieś przypadkowo małe napięcie lub też samodzielnie wyłącza się i restartuje,
- Zasilacz ma tę cechę, że bez porządnego obciążenia nie działa stabilnie. Słabiutkie Arduino nie dociąża go wystarczająco (tj. pobiera za mały prąd) i napięcie jest co jakiś krótki czas wyłączane. Zobacz, czy migotanie ustanie gdy podłączysz oprócz Arduino żarówkę samochodową 12V/5W. Jeżeli wszystko zdechnie kompletnie, to zasilacz jest do kosza.

- Uszkodzona wtyczka zasilacza, jego kabelek lub gniazdko na Arduino. Jeśli migotanie nie jest bardzo powtarzalne a zależy od poruszania kabelkami i wtyczkami, to problem może być czysto połączeniowy. Może problemy z kontaktami na płytce stykowej?

Gdy obserwujesz zjawisko migotania spróbuj zmierzyć napięcie zasilacza na płytce Arduino. Zobacz jak przylutowane jest gniazdko i podłącz się sondami woltomierza wprost do punktów lutowniczych gniazdka. Zmierz też napięcie zasilania procesora, oczekiwane jest 5V±0.2V.

Udostępnij ten post


Link to post
Share on other sites

Podłączałeś żarówkę i co? Miałeś sprawdzić, czy zwiększone obciążenie poprawia pracę zasilacza, czyli podpiąć jednocześnie Arduino i jakiś "cięższy" odbiornik prądu z jednoczesnym pomiarem napięcia. Eksperymenty nie są po to by je wykonywać na bezdurno i za chwilę o nich zapominać tylko żeby wyciągać z nich naukę. A jeśli masz jakieś nowe wyniki lub obserwacje to je szczegółowo opisuj. Tylko na tej podstawie możesz dostawać kolejne porady - nie będziemy przecież sypać jak z rękawa kolejnymi pomysłami. Możemy jedynie opierać się na tym co napiszesz nowego. Nikt nie lubi zgadywać w ciemno.

Jeżeli napięcie zasilacza w tych warunkach (czyli Arduino + żarówka (jaka? - tego też nie napisałeś)) jest OK to znaczy, że problemy ma sama płytka. Może mechanicznie jest uszkodzone samo gniazdo DC, może stabilizator albo jego lutowanie a może problem jest jakiś trywialny tylko go nie widzimy. Spróbuj np. dla odmiany pomrugać diodką wbudowaną w Arduino - kod nie jest dużo bardziej skomplikowany. Ona na pewno jest dobrze podłączona i działa.

Zmierzyłeś napięcie zasilania procesora? Musisz badać to metodycznie, robić pomiary i wyciągać wnioski a jeśli nadal nie wiesz o co chodzi, opisywać wszystko co zrobiłeś i co zauważyłeś tutaj. Opisałem Ci kilka możliwości. Opowiedz która wciąż jest prawdopodobna a którą już odrzuciłeś. I niczego nie zakładaj. Po to masz sprzęt pomiarowy i głowę na karku by wszystko od początku do końca weryfikować a dalsze eksperymenty planować na wynikach poprzednich. Zasilacz może być uszkodzony dokładnie tak samo jak Arduino, płytka stykowa, gniazdka, wtyczki czy nawet kabelki.

Udostępnij ten post


Link to post
Share on other sites

Dzięki za wskazówki. Chwilowo nie mam miernika więc do dalszych testów wrócę dopiero za kilka dni. Do tej pory sprawdziłem:

- podpięcie żarówki 12V 5W do zasilacza. Wynik bez zmian, dioda nadal pulsuje

- miganie diodą na Arduino. Wynik, dioda nawet się nie włącza, ale dioda ON na płytce świeci

Udostępnij ten post


Link to post
Share on other sites

Wykonałem pomiary, na wyjściu z gniazda zasilania na płytce mam 12V, ale na wejściu stabilizatora napięcia już tylko 2.2V. Czy mogę prosić o podpowiedź co znajduję się pomiędzy?

Udostępnij ten post


Link to post
Share on other sites

Dzięki, ale ten schemat już widziałem wcześniej, niestety nie znam się na elektronice i nie potrafię go zrozumieć.

Udostępnij ten post


Link to post
Share on other sites

motorider, to jak chcesz dokonać naprawy? Prawdopodobnie wcześniej została uszkodzona jakaś część odpowiedzialna za zasilanie bez konkretów ciężko typować, gdzie jest problem. Sprawdź jeszcze jaki prąc pobiera całe Arduino podczas zasilania z zasilacza. Może pojawiło się gdzieś zwarcie?

Przy okazji polecam serię artykułów o budowie Arduino:

Arduino, co w środku piszczy – #1 – schemat

Udostępnij ten post


Link to post
Share on other sites

To fajnie, ale ciekawe co go zabiło? UNO ma diodę na wejściu z zasilacza, więc raczej nie odwrotna polaryzacja. Już prędzej napięcie, ale wtedy zwykle tranzystor szeregowy przebija się na zwarcie i z dymem idzie cała reszta. W każdym razie zmierzyłbym dla pewności napięcie zasilacza. Niektóre tańsze sztuki mają znamionowe napięcie (np. 12V) dopiero przy znamionowym obciążeniu (np. 1A), w "luzem" to i 16V może być.

Udostępnij ten post


Link to post
Share on other sites

Sprawdzałem zasilacz, daje 12 V nawet bez obciążenia. Stabilizator musiał paść z mojej winy, płytka stykowa, plątanina kabli, coś gdzieś zrobiło zwarcie i taki jest efekt.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...