Skocz do zawartości
ps19

Proszę o sprawdzenie PCB,SCHEMATU

Pomocna odpowiedź

Proszę o sprawdzenie.

Schemat:

PCB:

Głównie chodzi mi o poprawność PCB, ale nie wiedziałem gdzie napisać ten temat.

Udostępnij ten post


Link to post
Share on other sites

Hey

Bardzo małe odległości, ścieżki b.łatwo będą zalewane cyną. Ścieżkę z pin2 293 ( chyba ) do Mega lepiej poprowadzić prawie wprost niż dokoła i przeciskać między pinami. Tak samo C2, lepiej umieścić go przy C3.

Ponadto, masz połączone Vc1 z Vc2, zakłócenia z silników będą szły wprost do Mega. Rozważ czy ich nie rozdzielić i jedno brać sprzed stabilizatora.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Schemat - brak dużego kondensatora low-esr przy L293D od strony zasilania silników (min. 10uF) Do tego nie zasilaj silników z wyjścia 7805, bo to nie będzie działać. Zasilaj silniki bezpośrednio z akumulatora.

Płytka:

1, Na oko śruby za małe (standard to otwór 3,2mm dla śrub 3mm) i do tego 6,7mm średnicy miedzi dookoła otworu dzięki czemu śruba nie połączy innych ścieżek

2. Skoro masz u góry miedź to też rozlej tam masę

3. O ile nie jest to zupełnie niezbędne staraj się robić ścieżki tylko pod kątem 45stopni i tylko 45 stopni (nie 90)

4. Przerwy pomiędzy ścieżkami wyglądają na dosyć małe - jak będziesz robił płytkę?

5. Ścieżki do zasilania silników zdecydowanie grubsze.

6. Po co taka szeroka ścieżka reset?

Ogólnie nie jest najgorzej, ale można trochę poprawić - pytanie tylko o odległości, bo jak będziesz ją robił sam to się napocisz.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Poprawiam.

Udostępnij ten post


Link to post
Share on other sites

Kondensator jest raczej niezbędny ponieważ spadki napięcia wywoływane przez silniki mogą resetować uC i zwiększ odległość polygonu od innych ścieżek

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Poprawione, dodałem kondensator 10uF 63V (Akurat taki miałem) i jeszcze kilka innych.Płytkę robię termotransferem.

Co do lutowania to mam trochę wprawy więc nie powinienem mieć większych problemów.

PCB:

Schemat:

Udostępnij ten post


Link to post
Share on other sites

ps19 nie dawaj tych kondensatorów elektrolitycznych "odkłócających" silniki. Zostaw tylko te ceramiczne. Natomiast te elektrolity daj na filtrowanie zasilania mostka (usuń te ceramiczne) 😉

Płytkę bez problemów da się zrobić jednostronną 😉

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Przy mostku do VCC1 powinno być podłączone 5v, a do VCC2 zasilanie na silniki. To dość poważny błąd.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Niby jak mam podłączyć zasilanie do silników, wydaje mi się, że idzie ono z wyjść w L293.

Jak do silnika podepnę jeszcze nóżkę od zasilania to mostek pójdzie z dymem.

Udostępnij ten post


Link to post
Share on other sites

ps19 nie zrozumiałeś 😉Robomaniakowi chodzi o to, że VCC2 jest to jedno z wyjść mostka odpowiadające za zasilanie silników. VCC1 to zasilanie logiki.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Prościej na VCC1 podajesz 5V a na VCC2 podajesz napięcie prosto z akumulatora

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Poprawione.

Udostępnij ten post


Link to post
Share on other sites

Wróciłeś do wersji podstawowej, znów połączyłeś Vc1 z Vc2. Pin 16 w L293 ma iść do +5V a pin 8 przed stabilizator. Ponadto, coś nakombinowałeś z kondziorami. Niepotrzebnie oddaliłeś ich piny (+) od odpowiedniej ścieżki a w C4 (-) idzie na masę ale na bardzo "słabą", przez cienką ścieżkę.

Nie przejmuj się, z praktyki wiem że o ile wstępne zaprojektowanie PCB zajmuje X czasu to kosmetyka często 5X.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Nie wiem dlaczego,ale Eagle mimo że VCC2 i VCC1 nie są połączone to i tak je łączy.

W razie małych błędów proszę o poprawienie.

Udostępnij ten post


Link to post
Share on other sites

Nie znam Eagle, "od zawsze" robię druki w Protelu, przypuszczam że te ścieżki są na "lock" czy tp.

Teraz jest b.źle, do Megi ect. puściłeś U sprzed stabilizatora. Wróć do poprzedniego projektu i daj ścieżkę ( grubą ) do pin8 L293 na drugiej warstwie lub obróć tę kość o 180°.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...