Skocz do zawartości

Kurs Arduino - #1 - podstawy Arduino oraz środowisko


Pomocna odpowiedź

8 godzin temu, Treker napisał:

@CARRUS17, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.

Adres strony podany jest na ulotce (pogrubiony, na żółtym tle, tuż obok kodu) 🙂

Dzięki za pomoc, zwyczajnie źle wpisałem adres strony.

  • Lubię! 1
Link to post
Share on other sites

Oryginalne upalilem i korzystam teraz z jakiejś kopii z allegro, bo szkoda mi zniszczyć kolejnego, (dopiero się uczę)

Tylko wcześniej działało na moim laptopie, który jest teraz w naprawie, ja korzystam z zastępczego który nie chce współpracować

 

Link to post
Share on other sites
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Jeśli to klon to prawdopodobnie brakuje odpowiednich sterowników, bo klony działają trochę inaczej od oryginalnych Arduino. Poszukaj i zainstaluj odpowiednie sterowniki - może ruszy.

A tak z ciekawości - jak spaliłeś oryginał? Rzadko się zdarza, że ktoś uszkadza te płytki 😉

Link to post
Share on other sites

Dałem radę już się z tym uporać, wieczorem znalazłem sterownik portu szeregowego na internecie i ruszyło

Co do Arduino, tworzyłem projekt małej klawiaturki która miałaby działać na zasadzie starych klawiatur z telefonów tylko jeszcze bardziej złożona

Mianowicie miała być obsługiwana przez rękawice z płytkami stykowymi i stykanie ze sobą palców odpowiednią ilość razy miało wywołać odpowiadajace zapisowi funkcje w projekcie ktory tworze ale narazie nie będę zdradzał szczegółów 

W każdym razie za funkcje w prototypie odpowiadały sekwencje zapalania i gaszenia diod led ktore oznaczały czy program interpretuje poprawnie ruchy

No i chyba przedobrzylem bo wkoncu coś syknęło i zgasły diody , więcej nie udało mi się go włączyć, dokladnie nie wiem co się stało, po płytce nie widać żeby coś było zadymione czy czarne, ale nie znam tak dogłębnie budowy Arduino żeby próbować to naprawić, dlatego teraz eksperymentuje na jakiejś tanioszce

 

Link to post
Share on other sites

Witam,

dzisiaj przyjechała do mnie paczka z podstaw Arduino i mam problem przy instalacji sterowników. Gdy podłączam Arduino do komputera to pomarańczowa dioda LED miga (od razu po podłączeniu Arduino), ale gdy już wchodzę w menedżer urządzeń to pojawia mi się ta ka informacja jak na pierwszym screenie. Dodam jeszcze, żeby zobaczyć w ogóle dostępne porty COM to musiał w opcji widok kliknąć "pokaż ukryte urządzenia". A gdy włączyłem program i wszedłem w przykład "Blink" tak jak na kursie, to nie mogę wybrać portu (screen 2). 
System operacyjny: Windows 10

Bardzo proszę o pomoc.

1.png

2.png

Link to post
Share on other sites

@Jeffrey witam na forum 🙂 W przypadku oryginalnego Arduino (a takie jest w zestawach) nie powinieneś mieć żadnych problemów ze sterownikami. Podłączyłeś Arduino do PC zanim zainstalowałeś środowisko czy dopiero później? Masz pod ręką może inny przewód USB, którym mógłbyś podłączyć Arduino do PC dla testu?

Link to post
Share on other sites

Warto byłoby chyba spróbować usunąć urządzenie z systemu, odinstalować ręcznie sterowniki i jeszcze raz ponowić instalację. Coś musiało pójść źle konkretnie w Twoim przypadku, bo to nie jest często spotykany problem (szczególnie przy oryginalnym Arduino). Jak masz dostęp do innego PC to też warto spróbować podłączyć tam Arduino, aby zobaczyć czy system wykryje jakieś nowe urządzenie. Jeśli to nie pomoże to może faktycznie problem leży w sprzęcie (kable/płytka), ale bardzo bym się wtedy zdziwił 😉

Link to post
Share on other sites

Właśnie przed chwilą odinstalowałem środowisko i najpierw podłączyłem Arduino do komputera, wtedy od razu wykryło mi porty COM. Następnie zainstalowałem ponowie środowisko i od razu wszystko działa tak jak należy 😉. Dziękuję za pomoc 😉

  • Lubię! 1
Link to post
Share on other sites

Trochę dziwne, że w odwrotnej kolejności nie ruszyło. W każdym razie najważniejsze, że się udało - powodzenia w nauce programowania 😉

  • Lubię! 1
Link to post
Share on other sites

Witam,

zakupiłam zestaw FORBOT z Arduino Uno i przystąpiłam do kursu, ale po instalacji sterowników w Menedżerze urządzeń nie pojawia mi się opcja "Porty (COM i LPT)" (tak jak na screenie). Tak samo w Arduino IDE nie wykrywa mi żadnych portów. Dioda LED pokazuje, że Arduino działa. Co powinnam zrobić?

11.png

22.png

 

Edit: Przeczytałam problem kolegi przede mną i odinstalowałam IDE. Wtedy jakby coś zaskoczyło i pojawiło się w Menedżerze Urządzeń "unknown device". Pobrałam znowu IDE i niestety urządzenie zniknęło. Portów nadal nie ma.

Edytowano przez Hatenko
Link to post
Share on other sites

Witam. Zakupiłem orginalne Arduino Uno w Botland. Zacząłem kurs, chciałem przetestować płytkę wg. instrukcji z kursu i mam problem bo nie mogę nic skompilować ani zgrać na Arduino. O co tu chodzi. Dodaje zrzut ekranu z komputera. 

 

Windows Vista. Wydaje mi się,że to jakiś problem ze sterownikami. Może ktoś miał podobny problem?

Arduino problem.jpg

Z Google Play pobrałem aplikacje ArduinoDroid. Kablem OTG połączyłem telefon z Arduino i tam wszystko działa bez problemu. Zmieniam parametry "mrygania" diody. Próbuję dalej bo problem jest po stronie komputera. Jak znajdę rozwiązanie dam znać.

Edytowano przez Gregor1984
Brak rozwiązania problemu
Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.