Skocz do zawartości
kasprzyk.michal

Schemat do LineFollower'a.

Pomocna odpowiedź

Cześć trochę błędów jest:

*transoptory masz źle spolaryzowane. Emiter na masie, rezystor 20k do kolektora i z niego pobierasz sygnał.

*Przy Avcc -kondensator 100nF do masy, dławik 10mH do Vcc.

*Pamiętaj aby przy mostku TB6612 dać konensator LOW ESR.

*Jeśli to złącze KANDA to sprawdz dokładnie jak sie je podłącza(tam jest 4 masy).

*AREF - kondensator 100nF do masy.

*Ewentulanie jeśli masz mało miejsca na płytce to zamiast dawać rezystory pull-up mozesz zwyczajnie włączyć rezystory podciągające w mikrokontrolerze(rzędu 50k)

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Może to nie błąd ale zewrzyj te diody do masy będzie łatwiej podciągać je do rozlanej masy...

Udostępnij ten post


Link to post
Share on other sites

@MacGyver, poprawiłem to o czym wspomniałeś w swoim poście. Czy mogłbyś teraz na to popatrzeć ?

Może to nie błąd ale zewrzyj te diody do masy będzie łatwiej podciągać je do rozlanej masy...

Faktycznie, lepszy pomysł. Nie miałem czasu tego zmienić na poprawionym schemacie.

Pozdrawiam.

Udostępnij ten post


Link to post
Share on other sites

Teraz wg mnie jest wszystko dobrze. Masz jeszcze kilka wolnych pinów, proponuje podłączyć jakis switch(np. do startu. Osobiscie mam wyprowadzony także reset), napewno sie przyda. Pamiętaj o wyłączeniu JTAG'A 🙂

Udostępnij ten post


Link to post
Share on other sites

Bądź aktywny - zaloguj się lub utwórz konto!

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto w ~20 sekund!

Zarejestruj nowe konto, to proste!

Zarejestruj się »

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się »

×