Skocz do zawartości

Problem z mostkiem H na tranzystorach bibolarnych sterowany za pomocą Arduino.


Aragorn53

Pomocna odpowiedź

Witam. Mój problem na budowie mostków bod robocik OWI535 sterowanego za pomocą Arduino. Mostki zasilane są zasilaczem komputerowym poprzez złącze Molex 5V 15 A. Zbudowałem układ ukazany na rysunku:

na bazy tranzystorów BD911 podpiąłem jak widać na rysunku po dwa kabelki pochodzące z płytki Arduino aby zwiększyć prąd przepływaćacy przez emiter tych tranzystorów, prąd na jednym pinie w Arduino wynosi 5 V 40mA , wzmocnienie maksymalne tranzystora BD911 to 15. Tranzystory BC547B zastosowałem w celu aby można było sterować silniki za pomocą PWM.

Gdy testowałem tylko 1 mostek z odłączeniem pozostałych wszystko wydawało się pracować poprawnie.

Natomiast gdy podpiąłem wszystkie mostki jak ukazano na rysunku powstały pewne problemy.

Włączając tylko jeden silnik, w przypadku opuszczania ramienia układ działa poprawnie ale natomiast podczas podnoszenia ramienia robocika do góry silnik pracuje z bardzo małą mocą, a ramie jest słabe i wolno się podnosi albo wogóle.

Natomiast górny załączony tranzystor BD911 w mostku, nagrzewa się mu nużka korektora. Prawdopodobnie powstaje jakieś zwarcie tylko nie jestem w stanie ustalnić z jakiego powodu ono się pojawia.

Proszę o pomoc.

Czy powodem tego że robocik nie może się podnieść a górny tranzystor BD911 nagrzewa się do niebezpiecznych dla niego wartości może być że nie zastosowałem rezystorów na bazach tych tranzystorów lub diod w mostku H?

Jeżeli tak to czy moglibyście mi doradzić jakich użyć i jak zamieścić je w układzie?

Z góry dziękuję za pomoc.

Link do komentarza
Share on other sites

Muszę Cię zmartwić, Twój post jest kolejnym przykładem na kłamliwość hasła "Nie matura lecz chęć szczera zrobi z ciebie oficera". I drugie moje ulubione: "Arduino - każdy może zostać elektronikiem" 😃 Przepraszam, nie mogłem się oprzeć.

Skąd wziąłeś ten układ? Jest kompletnie bezsensowny począwszy od założeń (górny tranzystor jako wtórnik przy tak niskim zasilaniu) a skończywszy na realizacji układowej. Jeżeli masz jeszcze chwilę czasu, rozmontuj wszystko jeszcze dziś wieczorem i zacznij czytać jakieś książki o elektronice. Twój układ nie nadaje się do podłączania wprost do procesora, bo jest dla niego po prostu groźny. Tak, oporniki w bazach uratują procesor (jeżeli jeszcze żyje po tych makabrycznych eksperymentach), ale nie pomogą w działaniu mostka. Kto Ci powiedział, że możesz bezkarnie pobierać z wyjścia procesora 40mA? W jakich warunkach?

Gdy piszesz "wszystko wydawało się pracować poprawnie" to co to oznacza? Coś mierzyłeś? Jakieś prądy, napięcia, czy tylko silniczek się kręcił i to Cię uspokoiło. Dużo pracy przed Tobą.

Może zacznijmy od tego, że powiesz nam jakie masz silniki albo przynajmniej jaki prąd zwarciowy pobierają i jakiego prądu typowo oczekujesz podczas pracy układu. To da wyobrażenie o koniecznych osiągach samego mostka.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.