Skocz do zawartości
MatiPl01

Problem z uruchomieniem Raspberry PI 3 B+

Pomocna odpowiedź

Witam. W zeszłym tygodniu w piątek zakupiłem Raspberry Pi 3 B+. We wtorek tydzień później zainstalowałem system i rozpocząłem swoją przygodę z urządzeniem. Początkowo wszystko działało poprawnie, lecz dziś, podczas korzystania z malinki, nagle zgasła zielona dioda i połączenie zostało przerwane (użytkowałem przez ssh korzystając z VNC Viewer). Aby się upewnić, że to nie wina połączenia podłączyłem rpi do monitora, lecz nadal nie było żadnego obrazu. Wcześniej pojawiał się pulpit i miałem możliwość normalnego sterowania jak na komputerze (wgrałem system raspbian z graficznym interfejsem). Po odłączeniu przewodu zasilającego, przeinstalowałem system i upewniłem się, że wszystko jest dobrze podłączone (karta nie leży luźno w slocie). Od tego czasu nie widzę graficznego interfejsu oraz nie świeci się zielona dioda, wskazująca na pracę urządzenia. Nie wiem co jest przyczyną i mam pytanie, czy można to naprawić samemu, czy jest to wina urządzenia i wymaga serwisu. Proszę o rozpatrzenie i pomoc.

Z góry dziękuję i pozdrawiam.

Udostępnij ten post


Link to post
Share on other sites
My także nie wiemy.

To szkoda, spróbuję z serwisem jak przyjmą, bo niby na gwarancji jest, ale to nigdy nie wiadomo, co wymyślą, aby nie naprawić. 🙁

Udostępnij ten post


Link to post
Share on other sites

MatiPl01, witam na forum!

Podałeś trochę mało informacji, aby można było zdiagnozować Twój problem. Chociażby najważniejsze - z czego zasilasz układ? Masz odpowiedni zasilacz?

Udostępnij ten post


Link to post
Share on other sites
MatiPl01, witam na forum! Widzę, że to Twoje pierwsze kroki na Forbocie, jeśli chcesz przywitać się z innymi członkami naszej społeczności możesz skorzystać z tego tematu: Wątek zbiorczy: powitania użytkowników 🙂

Podałeś trochę mało informacji, aby można było zdiagnozować Twój problem. Chociażby najważniejsze - z czego zasilasz układ? Masz odpowiedni zasilacz?

Zasilam zasilaczem, który był w komplecie (zestaw kupiłem na allegro) - parametry zasialcza: 5V 3.1A (LINK: https://allegro.pl/zestaw-raspberry-pi3-model-b-i7237645729.html?snapshot=MjAxOC0wNy0yNVQxODowOTozNC40MjVaO2J1eWVyOzc4OTBlNmUyODA4MTJlZmMzNjEyYTU2ZWZjZGMzNzk2ZDA3ZDE5Y2NiOTRkZGRjY2MyNjhmZmM2NGUwOWJhYjI%3D)

Udostępnij ten post


Link to post
Share on other sites

MatiPl01, prąd i napięcie to nie jedyne parametry zasilacza. Ciężko powiedzieć czy ten konkretny sprawdza się dobrze z RPi. Przy tego typu problemach złe zasilanie to najbardziej prawdopodobne źródło problemów. Pozostaje kontakt ze sprzedawcą 🙂

Udostępnij ten post


Link to post
Share on other sites
MatiPl01, prąd i napięcie to nie jedyne parametry zasilacza. Ciężko powiedzieć czy ten konkretny sprawdza się dobrze z RPi. Przy tego typu problemach złe zasilanie to najbardziej prawdopodobne źródło problemów. Pozostaje kontakt ze sprzedawcą 🙂

Na razie czekam na kuriera, który ma przyjechać z nowym egzemplarzem i odebrać zepsuty. Zasilacz podobno jest odpowiedni, o czym może świadczyć liczba pozytywnych opinii u sprzedającego na allegro, więc albo trafiłem na wadliwy sprzęt, albo zrobiłem spięcie. Czy napięcie 3,3V, gdy prąd popłynie nie tak, jak powinien (np. przy zetknięciu opornika z przewodem) może zniszczyć całe Raspberry?

Udostępnij ten post


Link to post
Share on other sites

MatiPl01, zależy "co z czym zetkniesz", ale oczywiście uszkodzenie RPi w taki sposób jest możliwe.

Udostępnij ten post


Link to post
Share on other sites
22 godziny temu, Treker napisał:

MatiPl01, zależy "co z czym zetkniesz", ale oczywiście uszkodzenie RPi w taki sposób jest możliwe.

1.thumb.png.db71ee504d20422a8b45f9e71447979e.png Zbudowałem taki układ jak na zamieszczonym screenie i myślę, że górny kondensator mógł styknąć się z nogą czujnika światła, będącego pod nim.

Czy istnieje jakikolwiek sposób na zabezpieczenie malinki przed spaleniem lub zmniejszenie ryzyka spalenia? Czy jest jakaś reguła, bądź można zamontować odpowiedni bezpiecznik? (Do GPIO na RPI mam podpięty przewód, który łączy je z płytką stykową za pomocą niebieskiego rozdzielacza - patrz schemat. Czy przy takim układzie można postarać się o zabezpieczenie urządzenia?)

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Optoizolacja 🙂 Najlepsza metoda to podłączanie rzeczy na wyłączonym zasilaniu i kilkukrotne sprawdzenie układu przed podłączeniem zasilania. RPI to na tyle "otwarta" platforma, że zawsze można zrobić coś nie tak.

Jeśli zwarłeś nogę "2" od R4 z GND, to mogłeś ubić stabilizator, ale to wróżenie z fusów. Jeśli nie ma fizycznych uszkodzeń (kratery na PCB, czarne ślady po "magic smoke"), to pozostaje serwis. Proponuję jeszcze sprawdzić, czy po podłączeniu wszystkiego masz napięcie 5V na odpowiednim pinie raspberry. Jeśli nie - wymień zasilacz i spróbuj ponownie. Jeśli masz - pewnie padło coś po stronie maliny (zacząłbym od stabilizatora 3V3).

Edytowano przez Nawyk
  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites
11 godzin temu, Nawyk napisał:

Optoizolacja 🙂 Najlepsza metoda to podłączanie rzeczy na wyłączonym zasilaniu i kilkukrotne sprawdzenie układu przed podłączeniem zasilania. RPI to na tyle "otwarta" platforma, że zawsze można zrobić coś nie tak.

Jeśli zwarłeś nogę "2" od R4 z GND, to mogłeś ubić stabilizator, ale to wróżenie z fusów. Jeśli nie ma fizycznych uszkodzeń (kratery na PCB, czarne ślady po "magic smoke"), to pozostaje serwis. Proponuję jeszcze sprawdzić, czy po podłączeniu wszystkiego masz napięcie 5V na odpowiednim pinie raspberry. Jeśli nie - wymień zasilacz i spróbuj ponownie. Jeśli masz - pewnie padło coś po stronie maliny (zacząłbym od stabilizatora 3V3).

Napięcie 5V mam na tych pinach, na których powinno być, lecz nie miałem 3.3V na dwóch pinach, na których powinno być takie napięcie. Przed chwilą kurier przyjechał i wymienił mi na nowe, zobaczymy, czy coś stwierdzą po sprawdzeniu odesłanej malinki. Na płytce nie było żadnych śladów przepalenia itp. Myślę, że może  być to wina listwy,  do której podpiąłem zasilacz, ponieważ dziś usłyszałem, że po podłączeniu listwy do prądu wydaje ona dziwne trzaski, więc może wina leży po jej stronie. Do listwy miałem podpięty tylko jeszcze router od internetu, który też od czasu do czasu przerywał. Obecnie mam remont, więc nie wiem, czy sprawdzę od razu nową malinkę, ale podłączę ją do nowej listwy. Jeśli chodzi o sprawdzanie, czy układ jest dobrze zbudowany, to sprawdziłem około 2 razy i było ok, więc albo zasilanie, albo coś zwarłem.

Poza dokładnym sprawdzaniem, nie istnieje inna metoda zabezpieczenia na wypadek nieodpowiedniego napięcia, spięcia itp.?

Udostępnij ten post


Link to post
Share on other sites
2 godziny temu, MatiPl01 napisał:

Poza dokładnym sprawdzaniem, nie istnieje inna metoda zabezpieczenia na wypadek nieodpowiedniego napięcia, spięcia itp.?

Chyba tylko separacja galwaniczna (np. optoizolacja) każdego pinu wychodzącego "na zewnątrz" daje Ci w miarę dużą pewność, że nie uszkodzisz układu przypadkowym działaniem podczas prototypowania/testowania. Jeśli chodzi o samą sekcję zasilania, to stosuje się bezpieczniki i układy przeciwzwarciowe na tranzystorach, diody zabezpieczające przed odwrotną polaryzacją itp. itd. Temat rzeka, jeśli nie sprecyzujesz dokładnie co przed czym chcesz chronić 🙂 Takie stabilizatory same w sobie też zwykle mają zabezpieczenia, bo jak zewrzesz wyprowadzenia, wzrośnie temperatura i wywali zabezpieczenie termiczne. Mogę jeszcze od siebie dodać, że przy uruchamianiu jakiegokolwiek układu warto monitorować prąd - jeśli przekroczy spodziewaną wartość, masz szansę szybko zareagować. A najlepszy jest zasilacz, w którym możesz dokładnie określić próg zadziałania OCP.

Udostępnij ten post


Link to post
Share on other sites
19 godzin temu, Nawyk napisał:

Chyba tylko separacja galwaniczna (np. optoizolacja) każdego pinu wychodzącego "na zewnątrz" daje Ci w miarę dużą pewność, że nie uszkodzisz układu przypadkowym działaniem podczas prototypowania/testowania. Jeśli chodzi o samą sekcję zasilania, to stosuje się bezpieczniki i układy przeciwzwarciowe na tranzystorach, diody zabezpieczające przed odwrotną polaryzacją itp. itd. Temat rzeka, jeśli nie sprecyzujesz dokładnie co przed czym chcesz chronić 🙂 Takie stabilizatory same w sobie też zwykle mają zabezpieczenia, bo jak zewrzesz wyprowadzenia, wzrośnie temperatura i wywali zabezpieczenie termiczne. Mogę jeszcze od siebie dodać, że przy uruchamianiu jakiegokolwiek układu warto monitorować prąd - jeśli przekroczy spodziewaną wartość, masz szansę szybko zareagować. A najlepszy jest zasilacz, w którym możesz dokładnie określić próg zadziałania OCP.

Zasilacza nowego nie kupię, już i tak za dużo jak na razie wydałem. Jeżeli chodzi o zabezpieczenie, to myślałem, że można ogólnie w jakiś sposób zmniejszyć ryzyko uszkodzenia samego RPI przy budowaniu obwodu na płytce stykowej, ale jak jest tak wiele różnych rzeczy, to tego nie ogarnę. Mógłbyś przybliżyć, z czym związana jest separacja galwaniczna i jak ją wykonać?

Udostępnij ten post


Link to post
Share on other sites

Ja bym zaczął od wyłączania zasilania podczas jakichkolwiek zmian w połączeniach. To taka podstawa.

Udostępnij ten post


Link to post
Share on other sites
(edytowany)
4 godziny temu, MatiPl01 napisał:

Mógłbyś przybliżyć, z czym związana jest separacja galwaniczna i jak ją wykonać?

Mogę pójść na łatwiznę i podrzucić Ci filmik, na którym ktoś dość dokładnie omawia temat i to w kontekście Raspberry PI:

4 godziny temu, MatiPl01 napisał:

 ale jak jest tak wiele różnych rzeczy, to tego nie ogarnę.

Nie chcę Cię zniechęcać, bo temat jest ciekawy i jedynie wymaga dodatkowej nauki, po prostu zabezpieczenie tak rozbudowanego układu, jakim jest RPi nie jest łatwe, a z Twoich postów wnioskuję, że dopiero zaczynasz przygodę i sam do końca nie wiesz, co przed czym chcesz zabezpieczyć. Dużo ostrożności i dokładność w wykonywaniu połączeń zabezpieczy Twoje układy lepiej niż jakakolwiek dodatkowa płytka 🙂 Jeśli coś wystaje kilka cm nad płytką stykową i buja się przy każdym podmuchu wiatru, to lepiej przyciąć nóżki tego elementu i mieć pewność, że nie dotkną niczego, czego nie powinny. Można nawet pokusić się o zabezpieczenie elementu taśmą, jeśli np. ma bardzo cienkie wyprowadzenia i nie trzyma się dobrze w płytce. Jeśli dwa elementy na stykówce niemal się dotykają, to rozsuń je - nie żałuj czasu nawet na przeplanowanie rozmieszczenia elementów, żeby uniknąć jakiegokolwiek ryzyka. Błędów na schemacie raczej nie unikniesz, ale od tego masz to forum i ludzi, którzy chcą Ci pomóc - wystarczy poprosić o sprawdzenie. No i popełnianie błędów to kosztowne, ale najlepsze lekcje, jakie tylko można sobie "zasponsorować" 🙂 Życzę Ci popełniania błędów, ale tylko nowych 😉

Edytowano przez Nawyk

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Napisz odpowiedź...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...