Skocz do zawartości
piechnat

Raspberry Pi 4b – niska prędkość WiFi

Pomocna odpowiedź

Mam problem z prędkością WiFi w nowo nabytym Raspberry Pi 4b (sieć domowa z routera TP-Link Archer C7, częstotliwość 2.4Ghz, kanał 6).

Strony wczytują się jak krew z nosa, również streaming po LAN nie daje rady. W serwisach testujących prędkość łącza wychodzi download rzędu 0.25 Mbps.

Wszystkie inne sprzęty, stojące w tym samym miejscu co malina, osiągają kilkanaście lub kilkadziesiąt megabitów. Co najdziwniejsze, jeśli obok routera położę telefon z włączonym hotspotem (Android), to na tej sieci Raspberry wyciąga bez problemu 8 Mbps (jak przyniosę telefon do pokoju, w którym stoi malina, to już w ogóle mam prawie 40 Mbps).

Wynika z tego jakby istniał jakiś konflikt między Raspberry Pi 4b, a tym konkretnym routerem.

Czy ktoś spotkał się z takim problemem? Czy można to jakoś rozwiązać?

Dziękuję i pozdrawiam.

Udostępnij ten post


Link to post
Share on other sites

Jestem troche sceptycznie nastawiony do WiFi w nowym RPi. Na wszystkich 3 płytkach do jakich mam dostęp jest konflikt WiFi - HDMI, kompletnie nie da się połączyć z siecią dopóki nie odłączę kabla... Także może spróbuj odłączyć HDMI. 

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Porobiłem kilkanaście testów, z których wynika, że na niską prędkość WiFi składa się kilka rzeczy:

1. W ustawieniach routera miałem na sztywno wybrany kanał 13, tymczasem moje RPi ma najstabilniejszy transfer na kanale 1 mimo tego, że najluźniejszy jest właśnie 13.  
W ten sposób prędkość uwolniła się z poziomu ułamków do kilku megabitów.

2. Dużym czynnikiem zakłócającym jest stojący obok dekoder TV (WiFi) jeśli był akurat włączony.
Po wyłączeniu prędkość doszła do ok. 15 Mbps, ale jest bardzo chwiejna.

3. Poza zmniejszeniem odległości od routera, najlepsze rezultaty przynosi odłączenie kabla HDMI. W takiej sytuacji prędkość wzrasta do 25-35 Mbps.
Wydaje mi się, że pewne korzyści, daje również podłączenie telewizora do drugiego portu HDMI. Niestety nie wiem, jak na drugim porcie spowodować, aby działało audio (nie ma również HDMI-CEC)?

[edytowane] znalazłem w sieci, może się komuś przyda 🙂

amixer -q cset numid=3 3

[/edytowane]

Zastanawiam się, czy to może mieć jakiś związek z jakością kabla? Zauważyłem przy kablu dedykowanym do RPi adnotację „potrójna warstwa ekranowania w celu izolacji od fal Bluetooth i WiFi”?

Edytowano przez piechnat
  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Cieszę się, że ktoś potwierdził moją teorię skorelowania kabla HDMI z WiFi... nikt nie chciał wierzyć, a jednak.

Dnia 14.09.2019 o 01:35, piechnat napisał:

znalazłem w sieci, może się komuś przyda

Służy to do ustawia dźwięk na HDMI? W dokumentacji RPi jest bez parametru -q, wiesz może co to robi?

Udostępnij ten post


Link to post
Share on other sites
(edytowany)
man amixer
[...]
-q Quiet mode. Do not show results of changes.

ostatni parametr:

0 - automatic
1 - force 3.5 jack
2 - force HDMI0
3 - force HDMI1
Edytowano przez piechnat
  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Napisz odpowiedź...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...