Skocz do zawartości

Tb6612 i atmega dziwne sygnały


Ahmed

Pomocna odpowiedź

Witam.

Mam problem związany z linefollowerem. Wszystko chodziło (jeździło) do czasu, gdy odwrotnie podpiąłem zasilanie z li-pola. Oczywiście spaliła mi się przetwornica (st1s10), jednak gdy wymieniłem ją, dławik i mostek to na jednym z kanałów sterujących kierunkiem obrotów silnika miałem bardzo dziwny sygnał. Gdy na jednym pinie podałem 1, a na drugim 0 na obu uzyskałem ok 4,2V (zamiast kolejno 5 i 0). Po ponownej wymianie mostka i kondensatora tantalowego oraz zamianie pinów sterujących z atmegi nic się nie zmieniło. Co najciekawsze, drugi kanał działa bez zarzutu. Czy ktoś ma pomysł, co może być tego przyczyną, a co ważniejsze jak mogę to naprawić? Czy mógł mi się spalić procek? (dodam, że attiny obok działa bez zarzutu)

Z góry dziękuję za odpowiedź.

Pozdrawiam.

Link do komentarza
Share on other sites

Dziękuję za odpowiedź.

Też tak myślałem, szkopuł w tym, że drugi kanał podpięty do tego samego portu© działa, z kolei, zmiana wadliwych sygnałów na PD4 i 5 nie przyniosła efektu. Czy jest wogóle możliwe, aby przetwornica przepuściła takie, odwrotne napięcie?

Link do komentarza
Share on other sites

Ahmed, zauważ, że po odwrotnym podłączeniu to odwrotne napięcie poszło ścieżką masy, która łączy wszystkie elementy. Mogłeś więc uszkodzić nie tylko przetwornicę ale i mostek czy TSOPa. Nie każdy układ jest zabezpieczony przed odwróceniem napięcia zasilającego.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Zgadzam się, jednak, jeśli 5V w przetwornicy wisi w powietrzu, to na moje oko procek nie powinien się spalić. W takim razie sądzicie, że to wina atmegi? Najbardziej mnie zastanawia, czemu drugi kanał (podpięty też do portu C) działa bez zarzutu. Szukam jakiegoś rozwiązania, ponieważ chciałbym go jak najszybciej uruchomić, odpalić 2, czy 3 razy i zrobić od nowa drugą wersję, a na te 3 przejazdy nie chcę się bawić z wymianą procka.

Akurat TSOP działa 😉

Link do komentarza
Share on other sites

Ahmed, masz pomiar napięcia na akumulatorku, więc puściłeś całe zasilanie przez port mikrokontrolera na resztę układów. Swoją drogą przetwornica ma pewnie przejście w "drugą stronę" ale to tylko zgadywanie bo nie chce mi się zajrzeć do dokumentacji 😋.

Link do komentarza
Share on other sites

Sabre, ale ten pomiar jest podpięty do attiny, które działa, mało tego, pomiar baterii nadal funkcjonuje bez zarzutów (sprawdzone diodami) 😃 Wiem, to dość dziwne, ale czy widzisz jakieś inne rozwiązanie oprócz w połowie spalonego procka? Czy byłaby możliwość, żebym na bieżąco palił poszczególne nóżki podpinając je do mostka? (jeszcze przed wymianą kondensatora)

Link do komentarza
Share on other sites

Ahmed, odwrotnie podłączone zasilanie mogło uszkodzić prawie każdy element który jest wrażliwy na wyższe i odwrotnie spolaryzowane napięcie. To, że nie widać zewnętrznych uszkodzeń nie oznacza, że uszkodzeniu nie uległ. Tantale są przeważnie dobierane na styk jeśli chodzi o napięcie zasilające i niestety po zmianie polaryzacji bardzo szybko się uszkadzają. Piny mikrokontrolera również mogły ulec uszkodzeniu ponieważ mogły uszkodzić się tranzystory wyjściowe. Możliwe, że uszkodzeniu uległ również mostek.

  • Lubię! 1
Link do komentarza
Share on other sites

Dobrze, zatem dziękuję za odpowiedź, mostek i tantal jest wymieniony, poszukam teraz jakiejś dobrej nóżki i może ruszy. Aktualizacja pewnie jutro.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.