Skocz do zawartości
sofnir

Czujnik CNY70 nie działa.

Pomocna odpowiedź

Hej, podłączyłem czujnik CNY70 wg. tego schematu:

Zasilam 5 Voltami. Zczytuję wartości za pomocą arduino i je sobie wyświetlam i mam problem, bo te wartości się prawie nie zmieniały. Wymieniłem rezystory, dałem do diody 100 Ohm, a do fototranzystora 100 kOhm i jest już trochę lepiej, ale wartości zmieniją się od 1000 do 900. Bardzo mnie to dziwi, bo w necie jak szukam tego typu schematów to ludzie używają 220 i 10k [Ohm] i wszystko im śmiga (wartości zmieniają się o kilkaset). Ja bym chyba musiał podłączyć szeregowo z 10x 100kOhm żeby osiągnać taki efekt, a to bez sesnu, największy opornik jaki mam to 100kOhm. W czym tkwi problem?

Ps Na razie podpiąłem szeregowo 5x 100kOhm i jest nieźle, bo wartości zmieniają się już o kilkaset i spokojnie można wykrywać linię, ale czy to jest normalne, że innym wystarcza 10kOhm, a ja muszę mieć pół miliona? o.O

Udostępnij ten post


Link to post
Share on other sites

Cześć!

Jesteś pewny, że dobrze podłączyłeś czujnik? Najlepiej jak pobierzesz sobie .pdf tego czujniczka i dokładnie zobaczysz na zdjęciu, gdzie jest anoda, katoda diody IR oraz gdzie jest kolektor i emiter fototranzystora. Wartości 220R oraz 10k spokojnie wystarczają co poprawnej pracy czujnika.

Zapodaj też zdjęcie swojego podłączenia tego czujnika - może będzie prościej pomóc 🙂

Udostępnij ten post


Link to post
Share on other sites

A nie zamieniłeś czasem kolektora i emitera?

Udostępnij ten post


Link to post
Share on other sites

@deshipu wydaje mi się, że to może być przyczyną, bo w bibliotece do Eagle tego czujnika chyba został odwrócony o 180* fototranzystor i może kolega podłączył czujnik patrząc na schemat (a nie w oparciu i notę katalogową).

Niech sofnir to sprawdzi 😉

Udostępnij ten post


Link to post
Share on other sites

Podłączyłem według tego:

Katoda i emiter do masy, anoda rezystor 220, kolektor 10k i od kolektora wyjście.

Udostępnij ten post


Link to post
Share on other sites

Na tym zdjęciu jest błąd. Kolektor i emiter są odwrotnie.

Udostępnij ten post


Link to post
Share on other sites

Wszyscy mieli rację, już działa, korzystałem z błędnego rysunku znalezionego w sieci.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Napisz odpowiedź...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...