Skocz do zawartości

Problem z zasilaniem przez 12V klona Arduino uno


WielkiWrobel

Pomocna odpowiedź

Więc mam taki problem

Ostatnio kupiłem do Arduino zasilacz impulsowy 12v, ale po podłączeniu Arduino mocno się grzeje i śmierdzi spalonom elektroniką. Zasilacz szybko odłączyłem bo nie chce nic uszkodzić. Nie wiem co się dzieje jak ktoś chce mogę wysłać zdjęcie Arduino, dać link do zasilacza. Posiadam klona Arduino więc może z nim jest coś nie tak. Jakby ktoś potrzebował to spróbuję znaleźć link do niego.

Link do komentarza
Share on other sites

12V zamienia się w 5V przez stratę 7V na ciepło w stabilizatorze liniowym, typowy w klonie, jak zasilasz tylko płytkę Arduino to nie powinno być problemu, ale jak z tych 5V chcesz brać teoretyczne maximum płytki, 500mA, to miałbyś 3.5W oddawane na ciepło, stabilizator liniowy tego nie przeżyje. Tak jak z samochodem, może jechać 200km/h, może spalać 5l/100km, ale nie równocześnie.

Nawet samo Arduino typowo pobiera 50mA, a to już wystarcza by nagrzać stabilizator i wyzwolić różne zapachy nieusunięte na linii produkcyjnej,

I x dU = P = ciepło. 

Zapachu za bardzo tu nie pokażesz, więc decyzja po twojej stronie jak dalej z tym działać, to wcale nie musiało oznaczać uszkodzenia.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Weź poprawkę na to, że te tanie klony produkowane za dolara, zrobione są z tego co chińczyk miał pod ręką. A często ma pod ręką jakieś tanie odrzuty poprodukcyjne. Sam trafiałem na różne moduły, które po prostu nie działały. Potem kupowałem dokładnie to samo (ale pewnie z innej serii produkcyjnej) i nagle było ok. Możesz też po prostu mieć tam jakieś zwarcie. Też mi się zdarzało znajdować krople cyny gdzieś w niewidocznym miejscu.

Link do komentarza
Share on other sites

Dnia 13.06.2023 o 08:28, Treker napisał:

@WielkiWrobel zerknij do tego artykułu, w którym dokładnie opisano budowę Arduino UNO (wraz z sekcją zasilania) mam nadzieję, że to rozwieje Twoje wątpliwości: https://forbot.pl/blog/arduino-co-w-srodku-piszczy-1-schemat-id16900

Zbyt skomplikowane dla mnie

Link do komentarza
Share on other sites

Dnia 13.06.2023 o 08:28, Treker napisał:

@WielkiWrobel zerknij do tego artykułu, w którym dokładnie opisano budowę Arduino UNO (wraz z sekcją zasilania) mam nadzieję, że to rozwieje Twoje wątpliwości: https://forbot.pl/blog/arduino-co-w-srodku-piszczy-1-schemat-id16900

Ale te klony to chyba niekoniecznie są całkiem zgodne. Przykładowo w nich nie ma drugiej atmegi.

Link do komentarza
Share on other sites

Dnia 12.06.2023 o 18:42, WielkiWrobel napisał:

Jak podłączam się przez USB to mam na VINie napięcia 5v. To normalne? A może mi 5v zwiera do 12v?

Inne pytanie: czy podłączyłeś 5V, kiedy VIN nie był podłączony? Obstawiam, że tak i w ten sposób uszkodziłeś stabilizator, który nie jest zabezpieczony przed odwróconą polaryzacją. Jedyna opcja to wymiana stabilizatora A1117 na nowy model (i na przyszłość wlutowanie diody przewodzącej od 5V do VIN, by zabezpieczyć regulator przed takim uszkodzeniem).

Ewentualnie stabilizator mógł wyjść uszkodzony z fabryki, zdarza się (zwłaszcza w tanim chińskim produkcie). IMHO jedyna opcja to go przelutować na nowy egzemplarz, można kupić tanio na jakimś module np. https://allegro.pl/oferta/modul-zasilania-mini-ams1117-5v-800ma-arduino-8758703875 i przelutować. Tylko uprzedzam, że to nie jest proste zadanie dla początkującego 😉 Plus trzeba przelutować właściwy regulator, bo często są dwa (5V i 3.3V, powinny być oznaczone, ale można sprawdzić TAB (duży pin) miernikiem dla pewności)...

Link do komentarza
Share on other sites

9 godzin temu, H1M4W4R1 napisał:

Inne pytanie: czy podłączyłeś 5V, kiedy VIN nie był podłączony? Obstawiam, że tak i w ten sposób uszkodziłeś stabilizator, który nie jest zabezpieczony przed odwróconą polaryzacją. Jedyna opcja to wymiana stabilizatora A1117 na nowy model (i na przyszłość wlutowanie diody przewodzącej od 5V do VIN, by zabezpieczyć regulator przed takim uszkodzeniem).

Ewentualnie stabilizator mógł wyjść uszkodzony z fabryki, zdarza się (zwłaszcza w tanim chińskim produkcie). IMHO jedyna opcja to go przelutować na nowy egzemplarz, można kupić tanio na jakimś module np. https://allegro.pl/oferta/modul-zasilania-mini-ams1117-5v-800ma-arduino-8758703875 i przelutować. Tylko uprzedzam, że to nie jest proste zadanie dla początkującego 😉 Plus trzeba przelutować właściwy regulator, bo często są dwa (5V i 3.3V, powinny być oznaczone, ale można sprawdzić TAB (duży pin) miernikiem dla pewności)...

Jako osoba która nie potrafi zlutować dwóch kabli że sobą chyba kupię nowe Arduino po prostu. Jeszcze dzisiaj sprawdzę czy bez obciążenia też będzie się tak grzał

  • Lubię! 1
Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.