Skocz do zawartości

Sterowniki USB ASP pod windows 7 x32


kamil-s

Pomocna odpowiedź

Witam,
Przepraszam że pisze posta z być może błahym pytaniem, ale męczę się już z tym 3 dzień i w połowie osiwiałem.

Kupiłem programator usb asp popiołem go pod attiny2313 na płytce stykowej i nie działa...

Zorientowałem się że nie zainstalowałem sterowników, próbuje zainstalować je na różne sposoby według instrukcji i nic 🙁

Próbowałem na systemach Windows 7 x32, Windows XP x32.

Proszę pomóżcie.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

popiołem go pod attiny2313 na płytce stykowej i nie działa...

Może użyłeś złego popiołu? Ja najlepszy popiół uzyskuję ze spalonej lipy w kominku, zawsze daje radę. Ja bym an Twoim miejscu spróbował podpiąć, może to coś da.

Ponieważ powodów może być wiele, to zacząłbym od zamieszczenia schematu i zdjęcia.

  • Lubię! 2
Link do komentarza
Share on other sites

*Podpiąłem

Oto zdjęcie programatora USBasp:

Z programatora idzie przewód do złącza kanada, (te diodki i procek jeszcze nie są przylutowane do złącza)

Ze złącza idą kabelki prosto do procesora:

Zaczynam się obawiać że to nie sprawa podpięcia tylko wadliwego programatora: Kupiłem go pół roku temu na allegro, spontanicznie wystawiłem pozytyw a wada chyba teraz wyszła, bo dopiero teraz chcę go uruchomić.

Luty nie są nigdzie poprzerywane, podejrzewam spalony procesorek lub nie zaprogramowany. Piszę właśnie do tego gościa może będzie wiedział o co chodzi.

Link do komentarza
Share on other sites

Aleś zdjęcia podesłał 😋 Jedynie widać, że programator to samoróbka, nic więcej. Postaraj się ogarnąć jakieś lepsze zdjęcia, jak nie masz możliwości robienia makro tym aparatem, który masz, to zrób z większej odległości, pewnie będą wyraźniejsze niż te co są teraz. Najlepiej byłoby napisać do tego kolesia czy nie ma schematu, według którego wykonywał tę płytkę, mogą być D+ z D- zamienione, albo nie ma zenerek na liniach danych USB (mi nigdy nie wywalało przy tym błędów, ale różnie bywa). Poodpinaj wszystko od programatora, podłącz go tylko do komputera, na razie musimy zastanowić się nad tym, co zrobić żeby on sam zaskoczył.

Link do komentarza
Share on other sites

Znalazłem w internecie informacje na temat podpisów cyfrowych sterownika przy uruchamianiu wcisnąłem f8 wyłączyłem to, udało się zainstalować sterownik tylko menadżer urządzeń nadal mówi programator jest jako unknow device a USBasp jest nawet po odłączeniu programatora - czyli powstał taki sztuczny sterownik co nie rozwiązuje problemów więc odinstalowałem.

Aparat jest na ładowarce, czekam na odpowiedź od tego gościa.

PS. Ktoś z was ma USBasp pod windows 7 32bit albo pod xp 32bit ?

Link do komentarza
Share on other sites

Fajnie by było gdybyś mógł podesłać link do dokładnego schematu z którego korzystałeś. Też miałem kiedyś problem z moim USBaspem i okazało się że tylko w tej konkretnej wersji brakowało diod Zenera przy USB, które były w każdej innej. Taki pech 😋

Link do komentarza
Share on other sites

Ja mam identyczny problem jak 'kamil-s'. Mam również Windows 7 32-bit oraz używam nawet tego samego programatora.

Chciałem się tylko zapytać, jaką masz wersję systemu?

Link do komentarza
Share on other sites

Spróbuj przy instalowaniu sterowników porozpinać wszystkie zworki na programatorze.

Może być tak, że komputer widzi urządzenie tylko w stanie domyślnym jeśli sterowniki nie są wgrane. Potem jeszcze raz spróbuj zainstalować sterowniki.

Link do komentarza
Share on other sites

Znalazłem gdzie leży problem.

Wymieniłem się z kumplem programatorem (mieliśmy identyczne), a tu nagle jego programator u mnie działał w pełni poprawnie, zaś mój u niego oczywiście nie.

Czyli taki problem jest generowany przez uszkodzony USBAsp.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.