Skocz do zawartości

USBASP problem


czarny8322

Pomocna odpowiedź

Witam,

Kupiłem na allegro nowy programator usbasp:

automatyka2001

link

Problem polega na tym że po mimo usilnych działań nie mogę sobie z nim poradzić;/

Instalowałem różnie sterowniki(stare i nowe pod xp).Instalacja sterowników zawsze przebiegała prawidłowo.

Do programowania uzywałem avrdude z nakładką burn-o-mat i tutaj zawsze wywala mi błąd o treści:

D:\programy\avrdude58\avrdude.exe -u -C D:\programy\avrdude58\avrdude.conf -p m16 -P usb -c usbasp -U flash:w:C:\Documents and Settings\Krzysztof\Moje dokumenty\AVRStudio\AVRGCC1\AVRGCC1\Debug\AVRGCC1.hex:a

avrdude.exe: warning: cannot set sck period. please check for usbasp firmware update.

avrdude.exe: error: programm enable: target doesn't answer. 1

avrdude.exe: initialization failed, rc=-1

Double check connections and try again, or use -F to override

this check.

avrdude.exe done. Thank you.

poza tym uzywałem mkAVR Calculator w celu odczytania atmegi, tam tez wyskkuje błąd avrdude. W programie khazama także wywala błąd.

Avrdude także instalowałem w różnych wersjach, od 5.2 do 5.8

Czy jest ktoś w stnie mi pomóc?

Link do komentarza
Share on other sites

Z błędów wynika, że programator nie może się połączyć się z mikrokontrolerem.

Double check connections and try again, or use -F to override

this check.

Dokładnie sprawdź połączenia.

  • Lubię! 1
Link do komentarza
Share on other sites

w Khazma najpierw wyskakuje okno z komunikatem:

"Error while operating...

Error Setting USBASP ISP Clock..."

po kliknieciu ok, wyskakuje następne:

"

error: programm enable: target doesn't answer. 1

initialization failed, rc=-1

Avr device initialized adn ready to accept instructions

Device signature = 0x000000

Yikes! Invalid device signature.

Expeced signature for ATMEGA16 is 1E 94 03

done. Thank you

"

następne okno:

"Error while operating...

Error Setting USBASP ISP Clock..."

nestepne:

"

error: programm enable: target doesn't answer. 1

initialization failed, rc=-1

Avr device initialized adn ready to accept instructions

Device signature = 0x000000

Yikes! Invalid device signature.

Expeced signature for ATMEGA16 is 1E 94 03

NOTE: FLASH memory has been specified, an erase cycle will be performed

To disable this feature, specify the -D option.

done. Thank you

"

oraz ostatnie:

"

-Reload Flash file: tutaj scieżka do hexa

-Last EEPROM file not found

-Erasing...

-Writing Flash...

>Flash Writing fail

"

Tak, programuje nowy procek, Atmege16. Myslałem że może jest wina po stronir procka wiec podłonczyłem także do attiny13 z takim samym rezultatem.

Co do napięcia to próbowałem z napieciem zewnetrznym jak i napięciem z programatora. Nie mam pojęcia co moge jeszcze zrobić...

[ Dodano: 18-03-2012, 22:04 ]

Połończenia są na 100% prawidłowe. Ma ktoś jakies pomysły jak to rozwiązać i co ewentualnie może być żle?

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Jestem praktycznie pewny, że błąd leży po stronie połączeń. Zworka slow SCK na programatorze założona? Jak zasilasz mikrokontroler? Co masz do niego podłączone?

  • Lubię! 1
Link do komentarza
Share on other sites

Programator ten nie posiada zworki sck, widać to na zdjęciach. Aby zmienić czestotliwość programowania użyłem programu mkavr calculator, ale to i tak nie pomogło.

Połączenia programatora sprawdzałem chyba ze 100razy. Na początku podłączyłem programator pod nową atmege16. Następnie pomyślałem że może wina leży po stronie procesora wiec zmieniłem go na także nowe attiny13.... bez skutku.

Co do zasilania to uzywałem napięcia z programatora(z usb) oraz zewnetrznego 5v.

Link do komentarza
Share on other sites

Te same prędkości można uzystać bez zworki stosując program mkavr calculator. Przetestowałem wszystkie bez skutku;/

[ Dodano: 19-03-2012, 19:55 ]

Dzisiaj otrzymałem schemat programatora od producenta. Okazało się że na programatorze tam gdzie powinna być masa jest MOSI, Kanda jest przylutowana odwrotnie. Po zmianie, wszystko działa jak należy

Dziekuje wszystkim za rady:)

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.