Skocz do zawartości

Pcb/i2c/onewire/ problem z zawieszaniem sie Arduino pro mini


Pomocna odpowiedź

5 minut temu, _LM_ napisał:

Przecież jasno napisałeś że po usunięciu podstawek zaczyna działać

Podstawek nie ruszam wogole...chodzilo o wyjecie Arduino z pcb😉

 

7 minut temu, _LM_ napisał:

podłącz multimetr do ardu i zrób pomiar napięcia jak najbliżej mikrokontrolera

Napiecie takie jakie na wejsciu to i na wyjsciu...zadnych spadkow..5v.

 

8 minut temu, _LM_ napisał:

Może świadczyć o uruchamianiu układ BOD, na jakie napięcie jest ustawiony tenże?

A tego to juz nie wiem...oryginalne ustawienie z bootloadera z Ide...

O krzywe ustawienie Ardu, chodzilo mi o to ze jak przekrzywie (gnd nie styka) to przekazniki zaczynaja dzialac...

Link to post
Share on other sites
6 minut temu, _LM_ napisał:

te lutowania tutaj to takie mają być?

Tak...akurat przekaznikow nie sprawdzilem i okazalo sie ze footprint mial odwrocone zasilanie...😔 Ale jak widac nie bylo wiele przerobek...problemem jest ta miedz ktora podkreslilem powyzej...to juz pewne..moglbym podrapac w kolo, ale chce sie przyjrzec czy faktycznie cos tam nie zostalo i nie robi mikro zwarcia...

Link to post
Share on other sites

Ten NRF też jest umieszczony i uruchomiony? Wiesz że potrzebuje on stabilnego i dosyć mocnego zasilania zwłaszcza w impulsie. 

3 minuty temu, farmaceuta napisał:

ale chce sie przyjrzec czy faktycznie cos tam nie zostalo i nie robi mikro zwarcia...

Ja bym to sprawdził multimetrem z piszczkiem, albo jak nie masz to zwykłą bateryjką z LED - em. 

  • Lubię! 1
Link to post
Share on other sites
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

1 minutę temu, _LM_ napisał:

Ten NRF też jest umieszczony i uruchomiony? Wiesz że potrzebuje on stabilnego i dosyć mocnego zasilania zwłaszcza w impulsie. 

Akurat do niego nie doszedlem...ruszylem od rtc, pojawily sie problemy i nawet za nrf'a sie nie bralem...i wiem ze ten galgan potrzebuje porzadnie filtrowanego zasilania😉 juz sie zdazylem przekonac...

 

2 minuty temu, _LM_ napisał:

Ja bym to sprawdził multimetrem z piszczkiem, albo jak nie masz to zwykłą bateryjką z LED - em. 

Wlasnie tak sprawdzalem..miernikiem na zwarcie, ale bez piszczyka bo akurat tam mi bateria padla...no ale miernik nic nie wykazuje..hmmmm ciekawy ten problem jest...🤔

Link to post
Share on other sites

Problem dotyczy juz "czystej" plytki po wpieciu Arduino..bledow w kodzie nie ma, zimnych lutow brak(ktore i tak by nic nie robily w tym przypadku)...jutro wezme tel od siostry bo aparat ma zblizenie jak mikroskop i przepatrze ten obszar..🙃

Link to post
Share on other sites

Teraz to juz nikt mi nie uwierzy...sprawdzalem one wire i co sie okazalo?? Nie dziala...ale!! Jesli odlutuje zworke od masy (innego obszaru) to zaczyna dzialac...malo tego obszar ktory zawiesza i2c moze byc podlaczony do GND i w zupelnosci nie przeszkadza to komunikacji onewire......niepojete..

Link to post
Share on other sites
(edytowany)

Patrzę na schemat. Te 3 piny GND są ze sobą zwarte na płytce Arduino? Dwa z nich wiszą? Tak ma być? 

Edytowano przez pmochocki
  • Lubię! 1
Link to post
Share on other sites
26 minut temu, pmochocki napisał:

Te 3 piny GND są ze sobą zwarte na płytce Arduino? Dwa z nich wiszą? Tak ma być?

Są zwarte. Parę razy podłączałem tylko jeden pin i działało bez zarzutu.

  • Lubię! 1
Link to post
Share on other sites
1 godzinę temu, pmochocki napisał:

Patrzę na schemat. Te 3 piny GND są ze sobą zwarte na płytce Arduino? Dwa z nich wiszą? Tak ma być? 

Tak jak kolega @ethanak prawi..masy sa polaczone na Arduino, ale i tak dla pewnosci obecnie sa podlutowane wszystkie trzy piny do GND...szkoda oczu na patrzenie, mniej wiecej jest ok...utrafilem poprostu ze zle prowadzona masa😁

Jeszcze potestuje..moze zrobie wiecej zworek miedzy tymi obszarami..? A jak nie zadziala to wiem co pomoze..noz do tapet, odseparuje wszystko od poligonu, objade kablem piny GND i bedzie dzialac..🙃

Link to post
Share on other sites
(edytowany)

Nie przyszlo mi jedno do glowy ..zmierzyc napiecia kiedy nie ma zworek miedzy masami...i jak widac jak zasilam z usb to miedzy masa 1 i masami 2/3 mam jakies lewe napiecie (te obszary mas nie sa polaczone z niczym)...te czarne to zworki ktore sa obecnie nie podlaczone...napiecia i polaryzacja jak na fotce...dodam ze plytka pusta..(tylko konektory pod moduly)...czy to jednak swiadczy o zwarciu??

Dodam ze napiecie zasilania wynosi ~5.25v mierzone na pcb, gdzie jest +/-

Edytowano przez farmaceuta
Link to post
Share on other sites

Jak mierzysz napięcie to podłącz jakiś bocznik do woltomierza - bez tego będzie odbierać Radio M.

  • Lubię! 1
Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.