Skocz do zawartości

Adapter AVR ISP- zestaw AVT


bartekwr1335

Pomocna odpowiedź

Witam. Kupiłem ostatnio adapter AVR ISP (http://www.cyfronika.com.pl/t/product_info.php?products_id=9812 )

i mam problem ponieważ nie mogę zaprogramować żadnego układu. Posiadam ATTINY26, którego otrzymałem wraz z zestawem 443-K, czyli ATTINY26 Starter Kit. Programator to STK500 v2. Czy to może być wina komputera, ponieważ to nie pierwszy raz kiedy dzieje się coś takiego. Proszę o pomoc.

Link do komentarza
Share on other sites

Na podstawie tego opisu mozna powiedzieć tylko, że COŚ robisz to żle.

Napisz w czym to programujesz i jaki komunikat dostajesz.

btw. przeczytałeś instrukcję obsługi i zalecenia producenta?

Link do komentarza
Share on other sites

Próbowałem w BASCOM AVR, niby nic nie wyskakiwało, ale też nic się nie działo. Następnie AVR DUDE i też nic oraz AVR Studio 4 i tam wyskakiwało takie coś jak Detected... FAILED. Nie zasilałem z USB ponieważ nie posiadam takiego kabla. Zasilanie dawałem z programatora, czyli było jakieś 4,33V. Aha posiadam wersję L mikrokontrolera więc według mnie powinno na tym zasilaniu chodzić, a tu nic.

Tak czytałem instrukcję bo dostałem ją wraz z zestawem.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Zainstalowałeś chociaż swojego STK500v2 zgodnie z instrukcją obsługi? Testowałem dwa typy (czyt. od dwóch sprzedających z Allegro) i przy postępowaniu krok po kroku zgodnie z pdf'ami nie miałem najmniejszego problemu z konfiguracją. Spróbuj odłączyć adapter i na samym "wiszącym" programatorze po reinstalacjach/innych próbach kliknij "Search" w SinaProg (pokazane w artykule, programator oczywiście podpięty do USB). Powinno się wyświetlić coś takiego:

avrdude: stk500v2_command(): command failed
avrdude: stk500v2_command(): command failed
avrdude: stk500v2_program_enable(): cannot get connection status
avrdude: initialization failed, rc=-1
        Double check connections and try again, or use -F to override
        this check.

zamiast

avrdude: avrdoper_open(): Device not found.

To drugie to ewidentnie zła konfiguracja/brak działających sterowników.

Link do komentarza
Share on other sites

Tak mam zainstalowanego zgodnie z instrukcją. Przepraszam za tak banalne pytania, ale gdy wczoraj wcisnąłem to co powiedział mi matrix programator chyba zadziałał bo nawet czerwona diodka się zaświeciła. Czyli chyba wszystko gra.

[ Dodano: 27-11-2010, 11:14 ]

W BASCOMIE wyskakuje znowu takie coś:

i wyłącza się to okienko.

[ Dodano: 27-11-2010, 11:22 ]

Jak zmieniłem w Programmer na STK500 native driver to wyskakuje takie coś:

Czerwona diodka też się zaświeci no ale pisze 0 bytes written to FLASH więc niewiem.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.