Skocz do zawartości

Tester serwa - problem z drganiami


BlackKnight

Pomocna odpowiedź

Witam serdecznie,

jestem nowy na tym forum tak więc od razu chciałem powitać wszystkich serdecznie. Nowy w sensie zarejestrowany bo na forum wchodzę od kilku miesięcy (wtedy jeszcze jako gość).

Mam pewien problem z testem serwa. Problem pewnie będzie dla Was banalny, ale mnie on już irytuje, a chciałbym się dowiedzieć gdzie może tkwić haczyk.

Mianowicie wykonałem tester z tego schematu : schemat 1

Zastosowałem takie same elementy jak na schemacie z tym, że dałem wieloobrotowy potencjometr bo normalnego na stanie nie mieli. To jednak chyba żadnego znaczenia nie ma. Wszystko budowane na płytce uniwersalnej (chciałem sprawdzić działanie programu przed zaprojektowaniem płytki końcowej). Zrobiłem, podpiąłem serwo Graupner'a oraz zasilanie z ładowarki telefonu komórkowego, która daje 4,8V oraz 800mA. Serwo z miejsca zaczęło mi wpadać w wibracje, kręcenie potencjometrem nic nie dawało. Zwarcie styków scalaka : 2 i 3 powodowało płynne przesunięcie dźwigni serwa do jednego z końców i blokowanie na trybach. Oczywiście chciałem tylko sprawdzić co może być nie tak, więc chwilę trzymałem w takiej pozycji.

Wymieniłem potencjometr z montażowego na normalny ale 10kOhm/A (liniowy) bo akurat taki posiadałem. Mniejszego normalnego nie mam. Jest ciut lepiej, ale od połowy zakresu dopiero serwo drga. W pierwszej połowie jest dziura gdzie do serwa impulsy żadne nie dopływają bo można nim swobodnie kręcić (w sposób mechaniczny) bez wyczuwania jakiegokolwiek oporu. Wraz z obrotem potencjometru we właściwą stronę siła drgań serwa nasila się. Można zauważyć, że teoretycznie zachowuje się dobrze, czyli zaraz za połową obrotu potencjometru serwo stara się dążyć do jednego krańca, natomiast przy końcu do drugiego. Ale drgania występują i serwo nie jest w stanie osiągnąć celu.

Próbowałem podłączyć akumulatorki (4x1,2V) ale to samo... dorzuciłem 10uF na zasilanie.. może jest nieco lepiej, ale nadal kicha.

Wykonałem także ten schemat : schemat 2

Jedynie dałem 47kOhm/A potencjometr bo taki mam akurat na stanie, 600kOhm rezystor zamiast 680 oraz 2x100nF bo 33nie mam. Mam 22nF ale to wydawało mi się za mało. Na tym 2 schemacie sposób podłączenia potencjometru jest inny niż w przypadku schematu 2. Nie zauważyłem znaczącej różnicy.

Moglibyście mi poradzić, podpowiedzieć w czym tkwi problem ? szukałem lupą czy gdzieś zwarć nie zrobiłem ale wszystko jest ok. Próbowałem z drugą kostką NE555 ale to samo.

Rozkładam ręce i dlatego też stworzyłem ten temat. W internecie niewiele wyczaiłem. Jedynie to z forum elektrody : "(...) witam

zrobiłem układ. Rewelacja po prostu.

Tylko mam problem, zasilam ten układ sieciowo i pojawiają się jakby zakłócenia.

Serwo "drży" i chyba trzeba wsadzić kondensatory tylko gdzie i jakie? (...)" "(...) uff

Rozwiązałem problem. Nieodfiltrowany prąd. Dałem baterie i git.

Tylko ne555 nie odtwarza pełnego zakresu ruchu. (...) "

Owe odpowiedzi jednego z użytkowników tamtejszego forum dotyczą schematu nr 1. Tu podsyłam linka do tego tematu : tester serw

Dziękuję bardzo za wszelką pomoc.

Pozdrawiam

---

Karol

Link do komentarza
Share on other sites

Ten drugi może nie działać ponieważ częstotliwość jest nieodpowiednia. Można zasymulować układ w LTSpice. Ten pierwszy powinien działać, ale ma mniejszy zakres regulacji wypełnienia. Pamiętaj o tym, że kondensatory mogą mieć duży błąd wartości, nawet kilkanaście %.

Pamiętaj, że nawet mając dobry sygnał, bez żródła zasilania, które będzie w stanie stabilnie zasilić NE555 oraz serwo, nie osiągniesz dobrego efektu. Mierzyłeś ile rzeczywiście wynosi napięcie zasilania? Pamiętaj, że NE555 porównuje napięcie na swoich kondensatorach z napięciem zasilania, a tam masz pewną bezwładność (RC) - czyli zakłócenia będą powodować zmianę szerokości impulsu sterującego serwem. Spróbuj dać oddzielne źródło zasilania do NE555 i serw albo kondensatory na zasilaniu (elektrolity + ceramiczne).

Link do komentarza
Share on other sites

Witam,

poddałem się z tamtym schematem, bo po dodaniu filtrowania czy 2 osobnych zasilań było to samo.

Postanowiłem zbudować sterownik (tester) na podstawie tego schematu : http://www.elportal.pl/pdf/k13/16_11.pdf

Zbudowałem 1 tor dla 1 serwa, zastosowałem filtrowanie 100nF oraz 100uF/16V dla sekcji zasilania. Wszystkie elementy są takie same jak na schemacie, tak samo podłączone itd.

Problem jest taki, że serwo odchyla się tylko w jedną stronę po czym blokuje się na trybach i buczy. Jak podłącze zasilanie z akumulatorków (~5,8V) to nie buczy i nie serwo nie próbuje się przebić przez blokadę mechaniczną. Pod zasilaczem ewidentnie wyczuwalne jest drganie trybów.

Podłączając osobno zasilanie pod serwo i osobno pod układ jest dokładnie tak samo.

Żadne regulacje potencjometrami montażowymi czy normalnym nic nie daje... :/... zauważyłem, że gdy są podłączone osobne zasilania to gdy serwo jest pod zasilaniem to odłączając układ od zasilania mija jakaś sekunda i buczenie ustępuje (tak jakby impuls się skończył).

Ktoś ma pomysł co może być nie tak ? Dlaczego akurat serwo kręci się w jedną stronę ? Gdy nie ma zasilania na serwie i przekręcając ręcznie orczyk to po podłączeniu napięcia i tak odchyla się w jedną stronę do samego końca.

Regulacje potencjometrów na sucho (bez podłączonego zasilania) nic nie daje...

Opadam z sił, bo już nie wiem co może być problemem...

Sytuacja powtarza się pod 2 różnymi serwami..

Pozdrawiam i proszę o jakąkolwiek pomoc w sprawie rozwiązania tego problemu.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

jeśli odchyla się w jedną stronę to oznacza prawdopodobnie, że zbyt krótki albo zbyt długi sygnał. Spróbuj zasymulować ten układ w LTśpice i zobacz w jakim zakresie zmienić się długość sygnału i jaką les częstotliwość.

  • Pomogłeś! 1
Link do komentarza
Share on other sites

Dzięki, tak zrobię.

Mam pytanie co do zasilania jeszcze. Ktoś mi powiedział, że tego typu układy są cholernie czułe na zmiany napięcia zasilania i może występować owe drganie itd.

Np zasilacze, gdzie nie ma idealnego napięcia, tylko zawsze w jakimś stopniu będzie drgało i to ono może być problemem. Czy to prawda ?

Bo jeśli tak no to muszę zakupić żelowe akumulatory o odpowiedniej wydajności co by mi posłużyły trochę.

Link do komentarza
Share on other sites

Jeśli zasilacz ma już wbudowany stabilizator, to nie trzeba. Chyba, że napięcie jest wyższe od tych wymaganych przez serwo/uC (zwykle ~5 V). Natomiast duży elektrolit na wejściu, w tym przypadku zawsze będzie mile widziany - w skrócie, zapobiega gwałtownym wahaniom napięcia.

  • Pomogłeś! 1
Link do komentarza
Share on other sites

Witam,

schemat działa, są jeszcze drgania, ale obracając wał potencjometru obraca się proporcjonalnie wał serwa. Drgania wyeliminuję zastosowaniem aku żelowego oraz lepszej jakości komponenty w postaci potencjometrów.

Użyłem oryginalnej płytki drukowanej tego sterownika, którą dostałem od kolegi. Widocznie na płytce testowej połączenia przewodami nie zdają egzaminu.

Mam pytanie, jak zwiększyć zakres obrotu wału ? zmniejszając potencjometr z 47kOhm na mniejszy, czy zwiększając ? Po prostu od trochę ponad połowy zakresu potencjometru wał serwa już się nie obraca (tak jakby to było jego max) - regulacje potencjometrami montażowymi nie dają rady problemowi.

Inne pytanie dotyczy samych elementów. Czy owe elementy użyte do sterownika muszą być jak najwyższej jakości ? Tolerancja jak najmniejsza ? czy i to może mieć duży, znaczący wpływ na drgania wału serwa ?

pozdrawiam

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.