Skocz do zawartości

Sterowanie silnikami ( mała moc)


Dawid 95

Pomocna odpowiedź

Witam !

Mam pewien problem .

Złożyłem płytkę ( https://www.forbot.pl/forum/upload_img/obrazki/IMG_4f1f40a8a89c63940.png ) . Wszystko gra jak na razie , mostkami mogę sterować , ale jedyna rzecz ,która nie daje mi spokoju to to ,że silniki sterując poprzez mostek TB6612 mają bardzo małą moc i prędkość mimo ,że pwm jest ustawiony na max. Czasem pojawia się problem ,ze silniki przerywają swoją pracę , a potem po jakimś czasie znowu działają , ale ten problem jest mało istotny teraz , ponieważ jako tako sobie z nim poradziłem. Dodam ,ze silniki zasilane bezpośrednio z akumulatora Li-po 2 S pracują zupełnie inaczej ( efektywniej) .

Link do komentarza
Share on other sites

Teraz mi to przyszło na myśl, nie grzeje ci się ten mostek? Bo on ma max wyjście na kanał 1.2A, pololki mają max prąd 1.6A, z tym że takie wysokie prądu to chyba tylko przy zatrzymaniu biorą.

Pomierz może napięcia na silniku przy max PWM.

Link do komentarza
Share on other sites

1. Jakie używasz silniki- HP czy nie HP

2. Zamiast PWM zacznij od zwykłego ustawienia stanu na wszystkich pinach. Napisz w tym celu jak najkrótszy i najprostszy program, który tylko ustawi wszystkie wyjścia mikrokontroler->TB6612 i sprawdź wtedy czy działa. Jak nie to pokaż program, który napisałeś.

3. Zamiast silników podłącz rezystor np. 100R i sprawdź miernikiem czy płynie prąd zgodny z prawem Ohma.

Ja widzę przynajmniej kilka możliwości:

a) zły lut - czasem piny nie stykają i dlatego mostek raz działa raz nie

b) resetowanie się procesora po włączeniu silników

c) przeciążenie mostka zbyt prądożernymi silnikami

d) zła częstotliwość PWM

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Silniki mam HP. Co do programu to wszystkie stany się zgadzają, sprawdzałem miernikiem. Teraz , jak na razie mi nie przerywa już.

Raczej mostek nie jest przeciążony bo silniki pracują w powietrzu. A w dodatku przy jeździe bez obciążenia pobierają mały prąd , z tego co pamiętam to jak mierzyłem to coś około 250 mA .

Link do komentarza
Share on other sites

Tak czy inaczej pierwsze zderzenie z przeszkodą może skończyć się dla elektroniki fatalnie 😉

Ponieważ nie zmienisz już rozkładu płytki pomyśl o przylutowaniu drugiego mostka "na plecach" pierwszego.,, brzydkie, ale nie będziesz przeciążać mostków.

PS. Jak coś nie działa, a potem bez powodu zaczyna to zazwyczaj w najważniejszym momencie (zawody, pokaz) znowu przestaje działać 😉

Link do komentarza
Share on other sites

Ale czy przyczyną małej mocy silników może być zbyt duże przeciążenie mostka ? Do tej pory jest okej z silnikami ( nie rozłącza )

Prąd zgadza się z prawem ohma.

Link do komentarza
Share on other sites

Ale czy przyczyną małej mocy silników może być zbyt duże przeciążenie mostka ?

Oczywiście że tak, mostek w najlepszym przypadku nie będzie w stanie dostarczyć tyle prądu do silników, ile naprawdę potrzebują, w związku z tym ich moc będzie mniejsza. W gorszym przypadku mostek się spali.

Jeśli znowu by ci się coś zaczęło dziać, to może spróbuj odpiąć kondy z zacisków silnika, mnie to pomogło, też mi z tymi kondensatorami silnik nierówno pracował.

Link do komentarza
Share on other sites

Po włączeniu silników zaczeły pracować ,ale po chwili zaczeły tracić obroty ( jakby pwm płynnie się zmniejszał ) aż do zera. Co do przylutowania mostka to go wlutować normalnie z tym ,że na ten obecny ? Dodam ,ze te silniki od pierwszego włączenia tak pracują ( wolno)

Link do komentarza
Share on other sites

Z jakiej biblioteki korzystałeś? Obawiam się, że naszły ci opisy na pady, a nawet tego nie zauważyłeś - wtedy tego nie da się praktycznie polutować dobrze bez drapania padów. Możliwe też, że może ta biblioteka ogólnie jest jakaś spaprana. U mnie było tak, że mostki się przeokropnie grzały i tak płynnie zmniejszały swoją prędkość (tak jakby się zmniejszało pwm). Nie jestem pewny do końca co to powodowało, ale jak wcześniej z nich korzystałem, to takich problemów nie miałem.

Link do komentarza
Share on other sites

Jeśli silniki przerywały pracę i zmniejszały obroty to zadziałało któreś z zabezpieczeń mostka, więc albo gdzieś jest zwarcie, albo silniki są uszkodzone. Zmierz pobierany prąd z akumulatorka gdy się tak dzieje.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.