Skocz do zawartości
Komentator

Kurs STM32 F4 - #3 - Sprzęt, konfiguracja środowiska

Pomocna odpowiedź

html_mig_img
Rozpoczęcie programowania STM32 z użyciem bibliotek HAL oraz kreatora graficznego Cube nie jest możliwe bez odpowiedniego oprogramowania.W tej części kursu przygotujemy sobie niezbędne narzędzia. Wcześniej omówimy jednak dokładnie zestaw Discovery, na którym będziemy pracować podczas kolejnych części kursu.

UWAGA, to tylko wstęp! Dalsza część artykułu dostępna jest na blogu.

Przeczytaj całość »

Poniżej znajdują się komentarze powiązane z tym wpisem.

Udostępnij ten post


Link to post
Share on other sites

Po podłączeniu zasilania migają diody LED LD3-LD6.

Po naciśnięciu niebieskiego przycisku diody sygnalizują ruch płytki w daną stronę.

Edit: Dlaczego w tym kursie używacie czystego eclipse a nie AC6 System Workbench for STM32?

Udostępnij ten post


Link to post
Share on other sites

Aby uniknąć kroku 5 z ostrzeżeniem w "Instalacja SW4STM32": w kroku 4 wystarczy rozwinąć "External Tools" i "OpenSTM32 Tools" i wybrać odpowiednie wersje. Np. dla Mac'a należy wybrać tak:

Udostępnij ten post


Link to post
Share on other sites

Witam, na kiedy jest przewidywana kolejna odsłona kursu?

Udostępnij ten post


Link to post
Share on other sites

Magit, artykuł pojawi się w tym tygodniu 🙂

Udostępnij ten post


Link to post
Share on other sites

Edit: Dlaczego w tym kursie używacie czystego eclipse a nie AC6 System Workbench for STM32?

Pytasz dlaczego sugeruję doinstalowywanie pakietów do Eclipse, zamiast wykorzystać instalator z OpenSTM32? Szczerze mówiąc, nie zastanawiałem się nad tym zupełnie, ponieważ w efekcie końcowym nie różnią się one w swojej funkcjonalności niczym (przynajmniej ja nic takiego nie zaobserwowałem, a pracuję równolegle na dwóch maszynach z SW4STM32 zainstalowanym na różne sposoby i cały kurs testuję na obydwu).

Udostępnij ten post


Link to post
Share on other sites

Dlaczego nie mogę pobrać pluginu do eclipse'a ze strony st?

Nie wyświetla mi się przycisk "get software" przy nazwie pliku.

Czy byłaby ewentualnie możliwość przesłania pliku na mail?

Udostępnij ten post


Link to post
Share on other sites

u mnie podobnie może coś zmieniło się w polityce udostępniania Cube'a ?

Udostępnij ten post


Link to post
Share on other sites

marhef, hansfreak, jest to ewidentnie błąd po stronie STM. Są w trakcie zmiany swojej strony, mam nadzieję, że niedługo zostanie to naprawione. W międzyczasie jedyna działająca opcja to chyba ta, która została opisana w innym temacie (sprawdziłem, działa):

https://www.forbot.pl/forum/topics49/stm32cubemx-brak-mozliwosci-pobrania-softu-ze-strony-st-vt12877.htm#108472

Udostępnij ten post


Link to post
Share on other sites

Cześć,
Mam pytanie skąd można pobrać bibliotekę, którą oferuje st do mp3? Dokładnie chodzi mi o koder.

Tutaj info z strony, lecz mamy tylko dostęp do pdf-a :

https://my.st.com/content/my_st_com/en/products/embedded-software/mcus-embedded-software/stm32-embedded-software/stm32-standard-peripheral-libraries-expansions/stm32-mp3nl-cod.html

Z góry dzięki, pozdrawiam!😉

Udostępnij ten post


Link to post
Share on other sites

elektryczny22, sprawdziłeś, czy podczas uruchomienia Eclipse "jako administrator" problem również występuje?

Udostępnij ten post


Link to post
Share on other sites

Cześć,
Potrzebuje waszej pomocy. Niestety w moim przypadku każda instalacja i próba uruchomienia czegokolwiek kończy się problemami. Do rzeczy.

Do aktualnie zainstalowanego Eclipse Mars (pod AVR) doinstalowałem SW4STM32.

Po imporcie projektu z CubeMx i próbie kompilacji otrzymuje następujące błędy:

Próbowałem sobie z tym poradzić ale poległem i pobrałem koleją wersję Eclipse.

Do "czystego" Eclipse doinstalowałem SW4STM32 i sytuacja się powtarza.

Zainstalowałem więć SW4STM32. jako samodzielny soft. Dokładnie to samo:

Domyślam się, że problem leży po stronie toolchain i Path. Niestety nie wiem jak sobie z tym poradzić.

P.S Może lepiej jak poświęcę wolny czas fotografii??

z góry dzięki.

[ Dodano: 17-03-2017, 20:15 ]

Ok. Skoro brak pomocy to zapytam inaczej. Czy po samodzielnej instalacji SW4STM32 lub instalacji jako plug-in do Eclipse, konieczna jest instalacja toolchain'a ?

Udostępnij ten post


Link to post
Share on other sites

Foadrian, brak odpowiedzi wynika z tego, że pewnie nikt nie trafił jeszcze na taki problem, a ciężko go rozwiązać, bo wynika z konkretnej konfiguracji na Twoim PC 🙁 Przekieruję zaraz temat do autora kursu, może coś poradzi.

Udostępnij ten post


Link to post
Share on other sites

Czy korzystacie z Eclipse skonfigurowanego jednocześnie dla AVR i STM32 ? Czy też dla każdej rodziny macie oddzielną "sztukę" Eclipse ?

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...