Skocz do zawartości
Komentator

Kurs elektroniki II - #9 - czujnik przeszkód, sterownik serwa

Pomocna odpowiedź

html_mig_img
W poprzedniej części kursu elektroniki omówiliśmy zasadę działania małego, ale popularnego układu czasowego - NE555.Teraz pora na ćwiczenia praktyczne. Zajmiemy się budową prostego sterownika serwomechanizmów oraz czujnika odległości. Oba układy używane są bardzo często przez modelarzy oraz robotyków.

UWAGA, to tylko wstęp! Dalsza część artykułu dostępna jest na blogu.

Przeczytaj całość »

Poniżej znajdują się komentarze powiązane z tym wpisem.

Udostępnij ten post


Link to post
Share on other sites
Z kolei, po zwarciu wewnętrznym tranzystorem wyprowadzenia 7 do masy, dioda zatyka się i C1 rozładowuje się tylko przez R2.

Wydaje mi się, że powinno być C2.

Edit:

Link pod artykułem już przenosi do tego wątku. Może nie działał bo nie było żadnego komentarza?

Udostępnij ten post


Link to post
Share on other sites
Wydaje mi się, że powinno być C2.

Faktycznie był tam błąd - ale dlaczego według Ciebie C2? On tylko filtrował zasilania razem z C1. Poprawiłem na C4 🙂

Edit:

Link pod artykułem już przenosi do tego wątku. Może nie działał bo nie było żadnego komentarza?

Albo była to kwestia cache przeglądarki - grunt, że jest już dobrze.

Gdyby problemy się pojawiły ponownie daj znać na PW podając wersję przeglądarki, na której są problemy.

Udostępnij ten post


Link to post
Share on other sites

Napisałem, że przez C2 ponieważ brałem pod uwagę oznaczenia z górnego obrazka, a nie dolnego.

Udostępnij ten post


Link to post
Share on other sites

VVasyl, słusznie - poprawione 🙂 Teraz nie będzie już żadnych wątpliwości.

Udostępnij ten post


Link to post
Share on other sites

Z animacji pracy serwomechanizmu wynika, że sygnał powinien być podawany co 20ms. Czyli 1-2ms stanu wysokiego i 19-18ms stanu niskiego. Czyli z wydłużeniem czasu trwania impulsu, czas stanu niskiego musi się zmniejszać. Dlatego nie rozumiem ostatniego zdania akapitu:

W typowej konfiguracji astabilnej, za czas trwania stanu wysokiego odpowiada suma rezystancji R1 + R2, a za stan niski tylko R2. Podczas zmiany stanu wysokiego zmieniamy również czas stanu niskiego. Jest to pewna niedogodność w sytuacji, gdy stan niski powinien trwać tyle samo.

Czy po prostu przyjmujemy, że w przybliżeniu to wszystko i tak będzie trwało ok. 20ms i na jedno wyjdzie (nie zagłębiając się w szczegóły)? Czy czegoś nie rozumiem?

Udostępnij ten post


Link to post
Share on other sites

gp, jeśli dobrze zrozumiałem pytanie, to jest tak jak piszesz, będzie to trwało ~20 ms.

Udostępnij ten post


Link to post
Share on other sites

Witam,
Mam problem z układem czujnika ruchu na 555. Zrobiłem go zgodnie z poszczególnymi krokami z obrazków, potem porównałem ze schematem, a układ po podłączeniu zasilania nie chce działać tak jak na filmiku. Dodam, że TSOP odbiera sygnał np: z pilota TV, a dioda widocznie świeci na kamerze telefonu. Po podstawieniu przeszkody przed diode i czujnik, nic sie nie dzieje. LED mryga pojedyńczo dopiero gdy wykrywanym obiektem poruszam przed czujnikiem dość szybko, ale nadal nie występuje ciągłe świecenie diody LED, ale jej pojedyńcze mryganie przy każdorazowym wykryciu przeszkody. Czy ktoś wie co może powodować takie a nie inne działanie układu?

Udostępnij ten post


Link to post
Share on other sites

Prosper, układ był składany od zera minimum 3 razy podczas pisania artykułu, więc tam raczej błędu nie znajdziemy. Polecam sprawdzić wartości rezystorów, tutaj mają one kluczowe znaczenie. Może przez pomyłkę coś zamieniłeś i układ generuje sygnał o złej częstotliwości? Spróbuj też dodać jakąś przegrodę między diodą IR, a odbiornikiem TSOP. Raczej w tym wypadku to nie pomoże, ale warto sprawdzić.

Udostępnij ten post


Link to post
Share on other sites

Prosper, mam identyczny problem. Udało Ci się go rozwiązać? Dodam, że używam napięcia 5V dlatego zrezygnowałem z diody, która miałaby obniżyć napięcie zasilania. Czy ma ktoś jeszcze podobny problem?

Udostępnij ten post


Link to post
Share on other sites

szymo092, podaj proszę orientacyjną datę zakupu zestawu - sprawdzimy, czy nie ma błędu w serii. Rozumiem, że w Twoim przypadku tester pilotów TV również działał poprawnie? Czy będziesz mógł wstawić zdjęcia swojego układu?

Udostępnij ten post


Link to post
Share on other sites

Treker, części zakupiłem około miesiąc temu. Tak, tester pilotów działa poprawnie. Jedyne co przychodzi mi do głowy to sprawdzić czy układ generatora faktycznie generuje 36 kHz. Czy mógłbyś mi podpowiedzieć dlaczego zastosowano drugi kondensator (na chemacie) C6? Dlaczego nie możemy podłączyć odbiornika tak, jak jest to pokazane w nocie katalogowej, czyli tylko rezystor i jeden kondensator? Czy to wynika z dobrania odpowiedniej wartości kondensatora? Tak jak wspomnialem, z diody D1 i rezystora R6 zrezygnowalem, ze względu na to że układ zasilam napięciem 5V. A może to jest przyczyna?

Pozdrawiam

Udostępnij ten post


Link to post
Share on other sites

szymo092, kondensator C6 dodatkowo filtruje zasilanie. Wstaw zdjęcie swojego układu, wtedy najłatwiej będzie znaleźć problem.

Udostępnij ten post


Link to post
Share on other sites

Treker, układ jest już zlutowany, dlatego przesyłam schemat. Próbowałem zmienić polaryzację diody IR, ale to nie pomaga.

Udostępnij ten post


Link to post
Share on other sites

szymo092, to ja już w takim razie nie rozumiem. Składasz zestaw z kursu, czy coś z zupełnie innego schematu? Na Twoim schemacie pojawia się bramka, elementy mają inne wartości i do tego piszesz jeszcze coś o lutowaniu. Żadna z tych rzeczy nie jest związana z tym kursem 🙁 Miejsc, w których mogłeś popełnić błąd jest znacznie więcej niż na początku to opisałeś i zależą głównie od montowanych elementów oraz lutowanego układu.

W komentarzach do kursów piszemy wyłącznie o układać 1:1 takich jak w omawianych artykułach, inaczej szybko doprowadzi to do zamieszania, bo nagle po kilku postach pt. "nie działa" okazuje się, że składasz zupełnie inny układ. Jeśli Twój problem dotyczy innego układu, innego schematu i dodatkowo są na nim jeszcze inne elementy, to będę wdzięczny za założenie osobnego tematu w odpowiednim dziale. Już sam fakt innych dzielników napięcia (z potencjometrem) i innych kondensatorów sprawia, że prawdopodobnie tam jest właśnie rozwiązanie Twojego problemu. Nie powiedziałeś nawet skąd te dane wziąłeś...

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...