Skocz do zawartości

Przegrzewanie gniazda zasilania Arduino UNO przy podłączaniu do paska ledów


Pomocna odpowiedź

Próbuję przy pomocy płytki arduino zrobić światła ledowe na przycisk zasilane kablem usb i jak podłączam arduino do zasilacza 12 V to momentalnie zaczyna się płytka podgrzewać okolicach gniazda zasilania. Skrypt jest prosty. niedawno przerobiłem sobie drugi poziom kursu arduino ale chyba brakuje mi wiedzy tylko nie wiem jakiem :/. Załączam także jak na podstawie zasilania buzzera podłączyłem wejście usb do zasilania ledów.

bool light=false;
void setup() {
  pinMode(A5, OUTPUT); //Konfiguracja A5 jako wyjście  
  pinMode(2,INPUT_PULLUP);
  digitalWrite(A5, LOW);
}
 
void loop() {
  if(digitalRead(2)==LOW&&light==false){
    digitalWrite(A5, HIGH); //Cykliczna zmiana stanu wyjścia
    delay(200);
    light=true;
  }
  else if(digitalRead(2)==LOW&&light==true){
    digitalWrite(A5, LOW);
    delay(200);
    light=false;
  }
}

291370256_5195073987272640_3927892331941174289_n.jpg

Link do komentarza
Share on other sites

(edytowany)

To wygląda na uszkodzony stabilizator liniowy (układ zaraz obok złącza DC). Jedyna opcja to wymiana...

Edytowano przez H1M4W4R1
Link do komentarza
Share on other sites

Jesteś pewien, że w układzie nie zrobiłeś żadnego zwarcia? Niestety nie za wiele widzę na tym zdjęciu ale kiedyś miałem podobny problem i okazało się że to było zwarcie w układzie. Spróbuj podłączyć samo arduino (bez układu) i zobacz czy coś się nie zmieni.

Link do komentarza
Share on other sites

2 godziny temu, StefanekP napisał:

Jesteś pewien, że w układzie nie zrobiłeś żadnego zwarcia? Niestety nie za wiele widzę na tym zdjęciu ale kiedyś miałem podobny problem i okazało się że to było zwarcie w układzie. Spróbuj podłączyć samo arduino (bez układu) i zobacz czy coś się nie zmieni.

Podłączyłem złącze usb prosto do arduino i po zapaleniu ledów tak samo momentalnie zaczęło się grzać w miejscu gniazda zasilania arduino.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

4 godziny temu, H1M4W4R1 napisał:

To wygląda na uszkodzony stabilizator liniowy (układ zaraz obok złącza DC). Jedyna opcja to wymiana...

czy chodzi o ten element?

291747515_748022212911768_2861100356611945830_n.thumb.jpg.bfd14d73dbb01db2b05c66a3dfd8e8b9.jpg

Link do komentarza
Share on other sites

5 minut temu, Janushello napisał:

Podłączyłem złącze usb prosto do arduino i po zapaleniu ledów tak samo momentalnie zaczęło się grzać w miejscu gniazda zasilania arduino.

Chodzi mi o to żebyś odłączył ledy i to co masz podłączone do arduino i zasilił samo arduino.

4 minuty temu, Janushello napisał:

czy chodzi o ten element?

291747515_748022212911768_2861100356611945830_n.thumb.jpg.bfd14d73dbb01db2b05c66a3dfd8e8b9.jpg

Tak.

Link do komentarza
Share on other sites

To sprawdź dokładnie czy nie masz zwarcia w układzie z ledami(myślę że masz). Może też być tak że układ pobiera za dużo prądu. Ile masz tych ledów?

Link do komentarza
Share on other sites

2 minuty temu, StefanekP napisał:

To sprawdź dokładnie czy nie masz zwarcia w układzie z ledami(myślę że masz). Może też być tak że układ pobiera za dużo prądu. Ile masz tych ledów?

mam 2 paski po 15 ledów tylko nie wiem w jaki sposób mam to sprawdzić :/.

Na pasku co jakiś czas jest napisane 5V. Na zdjęciu będzie lepiej widać jak to wygląda.

291736035_2036924409842179_559294801283519146_n.thumb.jpg.6cda533e40e2030d5b1454d114e5b50d.jpg

Link do komentarza
Share on other sites

5 minut temu, Janushello napisał:

A czy jak podpinam ledy do 5V to nie powinno pobierać odpowiedniej ilości prądu?

Jeżeli podpiąłeś LED'y do Arduino, a nie do zasilacza 5V to się nie dziwię, że stabilizator się przegrzał i uszkodził... Jego teoretyczna maksymalna wydajność to 1A (w rzeczywistości bliżej 0.6-0.7A). Nie widzę jakie rezystory są przy tych LED'ach, ale zakładając pobór prądu 20mA na LED'a to przy podpięciu 30 LED'ów same LED'y pobierałyby 0.6A, a jeszcze dochodzi mikrokontroler, układ scalony UART i straty na komponentach.

Układ pobierze odpowiednią ilość prądu, ale czy zasilanie to wytrzyma to inna sprawa. Arduino nie ma zabezpieczeń OCP/OVP i bardzo łatwo coś uszkodzić.

  • Lubię! 1
Link do komentarza
Share on other sites

1 minutę temu, Janushello napisał:

To powinienem wymienić stabilizator i dodatkowo dodać rezystory idące do ledów na kostce stykowej? 

Myślę że skoro po odłączeniu ledów  działa ok to stabilizatora nie trzeba wymieniać 

Link do komentarza
Share on other sites

1 godzinę temu, StefanekP napisał:

Myślę że skoro po odłączeniu ledów  działa ok to stabilizatora nie trzeba wymieniać 

czyli dodać rezystorów tylko ile rezystancji potrzebuję? mogę to jakoś obliczyć na podstawie samych ledów i tego że na pasku białych ledów jest 5V? tylko jak mam podstawić pod wzór Uzasilania ma być z zasilacza (12V)czy 5V czyli pin z arduino? Rozumiem ze Idiodyma być 0,2A, a Udiody jak mogę sprawdzić?

Link do komentarza
Share on other sites

11 minut temu, Janushello napisał:

czyli dodać rezystorów tylko ile rezystancji potrzebuję?

Nie, użyć oddzielnego zasilania do pasków i do Arduino.

  • Lubię! 1
Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.