Skocz do zawartości
Komentator

Kurs STM32 - #3 - Płytka Nucleo, konfiguracja środowiska

Pomocna odpowiedź

@danielbr3 witam na forum 🙂 Proponowałbym sprawdzić połączenie za pomocą innego kabla USB (jeśli masz do niego dostęp). Czy wszystkie zworki masz na płytce założone w poprawny sposób? Wgrałeś najnowsze wersje sterowników? Czy układ jest wykrywany przez ST-LINK Utility?

Udostępnij ten post


Link to post
Share on other sites

Witam,

Mam już zainstalowane sterowniki i podłączoną płytkę, ale w menadżerze urządzeń brakuje programatora STLink. Jak temu zaradzić ?

Udostępnij ten post


Link to post
Share on other sites

@Martiszka witam na forum 🙂

Ogólnie ten proces nie powinien sprawiać problemów. Warto sprawdzić standardowe rzeczy typu restart komputera, ponowne podłączenie zestawu do PC, a w ostateczności przeinstalowanie sterowników. Raczej wszystko powinno zaskoczyć bez żadnych problemów 🙂

Udostępnij ten post


Link to post
Share on other sites

nie mogę zaprogramowac PIERWSZEJ lekcji już mnie trzęsie

sterowniki wygląda na to że zainstalowane poprawnie a bydle nie che ruszyć proszę o jakąś podpowiedź 

system win7 professional 64biy płytka od was NUCLEO F103RB

frimware wgrany najnowszy z linku z lekcjii

STM32-erroor0.jpg

Udostępnij ten post


Link to post
Share on other sites

@cyberluk witam na forum 🙂

Po pierwsze proponowałbym wykonywać ćwiczenia z nowszej wersji kursu, czyli z tej: Kurs STM32 F1, migracja na HAL – #1 – wstęp, spis treści. W tej chwili czytasz starszą wersję, która właściwie jest zarchiwizowana. Ten sam zestaw możesz wykorzystać do wykonania ćwiczeń z linkowanego, nowszego kursu. Po drugie, jeśli masz problem z wykorzystywaniem programatora to zawsze warto sprawdzić czy jest on poprawnie wykrywany przez program ST-LINK Utility. Sprawdź czy możesz za jego pomocą odczytać informacje o podłączonym zestawie. Oprócz tego, warto również sprawdzić poprawność zworek na zestawie Nucleo. Programowanie tych płytek raczej nie sprawia problemów, w zdecydowanej większości przypadków wszystko działa od razu.

PS jeśli posiadasz nasz zestaw do tego kursu to go zarejestruj, może się to przydać w przyszłości. W tej chwili do Twojego konta przypisany jest tylko zestaw do kursu Arduino.

Udostępnij ten post


Link to post
Share on other sites

1. czytam już aktualną wersje kursu

2. sprawdziłem ST-Link Fruwa (załaczam preentscreena)

STM32-erroor1.thumb.jpg.85638f2c3f8673191bcd476fbda07449.jpg

3.zworki są jak na zdjęciu z kursu

4. zarejestrowałem

 

I nadal ni to samo co to może być wszystkie drivery zsintalowane świeże ze stronki st pod 64bity

ST-Link furwa

Udostępnij ten post


Link to post
Share on other sites

@cyberluk w takim razie mamy przynajmniej pewność, że sprzęt jest sprawny. Dla formalności polecałbym test po restarcie komputera (aby nie okazało się, że z jakiegoś powodu ST-Llink Utility cały czas ma dostęp do programatora i blokuje używanie innego softu). Problemem może być też Windows 7, ale tego niestety nie jestem w stanie teraz weryfikować (nie ma dostępu do PC z takim systemem). Tymczasowo możesz spróbować wgrywać program właśnie przez ST-Link Utility (wskazujesz wygenerowanego hex'a i normalnie wgrywasz). Możliwe, że w między czasie ktoś inny potwierdzi, że miał (lub nie) jakieś problemy na Windowsie 7. Nie przypominam sobie jednak, aby takie problemy występowały wcześniej. Możliwe, że wynika to z jakiejś unikalnej dla Ciebie konfiguracji sprzętu/oprogramowania.

Udostępnij ten post


Link to post
Share on other sites

wyweszylem jedną różnice

w zrzucie z kursu przed klikniecie run jest wyświetlona płytka raczej rodzaj zaznaczyłem na czerwonym kółkiemm

STM32-erroor2.thumb.jpg.beeb48124fe228723fa6ee76e9fd6aca.jpg

może coś przy instalacji mi ukneło ale cały proces gniotłem dwa razy od początku

Udostępnij ten post


Link to post
Share on other sites

Już się gubię, bo wklejasz tutaj zrzuty nie z tego kursu. W kursie, który własnie komentujesz okno to wygląda tak samo jak u Ciebie. Na zrzucie pokazujesz fragment z drugiego kursu. Pisz proszę w komentarzach do artykuły, który ostatecznie wykonujesz, bo inaczej się pogubimy. Czy wykonałeś ten fragment od: "Teraz czeka nas ważny krok, czyli wybór mikrokontrolera oraz płytki. W polu Series wybieramy STM32F1, a następne jako Board wybieramy NUCLEO-F103RB. Konfiguracja powinna wyglądać następująco"?

Udostępnij ten post


Link to post
Share on other sites

zdjecie wziołem z tego kurus niby aktualnego co podałeś linka

 

Udostępnij ten post


Link to post
Share on other sites
19 godzin temu, cyberluk napisał:

zdjecie wziołem z tego kurus niby aktualnego co podałeś linka

@cyberluk wiem, że zrzut wziąłeś z innego kursu, właśnie to napisałem w mojej wiadomości. Takim działem wprowadzasz zamieszanie w komentarzach.

Przypominam o PPF - bardzo chętnie pomożemy, ale musisz dać nam szansę. Czyli podawaj więcej szczegółów, pisz w odpowiednim temacie i staraj się pisać w taki sposób, aby można było łatwo zrozumieć Twoją sytuację i odtworzyć problem. Napisałem wyżej kilka porad (próba po restarcie PC, próba wgranie hex'a z ST-Link Utlity, zapytałem też czy wykonałeś konkretny fragment ćwiczenia), ale nie dałeś żadnej odpowiedzi w tym kontekście. Niestety ciężko rozwiązać problem, który najwyraźniej jest związany z konkretną konfiguracją Twojego komputera, jeśli nie odpowiadasz na wszystkie pytania.

Udostępnij ten post


Link to post
Share on other sites

ok

Dzięki za poradę programy z kursu ląduje ST-linkiem bez problemu

ale obraz z twojego linku niby z aktualnego kursu 😉

22 godziny temu, Treker napisał:

@cyberluk witam na forum 🙂

Po pierwsze proponowałbym wykonywać ćwiczenia z nowszej wersji kursu, czyli z tej: Kurs STM32 F1, migracja na HAL – #1 – wstęp, spis treści. W tej chwili czytasz starszą wersję, która właściwie jest zarchiwizowana. Ten sam zestaw możesz wykorzystać do wykonania ćwiczeń z linkowanego, nowszego kursu. Po drugie, jeśli masz problem z wykorzystywaniem programatora to zawsze warto sprawdzić czy jest on poprawnie wykrywany przez program ST-LINK Utility. Sprawdź czy możesz za jego pomocą odczytać informacje o podłączonym zestawie. Oprócz tego, warto również sprawdzić poprawność zworek na zestawie Nucleo. Programowanie tych płytek raczej nie sprawia problemów, w zdecydowanej większości przypadków wszystko działa od razu.

PS jeśli posiadasz nasz zestaw do tego kursu to go zarejestruj, może się to przydać w przyszłości. W tej chwili do Twojego konta przypisany jest tylko zestaw do kursu Arduino.

więc już nie kumam o co chodzi z tymi kurasami które są aktualne które nie 😞

co robić czym się sugerować ?

Udostępnij ten post


Link to post
Share on other sites

@cyberluk napiszę najprościej jak to możliwe 🙂 Jeśli wykonujesz ćwiczenia z nowszego kursu, który linkowałem to świetnie, bo to jest nowsza wersja kurs i tego trzeba się trzymać. Pisz jednak wtedy w komentarzach do tamtego kursu, aby ludzie, którzy trafiają na Twoje pytania wiedzieli, który artykuł dokładnie komentujesz. Teraz cały czas błędnie piszesz w komentarzach do starej wersji kursu, co sygnalizuję już od pierwszej wiadomości. Reasumując: wykonujesz instrukcje z nowego kursu, a piszesz w komentarzach do starego, co wprowadza zamieszanie.

Udostępnij ten post


Link to post
Share on other sites

ok tera kumam nie w tym poście co trzeba pisze przenoszę temat sorki

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...