Skocz do zawartości

Pomocna odpowiedź

Witam,

Mam problem i to dosyć spory, ponieważ zepsułem swoje arduino leonardo w taki sposób, że podłączyłem zły zasilacz i zamiast DC, arduino otrzymało 12V AC. Zwracam się z pomocą gdzie szukać problemu i czy w ogóle istnieje możliwość naprawy. Chciałbym sam naprawić uszkodzony element. Dlatego też pisze na forum o pomoc  od czego zacząć sprawdzanie czy dany element jest okej czy też nie. Oczywiście o ile jest możliwość wskrzeszenia tego maleństwa. Z góry dzięki za pomoc :). Ja osobiście na pierwszy rzut oka nie widzę żadnych zmian ale wrzucam zdjęcie dla osób które może coś dostrzegą.

IMG_20190716_194206.jpg

IMG_20190716_194155.jpg

Udostępnij ten post


Link to post
Share on other sites

Czy układ przestał działać również podczas zasilania przez USB?

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Podpinając przez USB świeci się dioda LED "ON" oraz "L" ale komputer tego nie widzi

Edytowano przez Famous_Deer

Udostępnij ten post


Link to post
Share on other sites

Temat uważam za zamknięty udało mi się znaleźć winowajce.

Udostępnij ten post


Link to post
Share on other sites

@Famous_Deer pochwal się w takim razie rozwiązaniem, na pewno przyda się komuś w przyszłości 😉

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Podłączyłem przewód USB do ładowarki telefonu o wyjściu 5V, następnie tym samym przewodem podpiąłem arduino przez co wyczułem wydzielanie się sporej ilości ciepła w okolicy zewnętrznego zasilania. Po przeanalizowaniu schematu ze strony arduino stwierdziłem że winowajcą na 90% jest dioda, więc wylutowałem ją wraz z kondensatorem, który znajdował się obok niej ( w moim przypadku była to konieczność ze względu dosyć sporej wielkości grot lutownicy). Schemat arduino oraz zdjęcie z elementem który należy wylutować wstawiam w załączniku (czerwone kółko, na schemacie jest to lewy górny róg dioda D1 M7 oraz kondensator C10 10u). Jeżeli ktoś nie ma zamiaru używać zewnętrznego zasilania na arduino to nie ma obaw, ponieważ bez tych dwóch elementów jest w pełni sprawne. Jeżeli natomiast ktoś by chciał wlutować nowe elementy to kondensator jest o pojemności 10µF, natomiast jeżeli chodzi o diodę to miałem problem znalezieniem jej, ponieważ na schemacie jest to pojedyncza dioda M7 natomiast na płytce jest to coś w tym stylu, dlatego też nie podaje elementu zastępczego dla naszej diody, moim zdaniem jest to coś takiego https://www.tme.eu/Document/f469f1bd2d3983ce14288ec945c32fac/gsot.pdf ale pewności nie mam. Mam nadzieje że jasno opisałem co i jak trzeba zrobić :).

arduino.jpg

Leonardo_Rev3d_sch.pdf

Edytowano przez Famous_Deer
  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Myślę, że wystarczyło wywalić diodę i ewentualnie wymienić stabilizator napięcia skoro atmega działa. Jaką według Ciebie funkcję może pełnić ta dioda? Jeśli dioda padła to stabilizator pewnie też jeśli długo było podłączone odwrotnie ale trzeba to sprawdzić. Swoją drogą, wiedząc do kogo przeważnie trafiają te płytki projektanci mogli tam dołożyć jakieś solidne zabezpieczenie na wypadek odwrotnego podłączenia zasilania. Stabilizatory napięcia są bardzo wrażliwe na odwrotną polaryzację.

3 godziny temu, Famous_Deer napisał:

dlatego też nie podaje elementu zastępczego dla naszej diody, moim zdaniem jest to coś takiego

a moim zdaniem to jednak zwykła dioda jak na schemacie bez różnicy w jakiej obudowie.

3 godziny temu, Famous_Deer napisał:

Mam nadzieje że jasno opisałem co i jak trzeba zrobić :).

Opisałeś raczej czego nie robić - nie podłączać zasilania odwrotnie 🙂

Diodę możesz wywalić zupełnie i jeśli stabilizator padł to wymienić stabilizator i powinno działać jak nowe. Ostatecznie zasilać tylko z usb.

Udostępnij ten post


Link to post
Share on other sites

Bo to prawda wystarczyło wywalić diodę, ja opisałem dlaczego wylutowałem również kondensator.

16 minut temu, atMegaTona napisał:

Opisałeś raczej czego nie robić - nie podłączać zasilania odwrotnie

 Opisałem schemat mojego działania, ponieważ nikt nie był w stanie mi pomóc więc musiałem sam szukać problemu, fakt żeby nie podłączać zasilania AC uwzględnia mój pierwszy post.

Udostępnij ten post


Link to post
Share on other sites

Fakt, nie doczytałem chyba i gdzieś przeoczyłem wcześniej twój post. Być może dzięki temu, że AC a nie odwrotnie nie przepaliłeś stabilizatora. Ta dioda tam nie jest niezbędnie konieczna do poprawnego działania tak jak kondensator ale szczególnie kondensator poprawia właściwości zasilania więc zostawił bym go tam jednak, co do diody sam zdecyduj czy Ci się przyda jeśli wiesz po co ona tam jest w ogóle. Tak czy inaczej gratuluję skutecznej "naprawy", zawsze jakieś doświadczenie na początek.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...