Skocz do zawartości
Ketchupex

Instalacja środowiska ISE (Windows 10)

Pomocna odpowiedź

Cześć jestem tu nowy zakupiłem niedawno płytkę Elbert V2 do Waszego kursu, mam pytanie dotyczące instalacji środowiska ISE, która wersja będzie dla mnie najbardziej kompatybilna z zestawem ( mam windows 10 ) w instrukcji dotyczącej kursu jest podana wersja dla windowsa 7 powinienem ją zainstalować, czy pobrać wersję dla mojego windowsa 10? aktualizowaną 2018r. czy pobranie nowszej wersji znacząco  utrudni mi  "przejście" kursu?

Pozdrawiam

Udostępnij ten post


Link to post
Share on other sites

Z tego co pamiętam to wersja dla windowsa 7 będzie odpowiednia dla windowsa 10.

U mnie działa, jak mawia programista 😀

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

@Ketchupex, ja miałem identyczną sytuację i mi ISE pod Windows 10 w ogóle nie chciało działać, a mam Win10 😄 Ta z Win7 działa na dziesiątce bez problemu i dało się przejść cały kurs.

  • Lubię! 1
  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Potwierdzam, wersja dla W7 będzie odpowiednia 🙂

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Pobrałem, wszystko działa chyba dobrze, nie wiem tylko czemu przy "Dodawanie gotowego pliku ucf" po kliknięciu add source na pliku vhdl program natychmiast się wyłącza (nie podaje żadnego komunikatu itp.)

Udostępnij ten post


Link to post
Share on other sites
37 minut temu, Ketchupex napisał:

Pobrałem, wszystko działa chyba dobrze, nie wiem tylko czemu przy "Dodawanie gotowego pliku ucf" po kliknięciu add source na pliku vhdl program natychmiast się wyłącza (nie podaje żadnego komunikatu itp.)

Cześć,

tak właśnie to działa pod Win10. Sprawdź, czy nie dzieje się to podczas syntezy (i fazy implementacji). Mi np. nie działa w ISE pod Win10 symulacja układu, a bez tego nie możesz być pewnym, że zaprojektowany układ działa prawidłowo. Kiedyś działała symulacja - przestała działać po którejś aktualizacji Windows 10 😉

Pozdrawiam.

  • Lubię! 2

Udostępnij ten post


Link to post
Share on other sites

Sprawdzałem wszystko jest zaznaczone na "Ok" po przebiegu symulacji, nie ma też żadnych zdiagnozowanych ostrzeżeń/błędów. 

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Niestety to środowisko ma już swoje lata i nie jest wspierane. Wybraliśmy jednak tego "starocia" specjalnie. Niestety na niektórych polskich uczelniach ISE w tej wersji cały czas jest popularne. Materiały o FPGA w większości przypadków są wykorzystywane przez studentów, więc chcieliśmy się trzymać oprogramowania, które spotykane jest na laboratoriach. Cieszę się jednak ostatecznie u Ciebie wszystko działa poprawnie 😉

Udostępnij ten post


Link to post
Share on other sites

@Ketchupex a w jakiś ścieżkach masz ISE i projekty? Nie masz gdzieś polskich znaków lub spacji w ścieżce do pliku? Nie kojarzę, aby ktoś zgłaszał taki błąd, więc to raczej musi być coś związanego bezpośrednio z Twoją konfiguracją.

Udostępnij ten post


Link to post
Share on other sites

Wstawiam w załącznikach screeny z przebigu konfiguracji nie wiem czy to ma jakiś związek, ale wybierając "open project" z project commands również dochodzi do natychmiastowego wyłączenia.

myganieledzdj.PNG

mryganieled2.PNG

mryganieled3.PNG

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Cześć,

nie rozumiem, po co piszesz, że wszystko jest OK. Nic Ci nie działa prawidłowo - tak właśnie jak u Ciebie objawiają się błędy tego środowiska. pod Windowsem 10 Prawdopodobnie odpalasz wersję 64-bitową "Project Navigator ISE" - ta wersja nigdy nie działala  mi poprawnie pod Windows10 . Zlokalizuj wersję 32-bitową (gdzieś w podkatalogu bin) i ją uruchom - prawdopodobnie nie będzie już tego błędu  (zamykania się środowiska). Faktu, iż nie działa symulacja u Ciebie jestem prawie pewien (pewnie pomyliłeś ją z fazą syntezy i implementacji). Pisałeś, lub uruchamiałeś "test bench", żeby uruchomić symulację. Używaj tylko wersji 32-bitowej środowiska, bo tylko ona (w niepełnym zakresie) działa dla Windows10 prawidłowo. Najlepiej zainstalować ISE pod Linuxem (tam działa to dobrze).

Scieżka do 32-bitowego "Project Navigatora pod Windows10 to :

Cytat

TwójKatalogInstalacyjny\14.7\ISE_DS\settings32.bat E:\Xilinx\14.7\ISE_DS\ISE\bin\nt\ise.exe

Pozdrawiam

BTW: do przejścia kursu FPGA Forbota na Elbercie  na szczęście nie jest potrzebna dziłająca opcja symulacji.

Edytowano przez FlyingDutch
  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Nie spodziewałem się, że będę mieć takie problemu już od początku, starałem się robić wszystko  krok po kroku jak w innych kursach, czy jest możliwe, że uszkodziłem płytkę wybierając bezpieczniejszą opcję poprzez wgrywanie gotowego pliku ucf? Po zmianie na wersję 32 bitową udało się dodać źródło, ale w chwili puszczenia programu w ElbertV2Config diody które mrygały (domyślnie  jedna po drugiej zgasły). Świeci się teraz tylko d10 (czerwona) , d9 (niebieska) i wyświetlacz. Komputer nie widzi urządzenia jak wcześniej (sterownik był zainstalowany):

606678392_braksterownika.thumb.PNG.875fd816660effb3368946fa151e4435.PNG

Udostępnij ten post


Link to post
Share on other sites

@Ketchupex teoretycznie jest szansa uszkodzenia płytki, ale dość mała. Chyba jeszcze nie było sytuacji, aby ktoś ją bezpowrotnie uszkodził 🙂 Powiedz najpierw dla pewności czy na pewno wgrałeś odpowiedni ucf i nie było podczas tego wgrywania żadnego błędu?

Udostępnij ten post


Link to post
Share on other sites
4 godziny temu, Treker napisał:

@Ketchupex teoretycznie jest szansa uszkodzenia płytki, ale dość mała. Chyba jeszcze nie było sytuacji, aby ktoś ją bezpowrotnie uszkodził 🙂 Powiedz najpierw dla pewności czy na pewno wgrałeś odpowiedni ucf i nie było podczas tego wgrywania żadnego błędu?

Cześć,

jeśli wgrałeś plik UCF z błędnym mapowaniem pinu zegara to jak najbardziej mogłeś uszkodzić płytkę FPGA (jest to problem specyficzny dla modelu Elbert V2). Przydarzyło się to już Elvisowi i mnie. W najgorszym przypadku będziesz musiał przeciąć jedną ścieżkę na płytce i wgrać poprawny plik projektu (z prawidłową definnicją zegara w pliku ucf).

Patrz ten linki:

 

Tam masz opisane jak można naprawić Elbert'a.

Pozdrawiam

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...