Skocz do zawartości

Tester czujników odbiciowych


aixI

Pomocna odpowiedź

Przecież to nic skomplikowanego. Możesz podłączyć czujnik pod procesor z ADC lub prościej użyć komparatora, a na wyjściu wpiąć LED'a. W najprostszej wersji możesz zasilić LED'a w czujniku, podpiąc odpowiednio fototranzystor, a zamiany na wyjściu sprawdzać miernikiem - do testu wystarczy.

Link do komentarza
Share on other sites

Spójrz sobie na linefollowery opisane na forum. Większość z nich ma odpowiednie komparatory, możesz skopiować sobie schemat.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

🙂 przerobiłem po swojemu ten schemat na 1 czujnik. Tamtego nie zrobię bo na razie pod ręką nie mam LM324, ale mam LM358.

Czy jest wszystko ok? I czy w ogóle będzie działało? Oczywiście VCC pin 8, a GND pin 4.

Link do komentarza
Share on other sites

aixI, jeśli będziesz testował CNY70 to musisz pamiętać, że katoda diody i emiter fototranzysora nie są obok siebie tylko w rogach po przekątnej, więc twój układ pinów nie będzie pasował do CNY70.

Link do komentarza
Share on other sites

Ja zamiast tego całego komparatora dałbym po prostu wyjście na woltomierz. Multimetr na pewno masz więc mogłbyś widzieć dużo więcej niż tylko LED "świeci" lub "nie świeci". Zmieniając wartości opornika wyjściowego (R12) miałbyś szansę dobierania czułości oraz określenia czy granice zadziałania są poprawne. Znając napięcie wyjściowe mógłbyś też porównywać czułość kilku czujników w tych samych warunkach (ta sama "przeszkoda" w tej samej odległości).

W wersji z komparatorem dodałbym histerezę. Bez niej zaryzykowałbym ocenę, że układ nie jest porawny.

Link do komentarza
Share on other sites

Mam chyba mały problem, mianowicie podłączyłem do tego układu zasilanie kiedy nie było podłączonego czujnika (gapa ze mnie) Jak zauważyłem, że nie ma czujnika to szybko odłączyłem, podłączyłem czujnik i zasilanie, dioda sygnalizująca zapaliła się po czym zgasła. Sprawdziłem miernikiem, czy nic się nie stało scalakowi i wyszło mi tak: białe tło: pin1-ok.3V, pin2-0,41V, pin3-1,99 / czarne tło: pin1-ok.3V, pin2-1,12V, pin3-1,99V

Jak układ podłączam do zasilania jak "odpocznie" to przez chwile działa poprawnie po czym dalej to samo. Co może być nie tak?

AixI.

Link do komentarza
Share on other sites

Ja tu nie widzę nic dziwnego. Dopóki napięcie na wejściu (+) jest większe od tego na wejściu (-), na wyjściu masz stan "wysoki" i LED nie świeci.

Jeżeli na pinie 3 ustawiłeś sobie 2V to na wejściu z czujnika musi być więcej, by diodka się zapaliła a to napięcie waha się od 0.4 do 1.2V czyli nie przekracza 2V. Zasłoń go czymś tak, by w ogóle nie widział żadnego światła i powinna się zapalić. Twój tester reaguje na brak przeszkody a nie na jej pojawienie się.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.