Skocz do zawartości
Komentator

Kurs Raspberry Pi - #6 - instalacja/komunikacja przez sieć

Pomocna odpowiedź

Podłączyłem RPi przez monitor i wyskoczyło mi okienko, że SSH jest odblokowane i należy ze względów bezpieczeństwa ustawić hasło, więc hasło ustawiłem. Dodatkowo w konfiguracji upewniłem się, że SSH jest odblokowane, więc tutaj sprawa jest jasna. 

 

Jeśli chodzi o router to mam LiveBoxa więc to router dostarczony przez operatora Internetu. Także nie mam pojęcia o co chodzi 😕 ale szukam dalej.

Udostępnij ten post


Link to post
Share on other sites

@Oskaritox ok, a czy po podłączeniu się przez monitor i sprawdzeniu SSH oraz aktualnego adresu IP próbowałeś się połączyć zdalnie przez RPi? Nie musisz odłączać monitora. Jest jakaś szansa, że LiveBox w tym miesza (mogą być nałożone jakieś ograniczenia co do komunikacji na konkretnych portach), ale to lepiej zostawić do sprawdzenia jako ostateczność 🙂

Udostępnij ten post


Link to post
Share on other sites

Więc tak, podłączam się przez kabel sieciowy do RPi oraz do monitora, plik SSH wgrywam tak jak zawsze. RPi od razu łapie mi Wifi co widzę na monitorze, a jak wyłącze WiFi to przełącza mi się na kabel i internet mam. Także nie mam zielonego pojęcia o co chodzi. IP znajduje bez problemu za pomocą komendy arp- a. Tylko nie moge zrozumieć czemu znajduje mi i łączy po WiFi, czy to jest zasługa Noobsa zainstalowanego na karcie SD tak jak było to przy pierwszym podłączeniu?  

Udostępnij ten post


Link to post
Share on other sites

@Oskaritox dane do WiFi musiałeś gdzieś podać - albo w GUI, albo w pliku konfiguracyjnym. Przy czystej instalacji nie byłoby żadnych informacji na temat "starego" WiFi 🙂

Udostępnij ten post


Link to post
Share on other sites

Problem rozwiązany. Po paru próbach przy pomocy wskazówek z forum RPi (m. in. ping z RPI do kompa itp) poszedłem po prostu dalej z kursem i łączyłem się za pomocą UART. Przy 7 lekcji nie wiem co się stało, ale jak zacząłem robić krok po kroku czyli ściągnięcie VNC Viewer itd zauważyłem, że łączy mi się za pomocą SSH przez Putty już po generacji klucza przez Putty gen. Po prostu odłączyłem UART i zrestartowałem malinke, po czym już przy pomocy samego Wifi, który malina miał już odpalony zlokalizowałem RPi i się połączyłem bez problemu przez SSH. Także nie wiem o co chodziło, może nie doprecyzowałem wszystkiego w w/w opisie ale najważniejsze, że działa 🙂

 

Pozdrawiam

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

@Oskaritox super, najważniejsze, że działa 🙂 Powodzenia w dalszych eksperymentach, gdyby były jakieś nowe problemy to śmiało pytaj i będziemy wspólnie kombinować 🙂

Udostępnij ten post


Link to post
Share on other sites

Co jeśli komputer nie widzi adresu ip malinki(bezpośrednie połączenie) ? Nie  mam monitora, żeby włączyć rpi jako pc. Na razie udało mi się połączyć tylko przez uart. Proszę o pomoc.

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

@jas123 możesz użyć skanera urządzeń danej puli adresów. Jeżeli RPi masz podłączone w sieci lokalnej najpewniej będzie to adres z puli 192.168.1.0-255. Sprawdź poleceniem ipconfig/ifconfig w cmd/terminalu jaki masz adres w sieci lokalnej. Program może być np. Advanced IP Scanner.

Inny sposób to mDNS. Na linuxach jest to domyślnie zainstalowane i po prostu w programie do SSH wpisujesz hostname w miejsce adresu. Na windowsie instalujesz Bonjure (taki sterownik dla drukarek od Appla...), odpalasz Putty i w polu adresu wpisujesz hostname raspberry pi (raspberry albo raspberrypi ale raczej to pierwsze).

Edytowano przez Gieneq
  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites
29 minut temu, Gieneq napisał:

instalujesz Bonjure (taki sterownik dla drukarek od Appla...)

Błagam, błagam...

Bonjour (to po francusku jest) a nie Bonjure. I czymkolwiek nie byłby Bonjour nie jest to sterownik dla drukarek od Appla...

I (przynajmniej pod Linuksem i Macem) nie wpisuje się hostname, a hostname.local - ot, drobna różnica...

 

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Dziękuję za dopełnienie.

I Bonjour monsieur 🙂 

Udostępnij ten post


Link to post
Share on other sites

To przy okazji: tutaj jest pokrótce opisane co to jest i jak to można zainstalować na Windows.

Udostępnij ten post


Link to post
Share on other sites

Próbowałem znaleźć IP w advanced IP scanner i nic , w cmd pisałem ipconfig i tez nic nie widać, wpisywałem arp -a i też nic. Przed chwilą jeszcze raz wszystko posprawdzałem i po wpisaniu arp -a pokazuje mi jakieś nowe IP 😀.Teraz wszystko działa. Zastanawia mnie tylko , dlaczego  adres MAC zaczyna się od dc-a6-32- , a nie od b8-27-eb- jak było powiedziane w kursie.

Udostępnij ten post


Link to post
Share on other sites
6 minut temu, jas123 napisał:

dlaczego  adres MAC zaczyna się od dc-a6-32- , a nie od b8-27-eb- jak było powiedziane w kursie

Może dlatego, że ktoś napisał kurs, a dopiero potem się okazało że skończyła się pula 0xffffff adresów mac i trzeba przydzielić następną? Pamiętaj, że adres MAC jest unikalny w obrębie całego świata i każde urządzenie musi mieć inny!

Zajrzyj na https://macvendors.com/ - zobaczysz co oznaczają oba prefiksy.

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Witam, mam pewien problem z połączeniem malinki do internetu a co za tym idzie nie mogę odnaleźć jej adresu. Malinka nie jest w stanie się połączyć z moją siecią wi fi (inne urządzenia łączą się normalnie). Do innej sieci (np. hot spot z telefonu) malinka się łączy. Dodam również, że do mojego routera na kablu działa internet jednak dalej nie moge odnaleźć jej adresu. Nie wiem w czym jest problem z moim routerem i nie wiem jak go przekonfigurować żeby można się było łączyć.Z góry dziękuje za pomoc.

Edytowano przez hardcorzanin

Udostępnij ten post


Link to post
Share on other sites

A czy w telefonie do udostępniania internetu masz ustawione hasło? Bo jeśli nie, to to może być trop. Sprawdź czy w pliku konfiguracyjnym wpa_supplicant.conf nie masz błędu w haśle. Sprawdź też czy przypadkiem nie masz w routerze ustawionego WEP`a (choć ciężko w to uwierzyć).
Napisz jaki to router i  jaki ma typ szyfrowania.
Skoro po kablu masz w Malinie internet, to i IP musi być widoczne. Tylko wtedy sprawdzasz nie na wifi0, wifi1, itd, tylko na eth0, eth1, itd. Podłącz malinę po kablu tak, żebyś miał internet i napisz co masz w konsoli po poleceniu ifconfig

 

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...