Skocz do zawartości
Komentator

Kurs Raspberry Pi - #6 - instalacja/komunikacja przez sieć

Pomocna odpowiedź

Dnia 3.10.2018 o 11:12, konrad98ft napisał:

Dodatkowo po podłączeniu karty SD do komputera okazało się, że zniknęły pilki ssh i wpa_supplinant.conf (ich ponowne wgranie nic nie dało).

Znikanie tych plików to poprawna zachowanie systemu. One tylko informują system o ustawieniach, które chcesz wprowadzić. System czyta informacje, wprowadza zmiany, a pliki znikają, bo nie są już potrzebne.

Dnia 30.09.2018 o 00:21, konrad98ft napisał:

gdy jednak podłączę do niej monitor mogę normalnie przeglądać strony internetowe, kiedy użyje komendy pokazującej ip także je otrzymuje.
Jednak mój laptop cały czas "nic nie widzi". W czym może być problem?

Jakie IP otrzymuje Raspberry Pi, a jakie malinka?

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Mam problem przy zalogowaniu się do Terminalu 
Login: pi 

Hasło: raspberry

i wyskakuje Access denied

co można z tym zrobić ?

Udostępnij ten post


Link to post
Share on other sites

@kamlixd, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.
5 minut temu, kamlixd napisał:

wyskakuje Access denied

To czysta instalacja, czy kiedyś działało i "nagle" się zepsuło? Włączyłeś możliwość komunikacji przez SSH (za pomocą pliku ssh)?

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

@Treker Pierwszy raz uruchomiłem wraz z kursem , tak utworzyłem plik ssh

Edytowano przez kamlixd

Udostępnij ten post


Link to post
Share on other sites

Na pewno zrobiłeś identycznie jak w kursie tj. pusty plik, bez rozszerzenia, dokładnie w tym miejscu, w którym trzeba? Upewniam się bo taki błąd to właśnie najczęściej kwestia nie włączenia dostępu przez SSH. Masz może podłączony monitor do malinki i masz dostęp do interfejsu graficznego?

Udostępnij ten post


Link to post
Share on other sites

@Treker plik ssh bez rozszerzenia w folderze głównym , i nie mam dostępu graficznego , podłączyłem bezpośrednio do sieci lokalnej po wygraniu softu 

Jeśli to robi jakąś różnicę to wgrałem wersje pełną rasbiana na kartę SD mimo że korzystam (chciałbym korzystać) z terminalu 

Udostępnij ten post


Link to post
Share on other sites

To niestety na ten moment nie mam pomysłu - może przeczyłem coś oczywistego i ktoś inny doradzi. Do tej pory nie pojawił się jeszcze nikt z takim problemem, więc to raczej na 99% coś konkretnie związanego z Twoim przypadkiem, ale nie mam pomysłu co... Próbowałeś łączyć się przez UART, aby wykluczyć jakieś dziwne uszkodzenie systemu?

Udostępnij ten post


Link to post
Share on other sites

@Treker No właśnie dziś mam zbyt wiele problemów

Próbowałem użyć usbasp v2.0 dla UART ale niestety win10 nie widział rasberry tak jak to było w kursie 

A na początku nie mogłem wypalić systemu na kartę bo wyskakiwał jakiś tam błąd , ale z tym już sobie poradziłem "nagle zaczęło działać"

 

 

Udostępnij ten post


Link to post
Share on other sites

cześć. Mam pewien problem. Dodałem plik ssh tak jak w kursie i gdy za pomocą arp -a albo ip-scannera próbuje znaleźć ip raspberry, nie znajduje mi jej :/. Jak podłączyłem sie z malinka przez hdmi i podpatrzyłem ip na niej było 192.168.5.8 i probowałem sie połaczyc przez putty to niestety nie nawiązuje sie połaczenie. Co może być nie tak? Bardzo prosze o pomoc bo nie wiem już co z tym mam zrobić.

Pozdrawiam

Udostępnij ten post


Link to post
Share on other sites

@rafafs, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.
23 minuty temu, rafafs napisał:

Co może być nie tak? Bardzo prosze o pomoc bo nie wiem już co z tym mam zrobić.

Czy masz dostęp do routera i widzisz tam, że malinka jest podłączona? Opisz trochę swoje środowisko sieciowe - to Twój router i nie ma tam żadnych blokad, czy może np. uruchamiasz to na uczelni, gdzie administrator sieci mógł nałożyć jakieś niestandardowe ograniczenia? Czy Twój komputer i RPi są na pewno w tej samej sieci lokalnej?

Udostępnij ten post


Link to post
Share on other sites

@Treker dziekuje za zainteresowanie. Router jest mój domowy.  Ale nie mogę zalogować się na niego. Po wpisaniu komendy cmd /k ipconfig zobaczyłem że adresem bramy domyślnej jest 192.168.5.254. Po wpisaniu go w przeglądarce pojawia się problem i pisze ze serwer odrzucił połączenie. Adres malinki jak sprawdziłem przy podłaczeniu do hdmi to 192.168.5.8/24. Po wpisaniu arp -a pokazują się wszystkie inne urządzenia podłączone do sieci oprócz raspberry. 

Przesyłam zdjęcie tablicy arp.

image.thumb.png.e4d5bd05f0e002decfc0283c866760bd.png

Pozdrawiam.

Udostępnij ten post


Link to post
Share on other sites

heheh, połączyłem się z moją malinką zdalnie:-)). Powolutku, pomalutku...

Udostępnij ten post


Link to post
Share on other sites
Dnia 16.04.2018 o 01:03, marekr napisał:

Po aktualizacji malinki i ponownym uruchomieniu nie ma możliwości połączenia się przez ssh. Rozwiązaniem jest dodanie w sekcji network linii "scan_ssid=1" . Niestety trzeba to zrobić przed pierwszym update-m. Poniżej poprawiony plik "wpa_supplicant.conf":


country=PL
update_config=1
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

network={
   ssid="network_SSID"
   psk="password_to_SSID"
   key_mgmt=WPA-PSK
   scan_ssid=1
}

Czy jeśli ssh u mnie działa, bez probletmu się łączę i prze putty i VNC, to muszę zastosować się do powyższej rady? Jeszcze nic nie aktualizowałem, nie chciałbym od nowa instalować obrazu...

Udostępnij ten post


Link to post
Share on other sites

Sieć bezprzewodową można skonfigurować na wiele różnych sposobów. Podany przykład pozwala na uruchomienie WiFi bez konieczności podłączania monitora, portu szeregowego, czy sieci lokalnej - zamiast tego używane są opisane pliki konfiguracyjne. Ale jeśli masz już działającą sieć, nie musisz z tej metody korzystać.

Ogólna zasada jest taka: to samo można osiągnąć różnymi sposobami, malinka posiada na tyle rozbudowany system, że nawet zwykłe podłączenie sieci można zrealizować przeróżnymi metodami.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Ok, wiem, że jak sobie zaktualizuję, albo i nie, to zawsze mogę podpiąć monitor i myszkę i z poziomu graficznego włączyć ssh, ale ja ten post rozumiem tak,  że jak nie uruchomię malinki z taką wersją pliku "wpa_supplicant.conf", to po aktualizacji nie dam rady połączyć sie poprzez putty czy VNC, dopoki nie włączę ssh jakoś inaczej. Dobrze rozumiem?

Edytowano przez SOYER

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...