Skocz do zawartości

LF - po raz pierwszy


othar

Pomocna odpowiedź

Witam.

Czemu zasilanie z 6x1,5V? Nie lepiej jest zainwestować w najtańszy akumulator Li-Pol 7,4V i najtańszą ładowarkę - chociaż na start?

Twój uC ma 6 kanałów ADC, a Ty masz 7 czujników 🙂 i jeden podłączasz do pinu I/O procka - ten czujnik może poprawnie nie działać - może szaleć w zależności od podłoża z jakiego jest wykonane i oświetlenia.

Jako stabilizatory możesz uśyć jakiś LDO (LM1117) 5V i 3,3V SMD lub THT - w zależności jak będziesz chciał. PS. po co Ci dwa źródła zasilania?

Masz słabe filtrowanie ADC, powinien się tam jeszcze znaleźć dławik 10/100uH podciągnięty od VCC.

Masz źle podłączone kondensatory i kwarc do uC, kondzie do masy.

Jak zamierzasz podłączyć czujniki do bota? Nie masz żadnych etykiet, ani zasilania przy czujnikach (na schemacie) i nie masz węzłów przy 3-pinowych goldpinach - przy czujnikach.

Czemu zasilanie silników to 3,3V? Trochę to dziwne.

Masz jeszcze 3 wolne piny I/O w procku - wykorzystaj je może do debugowania? Akurat TX i RX masz wolne + jeden wolny pin I/O dla diody LED 🙂

To chyba wszystko.

  • Pomogłeś! 1
Link do komentarza
Share on other sites

Dzięki za szybką odpowiedź 🙂

1. Co do dwóch źródeł zasilania, to wg. strony sklepu silniki są na 3V, też mi się to wydaje dziwne, ale przekonam się jak dostanę wszystkow w swoje ręce. Podejżewam, że są one 3-6V, tylko parametry są podane dla 3V.

2. Znaczy teorię czujników muszę postudiować. Dzięki 🙂

3. Ad. Filtrowanie ADC. Czy możesz mi napisać gdzie mam szukać informacji na ten temat, schematy?

Lubię czasem wiedzieć co, po co i dlaczego...

4. Podłączenie kwarcu już poprawiłem.

5. Czujniki chciałem zrobić każdy na oddzielnej, malutkiej płytce, tak żebym mógł testować w efekcie różne ich rozmieszczenie i jego wpływ na zachowanie pojazdu. z każdego wyprowadzony ma być 3-żyłowy przewód podłączany na płytce do złącz "CZUJNIKI" i "ZASILANIE CZUJNIKÓW" nie szukałem w bibliotece złącza 7x3 i zrobiłem po prostu 1x7 i 2x7, które mają być ustawione obok siebie.

Przy czujnikach: pin3 - +5V ; pin2 - GND ; pin1 - sygnał

7. TX i RX specjalnie zostawiłem, bo wiem, że służą do komunikacji. Jak się do tego debugowania zabrać? Jakiś link jeśli jest "pod ręką" byłby dużą pomocą.

"Obciąłem" jeden czujnik, więc mam 2 piny I/O wolne, więc dwie diody zmieszczę 😃

Schemat po szybkich poprawkach:

Link do komentarza
Share on other sites

Przydatne linki:

http://mirekk36.blogspot.com/2012/12/filtrowanie-zasilania-dlaczego-tak-wazne.html

http://mirekk36.blogspot.com/2012/04/mikrokontroler-prawidowe-zasilanie.html

PS. Jeżeli moja odpowiedz była pomocna kliknij pomógł 🙂.

Edit: Jeszcze znalazłem błąd na Twoim poprawionym schemacie, mianowicie przy takim podłączeniu diod LED (od uC) powinieneś anody tychże diod podłączyć do VCC, a nie do GND.

  • Pomogłeś! 1
Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Myślę, że możesz zrezygnować z oddzielnego zasilania na 3V. Jeżeli Twoje silniki są 3 woltowe to dając 5V na wejścia VCC2 na wyjściach dostaniesz 1-2V mniej. Najlepiej zrób test - podłącz 5V i sprawdź napięcie na wyjściach 1Y,4Y.

Dlaczego chcesz użyć dwóch mostków L293d?

Link do komentarza
Share on other sites

@matural

dzięki za sugestię, na pewno sprawdzę.

dwa mostki, ponieważ prad maksymalny dla jednego silnika to 2,1A, więc żeby mostek to wytrzymał przepuszczam prąd przez oba "kanały".

@Treker

lepiej więcej kropek niż za mało 🙂

zdażyło mi się, że dopiero po postawieniu kropki Eagle zapytał się mnie, czy na pewno chcę przyłączyć daną linię do GND

na tą chwilę pozostanę przy tym co kupiłem, bo jest tańsze. Dla kolejnej konstrukcji być może się rzucę na coś bardziej eleganckiego 🙂

Link do komentarza
Share on other sites

dwa mostki, ponieważ prad maksymalny dla jednego silnika to 2,1A, więc żeby mostek to wytrzymał przepuszczam prąd przez oba "kanały".

Twoje silniki pobierają 2,1A na jałowym biegu, czy pod obciążeniem / zatrzymaniem wału? To ważne, ponieważ jeżeli przy zatrzymaniu, to nawet "zmostkowanie" jednego pełnego mostka H nic Ci nie da, bo 600mA + 600mA = 1200mA => 1,2A / silnik. Więc na jeden silnik, który pobiera 2,1A, to za dużo jak na ten mostek.

Link do komentarza
Share on other sites

2,1A to prąd maksymalny silnika przy 3V, podejżewam, że chodzi o silnik zatrzymany.

L293D ma prąd szczytowy na kanał 1,2A, więc na obu kanałach jest teoretycznie 2,4A. Praktycznie jest pewnie mniej(odprowadzanie ciepła).

Na dzień dzisiejszy jest to podstawa dla Line Followera, więc silników nie będę za bardzo nadwyrężał. W przyszłości, jak się czegoś na tej konstrukcji nauczę, zmienię program i konstrukcję i powstanie coś innego. Marzy mi się coś zdalnie sterowanego z kamerą, wspomagającego jazdę między przeszkodami. Komunikacja po WiFi, program dla Androida lub PC.

Ale najpierw Line Follower 🙂

Link do komentarza
Share on other sites

widzę kropki....

są w wielu miejscach, w którym nie muszą, natomiast nie ma ich w miejscach w których być powinny 😉

+diody LED1,2 chyba powinny być na schemacie na odwrót

+a dodatkowo LED3 zamienione miejscem z R19, oraz LED4 zamienione miejscem z R16

+czy aby napewno VCC2 może być podpięte do 3V3?

Wide Supply-Voltage Range: 4.5 V to 36 V
  • Pomogłeś! 1
Link do komentarza
Share on other sites

torcek,
masz dobre oko.

tego zasilania 3,3V prawdopodobnie nie będzie, ponieważ zgodnie z informacją od matural spadek napięcia na mostku to około 1,5V, więc nie potrzebne jest. To będę musiał jeszcze sprawdzić. Ale jeśli okaże się prawdą oszczędzę trochę miejsca na płytce.

Link do komentarza
Share on other sites

Tak sobie jeszcze pomyślałem i wyszło mi, że układ wraz z silnikami będzie pobierał maksymalnie ponad 2A prądu. Standardowo stabilizatory mają 0,8-1A. Czy w piku można je przeciążać 2-krotnie?

Czy jest jakaś metoda na to?

Link do komentarza
Share on other sites

W Linefollowerze rzadko silniki pobierają wysoki prąd.

Ale tak ogólnie, to ja proponuję odseparować zasilanie logiki od silników, bo inaczej możesz mieć zakłócenia.

Widzę 2 opcje:

a) Logika ze stabilizatora, silniki bezpośrednio ze źródła zasilania

b) Logika ze stablilizatora, silniki z przetwornicy lub drugiego stabilizatora

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.