Skocz do zawartości

Arduino i budowa Zumo


emikrecik

Pomocna odpowiedź

Witam,

Zaczne od tego co mam i jak podlaczone

Arduino UNO

drv8833

Pololu HP 50:1

Bluetooth HC-05

W arduino sa 3 timery i dwa dzialaja na tych samych czestotliwosciach 490.20 domyslnie

A wiec driver silnikow podlaczony mam do 3 i 11 - jeden silnik, 9 i 10 drugi silnik.

i teraz do rzecczy na wyjsciach drivera mam rozne napiecia i dziwne przebiegi wszystko jest widoczne na zalaczonych zdjeciach.

co moze byc przyczyna ? skutkuje to ze jezeli chce pojechac do przodu on poprostu na chama mi skreca wiem ze rozwiazaniem moga byc enkodery ale nim je zastosuej chcialbym aby na wyjsciach panowal porządek tak jak ladny przebieg PWM i w miare rowne napiecia. roznice w napieciach pomiedzy kanalami roznia sie w zaleznosci od wypelnienia PWM im wieksze tym mniejsza roznica analogicznie przy malym wypelnieniu roznica jest ponad 1V miedzy kanalami.

Driver byl zmieniany myslac ze to wina trefnej sztuki.

Wyglada mi to na swego rodzaju jakies zaklocnia. Ale pozostawiam to Wam profesjonalistom poniewaz jezeli chodzi o elektronike jest mocno poczatkujacy w poronaniu z Wami.

pozdrawiam serdecznie i dziekuje z gory za sugestie i pomoc

Link do komentarza
Share on other sites

Ja nie widzę tam niczego dziwnego.

Jak każdy układ elektroniczny mostki mają pewien rozrzut produkcyjny i tym samym możesz mieć małą różnicę w napięciach. To samo z silnikami. Zmień silniki miejscami to sytuacja może się zmienić.

Reszta tego co widzisz to back emf.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

A w czym obecnie on Tobie przeszkadza?

Back emf jest związane z działaniem silnika i nie można się go "pozbyć" w takim układzie jak masz.

Można na różne sposoby go ograniczyć po stronie elektroniki (zmniejszyć amplitudę), ale w silniku zawsze się pojawi.

Link do komentarza
Share on other sites

no dobra czyli procz zmiany na idealny driver ktory pewnie nie istnieje nic nie zrobie.

nie mam kondensatorow przy silnikach. a wiem ze modelarze R/C stosuja najczesniej 100nF/50 V ale chyba dlatego aby nie zaklocac pracy odbiornika radiowego ? czy sie myle i czy powienien rowniez zastowac ?

no i wpadlem na pomysl tylko nie wiem czy to moglo by dzialac.

aby tam gdzie strzalka dac czujnik odbiciowy ktory by zliczal obroty kola przez te "wypustki"

co o tym sadzicie ? tym sposobem zaoszczedzilbym kasy na silnikach z podwojnym walem no i satysfakcja z wlasnego pomyslu.

edit:

cholera zapomnialem wkleic link 😃

Link do komentarza
Share on other sites

Może spróbuj zwiększyć częstotliwość PWM. 500Hz na silniki to trochę mało.

JA w jednej konstrukcji zmieniłem na 4kHz i silniki działają jak powinny, na 500Hz nie działały dobrze.

Link do komentarza
Share on other sites

no i wpadlem na pomysl tylko nie wiem czy to moglo by dzialac.

aby tam gdzie strzalka dac czujnik odbiciowy ktory by zliczal obroty kola przez te "wypustki"

co o tym sadzicie ? tym sposobem zaoszczedzilbym kasy na silnikach z podwojnym walem no i satysfakcja z wlasnego pomyslu.

Niestety to nie był Twój pomysł:

https://www.pololu.com/product/1218

Link do komentarza
Share on other sites

tak wlasnie pozniej to znalazlem szukajac czesci 😃 trudno

dobra no cos tam juz wiem o tej czestotliwosci tzn jak wplywa na prace silnika.

wczoraj jeszcze sprawdzilem jak dziala przy prawie 4 KHz i wydaje sie byc lepiej i jakby wiekszy moment i jakby rowniej sie krecily. niestety juz wszyscy domownicy spali wiec nie moglem przetestowac jak jezdzi ale licze ze uda mi sie dzisiaj.

czy ze wzrostem czestotliwosci rosnie prad ? poniewaz poczulem jakies cieplo tylko nie moglem znalezc zrodla ani mostek ani ogniwo. a silniki mam schowane wiec nie moglem wybadac organoleptycznie czy sie zagrzaly np od duzego pradu juz plynacego przez silniki przez zwiekszenie f do 4KHz.

Link do komentarza
Share on other sites

Przez zwiększenie częstotliwości przełączania mógł zacząć grzać się bardziej mostek. Skoro częściej się przełącza, to częściej musi naładować/rozładować mosfety w kluczach.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.