Skocz do zawartości

Komputer nie wykrywa Arduino Leonardo


Florss

Pomocna odpowiedź

Witam ostatnio chciałem pobawić się troszkę arduino lecz gdy podłączyłem je do komputera, komputer płytki nie wykrył świeciła się tylko dioda zasilania i migała dioda L . Nie jest to wina kabla,  ponieważ pliki z telefonu przez ten kabel przechodzą normalnie. 

Problem dotyczy płytki arduino Leonardo R3.

 

 

Edytowano przez Florss
Link do komentarza
Share on other sites

@Florss witam na forum 🙂

Jeśli dioda zasilania świeci, a druga dioda miga to znaczy, że Arduino działa poprawnie - tj. jest zasilane i wykonuje się domyślny program. Czy Arduino Leonardo, które posiadasz jest oryginalne, czy to jakiś klon? Z jakiego systemu operacyjnego korzystasz na PC?

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

@Misiek_86 W menedżerze urządzeń czasami pokazuje nieznane urządzenie a czasem nic. Portu w ogóle nie mogę wybrać tak jakby żadne Arduino nie było podłączone. Czasami tylko wyświetla się komunikat o skoku napięcia na usb. 

Link do komentarza
Share on other sites

Kabel może być dobry dla jednego urządzenia, a dla drugiego niedobry, niewielkie różnice spasowania, przy słabym  kablu zaczynają mieć znaczenie, ta sama wtyczka różnie zadziała w różnych gniazdach.

Druga opcja to uszkodzony bootloader, czasem planety tak się ułożą, że zniknie, trzeba wgrać programatorem na nowo.

Link do komentarza
Share on other sites

Ja bym spróbował: z innym kablem, z innym komputerem i tyle. Jak nie działa to odsyłać na reklamacje 🙂 Oryginalne Arduino powinno działać od razu, problemy z tymi płytkami zdarzają się sporadycznie, ale może faktycznie coś tam jest nie tak.

Link do komentarza
Share on other sites

(edytowany)

@H1M4W4R1 Albo to coś ze mną nie tak 🙂 , albo coś źle robię, po wgraniu bootloadera dioda on oraz L się świecą 🤔. Spróbuję jeszcze kilka razy. 

Edytowano przez Florss
Link do komentarza
Share on other sites

8 minut temu, Florss napisał:

Albo to coś ze mną nie tak 🙂 , albo coś źle robię, po wgraniu bootloadera dioda on oraz L się świecą 🤔

A testowałeś czy działa? 😄 Nie pamiętam dokładnie jak powinno to wyglądać, bo rzadko pracuję na Arduino z Arduino 😄 Zwykle jadę bezpośrednio na MCU.

Link do komentarza
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.