Skocz do zawartości
profesorek

Atmega8 i cny70 (Line follwer)

Pomocna odpowiedź

Przymierzam się do budowy mojego pierwszego Line follwera.

Nie chce zrobić błędu podczas wykonywania płytki i dalszych czynności związanych z budową robota. Proszę więc o sprawdzenie mojego schematu i wypowiedzenie się o ewentualnych poprawkach. czy w atmedze 8 wszystkie porty mają PWM czy tylko wybrane.

Czy jest konieczność stosowania dławika pomiędzy częścią analogową a cyfrową i czy on jest dobrze podłączony?

Czy schemat został poprawnie wykonany tak aby działał dobrze?

Czy mostek H został poprawnie podłączony tak aby można było sterować silnikami przez PWM? .

Z góry dziękuje.

czujnik.pdf

Udostępnij ten post


Link to post
Share on other sites
czy w atmedze 8 wszystkie porty mają PWM

Takie rzeczy tylko w erze. Nawet mx8 (48, 88, 168, 328) mają tylko kilka więcej niż m8. W ogóle to jak mamy sprawdzić schemat, skoro na nim nic nie widać? Nie widać żadnych połaćzeń do uC.

Udostępnij ten post


Link to post
Share on other sites

Jeden z cny nie est podpięty do masy (ten na samym dole)

Udostępnij ten post


Link to post
Share on other sites

To wiem.

Ale czy nie ma jakiś innych błędów?

[ Dodano: 30 Sty 10 05:43 ]

Użyłem dławika 10uH.

Czy mam kupić dławik osiowy czy może przeciw zakłóceniowy czy może jeszcze inny?

Udostępnij ten post


Link to post
Share on other sites
Czy mam kupić dławik osiowy czy może przeciw zakłóceniowy czy może jeszcze inny?

? ja poprosiłem po prostu o dławik 10uH i dostałem taki "rezystorowy" i jest w porządku.

Ja używam rezystorów 330 (dioda IR) i 47k (fototranzystor) przy czujnikach CNY70 i sprawdza mi się to.

Udostępnij ten post


Link to post
Share on other sites

Ten 'rezystorowy' to jest właśnie dławik osiowy. Jest fajny mały, ale na małe moce (bodajże 250mW, czyli tak jak rezystory).

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

To dobrze wiedzieć jak to się nazywa 🙂 Dzięki BoBBy.

Udostępnij ten post


Link to post
Share on other sites

Profesorek ty jesteś niereformowalny! Nie czytasz co inni do ciebie piszą, sam piszesz głupoty próbując udzielać innym bezsensownych porad, zamieszczasz posty w złych działach. Temat przenoszę tam gdzie jego miejsce.

Udostępnij ten post


Link to post
Share on other sites

Sory Sabre.

Jestem troszeczkę roztrzepany.

Czyli mam rozumieć że schemat jest dobrze narysowany czy są w nim jakieś błędy?

Udostępnij ten post


Link to post
Share on other sites
Jeden z cny nie est podpięty do masy (ten na samym dole)

Poza tym masz przy stabilizatorze źle dobrane kondy. Powinny być 2x 100nF ceramiczne i 2x elektrolity np. 10uF (ty masz 3x 100nF i 1x 100uF wszystkie ceramiczne).

Źle podpiąłeś piny enable mostka do procesora, uniemożliwi ci to sterowanie silnikami przez PWM (1-2EN nie powinien być podłączony do PD7, tylko do PB1).

Reszta chyba w porządku.

Udostępnij ten post


Link to post
Share on other sites

Bo na porcie D nie ma PWM'a.

W dodatku nie do jakiegokolwiek pinu portu B, tylko do PB1, bo na PB2 masz prawidłowo podpięty enable do drugiego silnika, a PB2 i PB1 to jest jeden timer i łatwiej tym sterować.

Udostępnij ten post


Link to post
Share on other sites

Co do kondensatorów to są różne rozwiązanie, ja osobiście stosuję dwa ceramiczne 100nF przed i za stabilizatorem i jeden elektrolit 10uF za stabilizatorem.

Rozszerzyłem posta wyżej.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...