Skocz do zawartości

Kurs elektroniki – #7a – tranzystory bipolarne w praktyce


Pomocna odpowiedź

52 minuty temu, Gieneq napisał:

@Strogg witam na forum 🙂 

LED jest poprawnie podłączony, plusem do zasilania. A tranzystor zapewnia lub zamyka przypływ prądu. To tak jakbyś przy pomocy tranzystora odcinał katodę LED od masy, lub ją do niej podłączał.

Czyli po prostu ta linia + na płytce zasila diodę w tradycyjny sposób, a tranzystor steruje "zamykaniem" obiegu tak?

Link to post
Share on other sites

@Strogg tak dokładnie tak. Można sterować w obie strony: albo zamykać że tak ujmę od przodu, albo od końca. To jakbyś postawił tamę na rzece - nieważne gdzie, czy za puntem pomiarowym czy przed, przepływu i tak nie będzie.

  • Lubię! 1
Link to post
Share on other sites
Dnia 21.08.2020 o 08:20, Gieneq napisał:

@Strogg tak dokładnie tak. Można sterować w obie strony: albo zamykać że tak ujmę od przodu, albo od końca. To jakbyś postawił tamę na rzece - nieważne gdzie, czy za puntem pomiarowym czy przed, przepływu i tak nie będzie.

Hmm. Trochę mi to przypomina działanie bramki logicznej w informatyce.

 

Wydaje mi się, że ten przykład z kursu miał tylko za zadanie pokazać, że to faktycznie działa, bo do gaszenia-zapalania diody można wykorzystać przecież jakiś wlącznik.

Link to post
Share on other sites
7 godzin temu, Strogg napisał:

Wydaje mi się, że ten przykład z kursu miał tylko za zadanie pokazać, że to faktycznie działa, bo do gaszenia-zapalania diody można wykorzystać przecież jakiś wlącznik.

@Strogg w tym konkretnym przypadku tak, ale jeśli zamiast diody mielibyśmy coś, co pobiera większy prąd (np. mocniejszą diodę), a całość miałaby być sterowana za pomocą programu wgranego np. na Arduino to przełącznik nic tu nie da, a bezpośrednio podłączenie takiej diody do Arduino uszkodziłoby układ. Tranzystor umożliwiłby poprawną pacę takiego układu.

  • Lubię! 1
Link to post
Share on other sites

Następny odcinek za mną. Robi się to już dla mnie skomplikowane o tyle, że jak czytam sobie cały wątek na forum, to czasem mam w głowie "o co chodzi, skąd to wiadomo, jak ci ludzie wiedzą, że to zadziała tak a nie inaczej" :). Trochę przesadzam i wiem też doskonale, że te eksperymenty to pierwszy krok, a wyczucie i zrozumienie to kwestia praktyki. Nie planuję kariery w elektronice :), czasem chciałbym po prostu wiedzieć, co mogę podłączyć do Raspberry, żeby wyjść poza programowanie (które mnie głównie interesuje).

Ale do rzeczy.

W pomiarach dla NPN wyszło mi podobnie, jak w kursie, to nie będę pisał. Napiszę tylko o jednej ciekawostce. Po wypięciu z bazy opornika i rozłączeniu kabli, dioda słabo się świeci, gdy zetknę końcówki kabli (od plusa i od bazy) na palcu. Ja jestem opornikiem. A dlaczego dioda się świeci, gdy dotykam tylko kabla od bazy?

Przy PNP musiałem na spokojnie pomyśleć, co połączyć z czym. I połączyłem: bazę z minusem przez opornik 10K, kolektor z minusem przez diodę i rezystor 1K, emiter z plusem. Wyszło:

Ube: 0,72V

Uce: 0,03V

Ic: 6,46mA

Ib: 0,85mA

Poczytałem forum, znalazłem odpowiedzi na kilka pytań (np. niemożliwość policzenia prądu na kolektorze dla zadanego prądu na bazie), ale trochę problemów sprawia mi - również na poziomie nazewniczym - nasycenie (swoją drogą i emiter mnie w nazwie zmylił 🙂 ).

1. Stan aktywny jest przed stanem nasycenia i wtedy beta jest prawdziwe. Stan nasycony (nasyciła się baza) to sytuacja, w której prąd dopływający do bazy nie może być "przeliczony" na kolektorze zgodnie z beta, bo źródło takiego prądu na kolektorze nie jest w stanie dać. Zgadza się to?

2. Jeśli się zgadza, to czy można o którymś stanie powiedzieć, że jest "lepszy"? Czy przy aktywnym mamy komfort szacowania prądu na kolektorze zgodnie z betą, czy tak nie myśleć?

Edytowano przez Leander
Link to post
Share on other sites

Witam ponownie. Wszystko szło rewelacyjnie do momentu zadania domowego. Zmieniłem tranzystor na pnp, zmierzyłem napięcia i zacząłem mierzyć prądy. Ku mojemu zdziwieniu, po przyłożeniu sond dioda zaczęła lekko świecić lecz multimetr pokazywał cały czas zero. Złożyłem układ jeszcze raz, zmieniłem tranzystor, złożyłem z powrotem układ z tranzystorem npn i okazało się, że miernik przestał mierzyć prąd 🥺. Powiedzcie co robię źle bo to już drugi zdefektowany multimetr podczas tego kursu. Jak tak dalej pójdzie to go nie skończę albo wydam fortunę na zakupy kolejnych urządzeń. Mój elektroniczny entuzjazm prysł jak bańka mydlana...

Rozkręciłem multimetr. Oba bezpieczniki wyglądają ok.

Edytowano przez jugen07
Rozkręcenie multimetru
Link to post
Share on other sites
Dnia 29.12.2020 o 21:43, jugen07 napisał:

lekko świecić lecz multimetr pokazywał cały czas zero.

@jugen07 a jaki miałeś ustawiony zakres? Bo lekkie świecenie może być już przy niecałym 1mA

Możesz sprawdzić jeszcze sondy, szarpnij troche za kable czy nie wypadną.

Edytowano przez Gieneq
Link to post
Share on other sites
Dnia 29.12.2020 o 21:43, jugen07 napisał:

Powiedzcie co robię źle bo to już drugi zdefektowany multimetr podczas tego kursu. Jak tak dalej pójdzie to go nie skończę albo wydam fortunę na zakupy kolejnych urządzeń. Mój elektroniczny entuzjazm prysł jak bańka mydlana...

Rozkręciłem multimetr. Oba bezpieczniki wyglądają ok.

To coś podejrzane 😉 Najlepiej pokaż co i jak mierzysz. Chyba jeszcze nie było tutaj przypadku, aby  ktoś uszkodził jakoś sam miernik (pomijając ewentualne przepalenie bezpiecznika). Jeśli w Twoim przypadku niby uszkodziły się już aż 2 mierniki to chyba trzeba poszukać głębszej przyczyny. Może jednak coś źle mierzysz? Pokaż to sprawdzimy.

Link to post
Share on other sites

Witam, mam pewien problem. Otóż, zawsze robię tak, że jak widzę jakiś schemat to staram się go utworzyć na płytce tak jak ja to widzę. Tak było też tutaj, zrobiłem własny układ i LED nie chciał się zapalić. Przeanalizowałem wszystko dokładnie i nie zauważyłem błędu. Następnie sprawdziłem jak to zostało 'zamontowane' na płytce w kursie. Połączenia wyglądały wg mnie tak samo, tylko moje były dłuższe (użyłem więcej przewodów do łącznie każdego elementu układu. Po zapoznaniu się z układem zrobiłem raz jeszcze układ po swojemu z mniejszą liczbą przewodów (o jednego mniej) i układ zadziałał... Kiedy dokładam jeden przewód przed lampką LED, nic się nie świeci... Dlaczego tak się dzieje? Testowałem kilka przewodów i za każdym razem to samo. Załączam dwa zdjęcia. Na pierwszym widać jak LED świeci gdy bezpośrednio wpięty jest do plusa, a na drugim zdjęciu dołożyłem między LED'a a plusa przewód i nic nie świeci. Proszę o pomoc, zaznaczam, że dopiero zaczynam swoją przygodę z elektroniką i jestem zielony... 😞

20210123_210418.jpg

20210123_210349.jpg

Link to post
Share on other sites
(edytowany)

@Luqash Na drugim zdjęciu dioda jest źle podłączona. Anoda i katoda diody są podłączone do tego samego potencjału (obie są podłączone do plusa) więc nie ma przepływu prądu. Polecam przeczytać ten artykuł, powinien wyjaśnić sprawę 🙂 https://forbot.pl/blog/jak-dziala-plytka-stykowa-zdjecia-budowa-przyklady-id21978

Edytowano przez szymon812
  • Lubię! 1
  • Pomogłeś! 1
Link to post
Share on other sites
47 minut temu, szymon812 napisał:

@Luqash Na drugim zdjęciu dioda jest źle podłączona. Anoda i katoda diody są podłączone do tego samego potencjału (obie są podłączone do plusa) więc nie ma przepływu prądu. Polecam przeczytać ten artykuł, powinien wyjaśnić sprawę 🙂 https://forbot.pl/blog/jak-dziala-plytka-stykowa-zdjecia-budowa-przyklady-id21978

aaa, już mi się rozjaśniło! 🙂 dzięki serdeczne za szybką odpowiedź 🙂 teraz mogę dalej lecieć z kursem 🙂 👍

  • Lubię! 1
Link to post
Share on other sites

Hej,

również zmontowałem układ z tranzystorem PNP. Wyniki wyszły następujące:

  • Ube: 0,739 V
  • Uce: 0,038V
  • Ic: 8,24mA
  • Ib: 0,98mA

Pytania:

  1. nie wiem czy te natężenia prądu na kolektorze i bazie nie są jakieś za duże ? 😛 
  2. dlaczego kiedy przekręcam tranzystor PNP BC556 o 180 stopni, to dioda nadal świeci ? 

P_20210206_183428_vHDR_Auto.thumb.jpg.3aa37a612296c69da88c160e55066427.jpg  P_20210206_183402_vHDR_Auto.thumb.jpg.8f3fbc631acc60368dca70cf9af32f69.jpg

Link to post
Share on other sites

@loogra dioda świeci, bo zamieniasz wtedy miejsca emiter z kolektorem. Wspomnieliśmy o tym w skrócie pod nagłówkiem "Podłączenie obciążenia do emitera". Na tym etapie nauki najlepiej jednak trzymać się jednej wersji, bo inne układy pracy tranzystora (bo tak to się nazywa) to trochę bardziej zawiły temat 😉

Link to post
Share on other sites

Witam wszystkich bardzo serdecznie 🙂
Nie wiem czy ktoś to też zauważył, czy ja źle rozumiem jako niedoświadczony elektronik. Mianowicie wydaje mi się, że jest błąd wyprowadzeń na obrazku 
"Opis wyprowadzeń tranzystora BC546
(po lewej widok od dołu, czyli od strony nóżek)"
Dokładniej nóżki są na obu widokach inaczej oznaczone. Po lewej kolektor to po prawej emiter i odwrotnie. 
Ale mogę się mylić :), dlatego prosiłbym o odpowiedź.

Link to post
Share on other sites
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.