Skocz do zawartości
Komentator

Kurs elektroniki II - #9 - czujnik przeszkód, sterownik serwa

Pomocna odpowiedź

Cześć, czy wytłumaczysz mi dlaczego przy pewnych wartościach serwo ciągle drga, a w większości się ustawia do danego poziomu, stabilizuje i pozostaje nieruchome? Zastanawiało mnie to już przy konfiguracji modeli i w tym układzie jest identycznie.

 

Udostępnij ten post


Link to post
Share on other sites

@jordanj przyczyn jest kilka 😉 Po pierwsze to są bardzo popularne, małe i stosunkowo tanie serwomechanizmy, więc ich jakość jest akceptowalna, ale nie idealna. W droższym sprzęcie takie drgania mogą być mniejsze (lub może nie być ich wcale). Po drugie, serwo stara się ustawić zadaną przez Ciebie pozycję, ale nie zawsze mu się to udaje. Zdarzają się pozycje, których nie będzie ono w stanie osiągnąć np. przez niedoskonałości w mechanice lub elektronice. W takiej sytuacji powstają drgania, bo serwo próbuje nieskutecznie wcelować w dane położenie (a ciągle trafia za blisko/za daleko) więc tylko drży. Po trzecie, każde zakłócenie w tym układzie na płytce stykowej sprawia, że zmienia się sygnał na wyjściu NE555, który steruje serwem. Każde zakłócenie może więc powodować małe drgania. 

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Też mam problem z serwo . Nie rusza się.  Gdy podłącze 9v to wibruje / drga .

IMG_20190727_084021.jpg

Udostępnij ten post


Link to post
Share on other sites
5 godzin temu, jas123 napisał:

Gdy podłącze 9v to wibruje / drga .

Gdzie i w jaki sposób podłączasz 9V? Ten układ powinien być zasilany z 6V, ponieważ serwomechanizmy nie są przystosowane do pracy z 9V. Najzwyczajniej mogłeś spalić swój serwomechanizm.

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Cześć, mam problem z poprawnym uruchomieniem układu z serwomechanizmem, serwo w ogóle się nie rusza. Generalnie składałem go już chyba z 4 razy od nowa, myśląc, że może coś źle podłączyłem, ale problem najwyraźniej tkwi gdzieś indziej. Nie potrafię sam dostrzec tej 'usterki', będę wdzięczny za pomoc. 😄

I w gwoli ścisłości, potencjometr jest podłączony równolegle z 6,8K aby zmienić jego przedział oporu z 0-20k do 0-5k, tylko taki miałem na składzie, więc musiałem kombinować. 😅

A całość jest zasilana z 5V a nie z 6V,  ale to raczej nie jest przyczyną zaistniałego problemu, ponieważ przy próbach z 6V sytuacja wyglądała tak samo.

71497634_505338880014916_9047631776217825280_n.jpg 71745865_466938880571303_4119993352017936384_n.jpg 71789473_696392074171936_7612488434447286272_n.jpg

Udostępnij ten post


Link to post
Share on other sites

@Mike84 czy przykład jest składany z elementów, które były w zestawie do tego kursu czy wszystkie dobierałeś samodzielnie? Ten układ raczej nie powinien sprawiać problemów - musi działać 😉 Jest więc duża szansa, że problem leży np. w złych elementach. Inne ćwiczenia z NE555 działały poprawnie? Widzę, że masz zestaw do kursu Arduino - testowałeś serwo w połączeniu z Arduino, kręci się bez problemów?

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

@Treker Winowajcą problemu okazało się serwo. Sprawdziłem je przy pomocy arduino i w ogóle nie reagowało, serwo jest w zasadzie nowe i wcześniej go nie używałem, więc może to wina jakiś zimnych lutów w środku czy coś w tym stylu? Może jeszcze uda mi się je naprawić. 🤔

W każdym bądź razie do układu z kursu podłączyłem serwo 360 i wszystko teraz działa, no tylko teraz działanie tego układu jest trochę inne. Serwo kręci się cały czas, a potencjometr reguluje jego prędkość i od pewnej wartości oporu (tak mniej więcej w połowie przekręcenia) zmienia kierunek obrotów. Taka ciekawostka. 😄

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

W takim razie pozostaje reklamacja, bo chyba niestety faktycznie trafiłeś na uszkodzony element 😞 Napisz proszę na adres reklamacje@botland.com.pl, na pewno szybko uda się wymienić element na nowy. Przepraszam za problem, mam nadzieję, że dalej obejdzie się już bez takich niespodzianek!

12 godzin temu, Mike84 napisał:

W każdym bądź razie do układu z kursu podłączyłem serwo 360 i wszystko teraz działa, no tylko teraz działanie tego układu jest trochę inne. Serwo kręci się cały czas, a potencjometr reguluje jego prędkość i od pewnej wartości oporu (tak mniej więcej w połowie przekręcenia) zmienia kierunek obrotów. Taka ciekawostka. 😄

Bardzo dobry pomysł, taki układ też może być przydatny 😉

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Napisałem reklamacje, bez problemu mi ją przyjęto i sklep wysłał mi nowe serwo, teraz wszystko śmiga jak powinno. 😄

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

@Mike84 super, powodzenia w dalszych eksperymentach 🙂

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Czujnik przeszkód praktycznie nie do zbudowania na podstawie dołączonych zdjęć dla osoby początkującej. Zdjęcia znów nie pokazują dokładnych miejsc połączenia. Brak spisu zastosowanych elementów.
Starałem się złożyć, ale nie działa.
Po włączeniu odbiornik IR nie reaguje na ruch (natomiast reaguje na sygnał z pilota TV i działa także dioda IR, bo widać w aparacie telefonu lekkie świecenie).

20191119_152545.jpg

Edytowano przez Ros0mak

Udostępnij ten post


Link to post
Share on other sites
12 godzin temu, Ros0mak napisał:

Czujnik przeszkód praktycznie nie do zbudowania na podstawie dołączonych zdjęć dla osoby początkującej.

Zapewniam, że naprawdę tysiące osób poradziły sobie z wykonaniem tych zadań, więc jest to możliwe 🙂 Układów nie odtwarza się ze zdjęć - to tylko podgląd. Przy każdym ćwiczeniu podany jest schemat i to właśnie to jest główną instrukcją budowy danego układu. W tym ćwiczeniu i tak dodaliśmy wiele zdjęć, które powinny ułatwić budowę opisywanych układów. Musisz się przyzwyczaić do korzystania ze schematów. Rozumiem, że jest to dla Ciebie trudne, ale weź pod uwagę, że nasze zdjęcia to i tak coś "niestandardowego". W książkach lub innych poradnikach znajdziesz najczęściej tylko schemat i trzeba radzić sobie samodzielnie. Jeśli masz problemy z odtworzeniem takich układów to polecam zerknąć raz jeszcze np. do tego artykułu: Czytaj schematy, jak doświadczony elektronik. Spróbuj przeczytać go ponownie i na spokojnie przeanalizuj swój układ 🙂 Z tego zdjęcia, które wrzuciłeś niestety nie jestem w stanie odczytać teraz wszystkich połączeń.

13 godzin temu, Ros0mak napisał:

Po włączeniu odbiornik IR nie reaguje na ruch (natomiast reaguje na sygnał z pilota TV i działa także dioda IR, bo widać w aparacie telefonu lekkie świecenie).

Jeśli układ reaguje tylko na pilota od TV, a nie na diodę z zestawu tzn., że najpewniej błędnie złożona została część z NE555 (generowany jest zły sygnał sterujący diodą). Sprawdź ten fragment schematu, porównaj wartości elementów i zobaczy czy uda Ci się znaleźć jakiś błąd samodzielnie.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...