Skocz do zawartości

Kurs elektroniki II - #9 - czujnik przeszkód, sterownik serwa


Pomocna odpowiedź

Wydaje się nieco za mały. A jakbyś zmierzył napięcie jałowe czyli na samych bateriach niepodłączonych do układu, a później podłączonych do układu, bo może są rozładowane. Jeżeli różnica będzie duża, to znaczy że zasilanie nie wyrabia się i jest za słabe.

Link to post
Share on other sites

czy  na pewno w płytce wszystkie linie zasilania są połączone? coś mi się wydaje, że nie - w mojej połączone są po dwa bloki, a bloki sobie trzeba połączyć samemu.

Link to post
Share on other sites
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

@szon spróbuj pójść dalej z kursem, sprawdzimy to dokładnie w poniedziałek (odtworzymy cały układ z tych samych elementów i będziemy szukać problemu) 😉

  • Lubię! 2
Link to post
Share on other sites
Dnia 28.06.2019 o 17:24, szon napisał:

Układ zbudowany kolejny raz. Dla czytelności inne połączenia.

Nie wiem czy Cię pocieszę, bo widzę kilka błędów, ale może teraz zadziała:

  1. Podłączone do GND zamiast do VCC
  2. brak zasilania na NE555 (dlatego możesz mieć mniejszy pobór prądu)
  3. Tam widzę coś z 5 na końcu, to nie jest przypadkiem 1uF? Powinno być 103 żeby mieć 10nF.
  4. Masz 1k zamiast 10k

Nie widzę jak masz wpięty elektrolit przy TSOPie, grunt żeby równolegle do kondensatora 104.

IMG_4460.thumb.JPG.643c43d32686babc3596f218a136391f.JPG

Na przyszłość zrób tak jak ja - wydrukuj schemat i w odwrotnej kolejności na podstawie układu zaznaczaj ścieżki i połączenia. Jeżeli pokryjesz cały schemat to jest ok.

Edytowano przez Gieneq
  • Lubię! 1
  • Pomogłeś! 1
Link to post
Share on other sites

@Gieneq Dzięki, poprawiłem. Teraz działa! ale zastanawia mnie punkt 1

2. faktycznie zapomniałem w ostatniej wersji układu, dlatego mniejszy A.

3. Tu mój błąd od początku 105 zamiast 103 używałem 

4. Wróciłem do 10k

z 1. mam problem, w wersji, która teraz działa mam z 3 nóżki ne555 przez rezystor 330 na anodę LEDa, a Katodę na GND. Nie tak jak na schemacie 😐 ale układ działa i jeszcze z ciekawostek bo sprawdzałem specjalnie wszystkie elementy. W jednej 104 zamiast 100nF jest 50nF, już wymieniona na nową.

IMG_20190701_155718.jpg

  • Lubię! 1
Link to post
Share on other sites

@szon super, że układ już działa 🙂

Jeśli chodzi o punkt pierwszy to podłącz układ tak jak na schemacie - też powinien działać. Świecąca dioda będzie wtedy oznaczała przeciwny stan na wyjściu układu (teraz u Ciebie reaguje na stan wysoki, a przy normalnym podłączeniu będzie reagowała na stan niski). Więcej o tym poczytasz jeszcze w kursie Techniki Cyfrowej. Jeśli chodzi o kondensator to przyczyn może być wiele. Po pierwsze, pomiar małych pojemności jest dość trudny i łatwo może wkraść się błąd. Po drugie, zwyczajnie mógł się trafić jakiś uszkodzony egzemplarz z wadą fabryczną. Takie sytuacje zdarzają się rzadko, ale są możliwe 😉

  • Lubię! 1
Link to post
Share on other sites

Cześć, czy wytłumaczysz mi dlaczego przy pewnych wartościach serwo ciągle drga, a w większości się ustawia do danego poziomu, stabilizuje i pozostaje nieruchome? Zastanawiało mnie to już przy konfiguracji modeli i w tym układzie jest identycznie.

 

Link to post
Share on other sites

@jordanj przyczyn jest kilka 😉 Po pierwsze to są bardzo popularne, małe i stosunkowo tanie serwomechanizmy, więc ich jakość jest akceptowalna, ale nie idealna. W droższym sprzęcie takie drgania mogą być mniejsze (lub może nie być ich wcale). Po drugie, serwo stara się ustawić zadaną przez Ciebie pozycję, ale nie zawsze mu się to udaje. Zdarzają się pozycje, których nie będzie ono w stanie osiągnąć np. przez niedoskonałości w mechanice lub elektronice. W takiej sytuacji powstają drgania, bo serwo próbuje nieskutecznie wcelować w dane położenie (a ciągle trafia za blisko/za daleko) więc tylko drży. Po trzecie, każde zakłócenie w tym układzie na płytce stykowej sprawia, że zmienia się sygnał na wyjściu NE555, który steruje serwem. Każde zakłócenie może więc powodować małe drgania. 

  • Lubię! 1
Link to post
Share on other sites
5 godzin temu, jas123 napisał:

Gdy podłącze 9v to wibruje / drga .

Gdzie i w jaki sposób podłączasz 9V? Ten układ powinien być zasilany z 6V, ponieważ serwomechanizmy nie są przystosowane do pracy z 9V. Najzwyczajniej mogłeś spalić swój serwomechanizm.

  • Lubię! 1
Link to post
Share on other sites

Cześć, mam problem z poprawnym uruchomieniem układu z serwomechanizmem, serwo w ogóle się nie rusza. Generalnie składałem go już chyba z 4 razy od nowa, myśląc, że może coś źle podłączyłem, ale problem najwyraźniej tkwi gdzieś indziej. Nie potrafię sam dostrzec tej 'usterki', będę wdzięczny za pomoc. 😄

I w gwoli ścisłości, potencjometr jest podłączony równolegle z 6,8K aby zmienić jego przedział oporu z 0-20k do 0-5k, tylko taki miałem na składzie, więc musiałem kombinować. 😅

A całość jest zasilana z 5V a nie z 6V,  ale to raczej nie jest przyczyną zaistniałego problemu, ponieważ przy próbach z 6V sytuacja wyglądała tak samo.

71497634_505338880014916_9047631776217825280_n.jpg 71745865_466938880571303_4119993352017936384_n.jpg 71789473_696392074171936_7612488434447286272_n.jpg

Link to post
Share on other sites

@Mike84 czy przykład jest składany z elementów, które były w zestawie do tego kursu czy wszystkie dobierałeś samodzielnie? Ten układ raczej nie powinien sprawiać problemów - musi działać 😉 Jest więc duża szansa, że problem leży np. w złych elementach. Inne ćwiczenia z NE555 działały poprawnie? Widzę, że masz zestaw do kursu Arduino - testowałeś serwo w połączeniu z Arduino, kręci się bez problemów?

  • Pomogłeś! 1
Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.