Skocz do zawartości

Kurs elektroniki II - #7 - scalony odbiornik podczerwieni


Pomocna odpowiedź

Platinu, witam na forum 🙂 Przyciąłem i zmniejszyłem trochę Twoje zdjęcia - teraz zamiast 9MB ważą 200kB. To tak tylko informacyjnie, na przyszłość warto zmniejszyć pliki przed wysłaniem.

Jeśli chodzi o Twój układ to mam wrażenie, że jednak podłączyłeś go źle. Zwróć uwagę na podłączenie odbiornika TSOP na naszych zdjęciach. Zawróć uwagę na opis odbiornika z kursu: "Patrząc od przodu, po lewej pierwsza jest masa, środkowa nóżka to dodatnie zasilanie, a skrajne prawe wyprowadzenie to wyjście naszego odbiornika". U Ciebie dioda podłączona jest do nóżki środkowej, a powinna być do skrajnej. Podłączyłeś układ zapewne tak jak jest to na schemacie (tam środkowa to wyjście). Pamiętaj jednak, że schemat to jedynie symboliczne przedstawienie całego obwodu. To jak dokładnie rozmieszczone są wyprowadzenia trzeba sprawdzić w nocie katalogowej, co było wspomniane w kursie:

Link to post
Share on other sites

@jas123 wydaje mi się, że jednak błąd polega na błędnym połączeniu układu. Zerknij na post wyżej - udzieliłem tam porady w identycznej sytuacji. Zwróć uwagę na opis wyprowadzeń TSOPa z noty katalogowej - tego trzeba się trzymać. Opis wyprowadzeń na schemacie ideowym nie ma tutaj znaczenia i nie można się nim sugerować (to tylko symbol).

  • Pomogłeś! 1
Link to post
Share on other sites

@jas123 super, powodzenia w dalszych eksperymentach 😉 Trzeba zwracać uwagę na takie drobiazgi, bo często symbol na schemacie jest oderwany od rzeczywistości 😉

  • Lubię! 1
Link to post
Share on other sites

Witam, początkowo miałem problem z układem złożonym według podanego schematu, dioda wcale nie reagowała na działanie pilota. Uznałem, że sprawdzę napięcie zasilania odbiornika i okazało się, że wynosi 5,7V. Na szczęście wyczytałem z noty, że maksymalne napięcie które nie powinno uszkodzić układu wynosi 6V i faktycznie układ jak się później okazało był sprawny. W celu obniżenia napięcia zastosowałem zamiast rezystora 100Ohm rezystor 1k i układ zaczął działać jak powinien (wtedy spadek napięcia na rezystorze wyniósł 0,3V i napięcie spadło do 5,45V), w czasie testów nie wiem z jakiego powodu, ale i ten układ potrafił nie działać, wtedy sprawdziłem z ciekawości rezystor 10k w tym miejscu i układ działał prawidłowo (napięcie na zasilaniu odbiornika wynosiło wtedy ok. 3V, więc mieściło się w przedziale). Co ciekawe kiedy sprawdziłem jeszcze raz rezystory 1k i 100Ohm układ w obu przypadkach działał prawidłowo (mimo napięcia zasilania odbiornika wynoszącego 5,7V przy rezysotorze 100Ohm). Spadek napięcia na diodzie prostowniczej wynosił u mnie 0,6V, napięcie z koszyka z bateriami 6,4V. Do tego zmierzyłem prąd jaki pobierał mój odbiornik i było to 0,33mA (w nocie typowa wartość to 35mA). Dodam, że jestem począkującym i piszę tu tylko o swoich doświadczeniach, które mam nadzieję, że mogą pomóc przy podobnych problemach. 

  • Lubię! 1
Link to post
Share on other sites

Witam

Zmontowałem układ z odbiornikiem podczerwieni i przetestowałem sobie domowe piloty... przy okazji wyjaśnił mi się problem jednego z nich który wymagał bliskiej odległości od odbiornika. Okazuje się że faktycznie zamontowany w nim nadajnik IR ma bardzo niewielki kąt padania promieniowania podczerwonego a dodatkowo sam nadajnik jest małej mocy. Ciekawe ćwiczenie i można było sprawdzić jak rozchodzi się promieniowanie podczerwone w domowych warunkach i z różnych odległości (zjawiska takie jak odbicie, załamanie promieniowania, itd). Odkryłem jednak coś czego do końca nie rozumiem. Gdy miałem włączony układ i pracowałem na laptopie zauważyłem że gdy w pobliżu odbiornika znajdzie się myszka bezprzewodowa zaczyna świecić dioda. Wydawało mi się że komunikacja myszka optyczna - PC odbywa się po Bluetooth, jednak ewidentnie obserwuje odbieranie sygnału przez zmontowany odbiornik. Czy to jakieś zakłócenia? Dodam że najlepiej widać świecenie jak podniosę myszkę i podstawię część optyczną pod odbiornik. Machając palcem między nimi uaktywniam myszkę i wtedy układ coś odbiera.

  • Lubię! 1
Link to post
Share on other sites

Pamiętaj o tym, że o ile komunikacja myszki odbywa się po bt (czy nawet kablu), o tyle same przesunięcia myszki odczytywane są poprzez detekcję światła odbitego od stołu, przy czym moc diody oświetlającej w myszce jest stosunkowo duża. Światło odbija się od podłoża, gdzieś tam świeci na boki... a odbiornik po prostu wykrywa jakiś modulowany sygnał którego co prawda nie rozumie (bo żadnej informacji tam nie ma), ale daje znać że coś odbiera. Przy czym filtry podczerwieni w odbiorniku przepuszczają częściowo czerwone światło diody.

Proponuję jako ćwiczenie skonstruowanie nadajnika, i spróbowanie zastosowania w nim zamiast diody na podczerwień zwykłych diod led, a nawet czerwonej diody laserowej.

  • Lubię! 1
  • Pomogłeś! 1
Link to post
Share on other sites

Witam,

chciałbym opisać moją dzisiejszą przygodę z elektroniką.

Otóż złożyłem układ taki jak na schemacie i niezwłocznie przystąpiłem do testowania pilota. Niestety dioda wcale nie świeciła! Zacząłem więc szukać błędów w połączeniach, bo może tam coś jest źle. Niestety nic to nie pomogło. Pomyślałem, że może układ działa, a wina leży po stronie pilota. Zmierzyłem więc napięcie na obu bateriach od pilota. Pierwsza miała napięcie 1.38V, czyli trochę rozładowana, za to druga miała (pomijając to, że wyglądała, jakby przeżyła bombardowanie jądrowe)  zaledwie 0.4V. Jako że nie posiadałem żadnej takiej baterii, a godzina już dawno poźna, w głowie pojawił mi się plan.

Używając rezystorów jako dzielnika napięcia, chciałem za pomocą dużej baterii 9V zasilić mój nieszczęsny pilot. Prawie idealne okazały się rezystory 330 oraz 1k - mierząc napięcie od dodatniego wyjścia baterii i końca rezystora 330 uzyskałem ok. 1.8V, czyli mniej więcej tyle, żeby zastąpić zużytą baterię i zrekompensować lekkie rozładowanie tej drugiej. 

IMG_20200217_231937.thumb.jpg.cb389cf65f08e35c2e8d6eb1d099700d.jpg

Po uzyskaniu odpowiedniego napięcia, zacząłem kombinować jakby tu podłączyć moje "dzieło". Jako, że nie jestem żadnym mistrzem montażu ani żadną złotą rączką (a raczej przeciwieństwem tego), to, ignorując wszelkie zasady BHP, bohatersko wcisnąłem przewody w zawinięte druciki w pilocie.

IMG_20200217_232000.thumb.jpg.8591c2a126bede9f23ba3b1cd1ebef6a.jpg

Po upewnieniu się, że przewody siedzą w miarę mocno, zmierzyłem miernikiem napięcie od plusa baterii do minusa  mojego dzielnika napięć, czyli pomarańczowego przewodu. Miernik wskazywał 3.17V. W sumie nawet trochę się zdziwiłem, że to działa, bo nie wiązałem z tym większych nadziei😅

Jako że miałem już, przynajmniej teoretycznie, działający pilot, pozostało mi tylko go wypróbować. Jakaż była moja radość, gdy dioda zamigotała, gdy wcisnąłem przycisk!

Może to nic wielkiego, ale dopiero od niedawna uczę się elektroniki "sam z siebie" i to był pierwszy raz, kiedy użyłem dzielnika napięć w praktyce🙃

 

  • Lubię! 1
Link to post
Share on other sites

@MateoS07 Witam na forum!

Pomysł naprawdę fiznezyjny, nie wiem czy by mi przyszedł do głowy, ale jak działa to znaczy że się da! 😄 Udał się dla tego, że pilot raczej nie pobiera dużych prądów - w ten sposób na pewno nie zrobisz ładowarki 5V z baterii 9V i 2 rezystorów, bo szybko się przegrzeją i spalą. Warto też brać pod uwagę, że podłączona bateria ma inne napięcie niż gdy mierzysz ją niepodłączoną.

Niemniej powodzenia w dalszych eksperymentach - fajnie, że starasz się kombinować jak co ruszyć, to dobra cecha 🙂 

  • Lubię! 1
Link to post
Share on other sites
8 godzin temu, Gieneq napisał:

Niemniej powodzenia w dalszych eksperymentach - fajnie, że starasz się kombinować jak co ruszyć, to dobra cecha  

Dzisiaj po śniadaniu chciałem przetestować mój nietypowo zasilany pilot. Niestety, po próbach włączenia nim telewizora, okazało się, że nie działa (mimo, że wykrywacz poczerwieni na niego reagował).

W międzyczasie tamta zużyta bateria zmartwychwstała i zaczęła jakimś cudem działać na tyle, żeby zasilić pilot. Wpadłem na pomysł, żeby zamiast diody wstawić buzzer. Gdy naciskałem przyciski na pilocie, buzzer fajnie piszczał, w rytmie, w jakim wcześniej świeciła dioda. Gdy potem znów zasiliłem pilot moim dzielnikiem napięć, buzzer też piszczał, ale wyraźnie słabiej. W tym wypadku postanowiłem, że zasilę go nie napięciem spomiędzy rezystora 330, tylko z rezystora 1k. No cóż, najwyżej pilot się spali czy coś. Zmierzyłem napięcie jakie dawał razem z drugą baterią i wyszło, 6.8V. Za to, gdy nacisnąłem przycisk na pilocie buzzer zapiszczał tak samo jak wcześniej z bateriami. Szybko pobiegłem do pokoju sprawdzić, czy może tym razem uda się włączyć telewizor. Udało się, działało bez zarzutu!

Swoją drogą ciekaw jestem, dlaczego pilot nie działał przy 3.2V (mimo, że z bateriami działał przy 1.8V, bo mierzyłem), jeśli powinno się go zasilać prawidłowo (chyba) 3V, bo tyle dają dwie "świeże" baterie, którymi powinien być zasilany. Za to zadziałał z napięciem blisko 7V.

Edytowano przez MateoS07
Link to post
Share on other sites

@wuugy Cześć fajnie że trafiłeś na nasze forum 🙂 

A dzieję się tak gdy wetkniesz kabelki w płytkę stykową? Możliwe że układ tak się zachowuje gdy zasilanie jest niestabilne/dopiero podłączone. A posługujesz się podzespołami z zestawu do kursu?

Link to post
Share on other sites

Podzespoły pochodzą z zestawu. Dzieje się tak właśnie w momencie wetknięcia kabelka w płytkę. Układ działa tzn reaguje na sygnały z pilota tylko zastanawiało mnie dlaczego po podłączeniu zasilania do płytki stykowej przez chwilę dioda błyśnie. Ale skoro może się tak zdarzyć to ok. Dzięki za odpowiedź

 

  • Lubię! 1
Link to post
Share on other sites
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.