Skocz do zawartości

[Dla początkujących] Światłolub. Jak zrobić robota? - Od żółtodzioba do pierwszego robota


Nawyk

Pomocna odpowiedź

Witam.

Wykonałem robota światłoluba zgodnie z instrukcją zamieszczoną na tym forum. Wszystko fajnie jeździ za światłem lecz według mojego uznania moje fototranzystory wychwytuja zbyt silnie światło ponieważ w porze dziennej po załączeniu robota silniki pracuja nieustannie.

I teraz przejdę do sedna . Czytając poprzednie posty wywnioskowałem że msuze zmienić moje rezystory 100kOHM. Tylko pada pytanie na jakie ? Myślę ,że łatwiej byłoby poprostu wbudować tam dwa potencjometry 100kOHM regulujące prace fototranzystorów. czy tak przerobiony schemat będzie prawidłowy ?

Pozdrawiam i życzę miłego weekendu.

Link do komentarza
Share on other sites

czy tak przerobiony schemat będzie prawidłowy ?

Nie będzie prawidłowy, podłączyłeś potencjometr jak zwykły rezystor i tak też będzie działał. Powinieneś podłączyć z jednej strony do ślizgacza (czyli środkowej nóżki potencjometru) a z drugiej strony do dowolnego z 2 pozostałych pinów potencjometru.

Aby zmniejszyć czułość na światło widzialne można dać fototranzystory w ciemnej obudowie, albo założyć na nie czarną koszulkę termokurczliwą, tak aby mniej światła wpadało z przodu przez soczewkę.

Link do komentarza
Share on other sites

Witam

Mam pytanie, czy do budowy tego robota mogę użyć przekładni podwójnej z silnikami o takich parametrach:

standardowe napięcie zasilania : 3V

Pobór prądu bez obciążenia dla 3V : 150mA

Prąd maksymalny dla 3V : 2100 mA

Pytam bo w artykule jest mowa, że przy napięciu ok. 5v i prądzie powyżej 600mA,
istnieje możliwość spalenia układu L293D.

Link do komentarza
Share on other sites

Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

Mostek przy udarze wytrzyma do 1,2A na kanał np. przy ruszaniu, ale przy takich silnikach podejrzewam, że ta wartość i tak będzie przekroczona... Poza tym pozostaje kwestia zasilania - skoro silniki są na 3V, a wg dokumentacji L293 napięcie zasilania musi być wyższe od napięcia zasilania logiki (jeśli dobrze pamiętam), to trudno byłoby to zrobić w "elegancki" sposób.

Link do komentarza
Share on other sites

Witam, jak się domyślacie widząc ten komentarz ze mam jakiś problem związany z tym mini robotem, no i sie nie mylicie. Mam o tuż taki problem

pierwszy z fotorezystorów działa poprawnie tak jak nalezy( odpowiednio współgra z silnikiem sterowny przez układ), natomiast ten drugi działa tak jakby na opak do tego pierwszego czyli jezeli zacieniam fotorezystor to sie włącza silnik za ktory odpowiada a powinien sie wyłaczyć i kiedy wyłączę robota nie zmieniając nic w układzie i z powrotem go załączę to czasem jest tak ze silnik zaczyna krecic sie w druga strone kiedy drugi kreci sie poprawnie i jest tez taka sytuacja że w ogóle nie reaguje na zmianę oświetlenia i jak by było mało tego to kiedy silniczek z prawej strony jest na chodzie i poswiece na odpowiadajacy mu fotorezystor to sie wyłacza.

Ogólnie rzecz biorąc to ja tego nie rozumiem zmieniłem już parę fotorezystorów(zmieniłem biegunowość i tez nic)rożne wartości rezystorów, napięcie +/-5v akumulator, Serwo Tower Pro Micro SG90 przerobione i raczej wewnątrz żadnych oporów nie mają z nimi jest okey,

Może macie jakieś pomysły co jest nie tak, no bo juz niestety od wylutowywania i wlutowywania ścieżki mi sie niszczą 😉 Jak nie będzie wiadomo to zrobie najlepiej od nowa , lm293 jest sprawny waszym zdaniem?

Link do komentarza
Share on other sites

Jeśli silnik działa, kiedy jest ciemno, a wyłącza się jak jest jasno, to spróbuj zamienić fototranzystor z sąsiadującym opornikiem (na schemacie T1 z R1 lub T2 z R2, zależy, który kanał nie działa).

Jeśli silnik będzie się kręcił w złą stronę, po prostu podłącz go odwrotnie.

Link do komentarza
Share on other sites

Dobra, spróbuje zamienić rezystor z fotorezystorem może coś da. A silnik kiedy zamknę obw. kreci się w przód, kiedy wył. i znowu wł. to czasem bez żadnej zmiany w układzie kreci się w stronę przeciwną ale nie zauważyłem od czego to zależy.

Link do komentarza
Share on other sites

No i zadziałało 😉 Udało mi sie to na płytce stykowej jednak na początku zachowywał się podobnie jak przedtem, nie wiem co jest do końca tego przyczyna no ale działa tak jak powinien, muszę tylko skalibrować fotorezystory odpowiednim rezystorem aby działały podobnie na takie samo natężenie światła, jtr zlutuje to na płytce prototypowej bo dzisiej po 7 h szukania błędu mam już dość 😉

dzięki za podpowiedzi 😉

__________

Komentarz dodany przez: Bobby

Pisz po polsku - "jtr".

Link do komentarza
Share on other sites

Nie działa dla mnie żadna kolejna część, do której są podane linki w temacie, jeszcze wczoraj było dobrze, a teraz to nawet schematu nie mogę znaleźć.

Link do komentarza
Share on other sites

Bądź aktywny - zaloguj się lub utwórz konto!

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto w ~20 sekund!

Zarejestruj nowe konto, to proste!

Zarejestruj się »

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się »
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.